[Solved+Issue] Scrollbar handle missing from AOO on Cinnamon

Issues with installing under all Linux Distributions

[Solved+Issue] Scrollbar handle missing from AOO on Cinnamon

Postby mwx » Wed May 28, 2014 10:04 am

HI

I found on the Cinnamon desktop that the scrollbar handle was missing from OpenOffice writer.
After following loads of tips and advice that got me nowhere I finally stumbled upon the simple solution.
Firstly, this is not a Cinnamon problem and its not a OpenOffice problem
The problem is with the theme, actually its not the choice of theme either.
The problem is with the setting for the theme for the Controls.

So heres the solution:
(1) Use whatever theme you like
(2) open the settings for cinnamon (usually the screwdriver/spanner icon on the main icon toolbar in my case on the far left of the screen when I click on the application popup)
(3) choose Themes
(4) ignore "Installed" tab and go for the "Other settings" tab
(5) Change the theme for Controls to "Adwaita"

Voila.
No reset of gnome required.

I hope this saves someone the hours and days it took me to solve.
Last edited by mwx on Wed May 28, 2014 11:30 am, edited 1 time in total.
mwx
 
Posts: 1
Joined: Wed May 28, 2014 9:49 am

Re: Scrollbar handle missing in openoffice on cinnamon deskt

Postby John_Ha » Wed May 28, 2014 10:58 am

mwx
Welcome to the forum. Thank you for posting that - it will help someone. Could I ask you to edit your post title with [Hint]. Thanks
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7901
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Hint] Scrollbar handle missing from openoffice on cinna

Postby Hagar Delest » Wed May 28, 2014 10:03 pm

There is an issue filed for that (121627), see: [Issue] Scrollbar glitch with AOO 4.1 on some GTK themes.
LibreOffice 6.4.6 on Xubuntu 20.04 and Windows 10.
User avatar
Hagar Delest
Moderator
 
Posts: 29084
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved+Issue] Scrollbar handle missing from AOO on Cinn

Postby k1ypp » Tue Jun 02, 2015 7:38 pm

I'm seeing a variation of this problem as well. Running on a Toshiba NB305, Linux Mint 17.1. In OO Impress and Calc, the scroll bar handles are missing. The mouse wheel does allow scrolling, but it is frustrating not having the handle.

I've tried all the controls, and the only one that it does show up in is the Controls: HighContrast, which is extremely ugly. I've tried other themes but no go. Is there any way to add more controls choices? The only choices are Adwaita, HighContrast and a bunch of different colored Mint-X-color versions.

Changing themes doesn't seem to offer any other controls choices, I thought it might.

Thanks

Dennis
OpenOffice 4.1.0 on Windows 7 and XP
k1ypp
 
Posts: 42
Joined: Tue Aug 16, 2011 5:03 am
Location: Sarasota, Florida

Re: [Solved+Issue] Scrollbar handle missing from AOO on Cinn

Postby Hagar Delest » Tue Jun 02, 2015 9:36 pm

Perhaps the themes you've tried are too close from each others.

I use a Numix theme on xubuntu 14.10 and it works fine.
LibreOffice 6.4.6 on Xubuntu 20.04 and Windows 10.
User avatar
Hagar Delest
Moderator
 
Posts: 29084
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved+Issue] Scrollbar handle missing from AOO on Cinn

Postby RoryOF » Tue Jun 02, 2015 9:38 pm

I use Greybird on Xubuntu 15.04 and it is OK.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31738
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved+Issue] Scrollbar handle missing from AOO on Cinn

Postby Bill » Wed Jun 03, 2015 12:55 am

@ k1ypp: Are you using AOO 4.1.0? The bug report indicates that this was a bug which was confirmed in AOO 4.1.0-dev and was fixed in AOO 4.1.1.
AOO 4.1.8 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 8008
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved+Issue] Scrollbar handle missing from AOO on Cinn

Postby k1ypp » Wed Jun 03, 2015 3:52 am

Thank you Bill. I intentionally avoided installing 4.1.1 because of other Impress issues that I ran into. I don't recall what it was now, but I think 4.1.1 didn't load my videos for the presentation correctly.

Guess I'll have to live with no handle on the scroll bar. I removed LibreOffice and installed OpenOffice because I couldn't get LO to load any videos properly. It kept complaining about the video format not being compatible, regardless of which format I chose. At least I can live with this problem until it gets fixed in a future release, if it ever does.

Thanks again for the quick response and we can close my problem out.

Dennis
OpenOffice 4.1.0 on Windows 7 and XP
k1ypp
 
Posts: 42
Joined: Tue Aug 16, 2011 5:03 am
Location: Sarasota, Florida


Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests