[Solved] Running OpenOffice after Yum update

Issues with installing under all Linux Distributions

[Solved] Running OpenOffice after Yum update

Postby lessharpe » Wed Jun 18, 2008 8:30 pm

I have just updated my machine using Yum and a lot of OpenOffice updates were included. I am running Fedora core 7. On trying to start OpenOffice after the update I get an error message which days:- "The application cannot be started. The user interface language cannot be determined."

How do I solve this problem please/

Cheers,


Les
Last edited by Hagar Delest on Mon Jun 23, 2008 11:51 am, edited 1 time in total.
Reason: tagged the thread as Solved.
OOo 2.3.X on Fedora other
lessharpe
 
Posts: 6
Joined: Wed Jun 18, 2008 8:19 pm

Re: Running OpenOffice after Yum update

Postby Villeroy » Wed Jun 18, 2008 8:47 pm

Shut down the office completely and rename your office profile. Usually it is directory ~/.openoffice.org2/ or something like that. The directory will be recreated from scratch when you start the office.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28149
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Running OpenOffice after Yum update

Postby lessharpe » Thu Jun 19, 2008 2:30 am

I have done mv .openoffice.org2.0 .openoffice.org2.0.old but I get the same problem on trying to start the program. What would you suggest now please?

Cheers,


Les.
OOo 2.3.X on Fedora other
lessharpe
 
Posts: 6
Joined: Wed Jun 18, 2008 8:19 pm

Re: Running OpenOffice after Yum update

Postby acknak » Thu Jun 19, 2008 3:17 am

Well, since you're using yum, you must be updating with Fedora packages, right? Except I thought F7 was past end-of-life, so it won't get updates any more.

Anyway, if you're not installing the OO.org packages, I would suggest that you at least try to report the problem to whoever is distributing the packages, or ask on the Fedora mailing list or forum.

If you can't get any help from the people who made the packages you installed, and you have to try and figure out the problem yourself, I would try creating a new user account on your system, and trying OOo when logged in as that user. That should give you a "clean" application environment.

You can also try running OOo from a terminal, to see if any other messages are printed on the terminal.

If that provides no further clues, you can try running OOo with a command like this:
$ LANG=en_US.UTF-8 ooffice

and see if that helps.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Running OpenOffice after Yum update

Postby lessharpe » Thu Jun 19, 2008 5:44 pm

I have uninstalled OpenOffice using yum and re-installed the packages I previously had also via yum.

I have tried a couple of the languages that can be selected at login time via the graphical login screen - "system default", "English-US" and "last language used".

I have renamed my profile directory ~/.openoffice.org2.0 as ~/.openoffice.org2.0.old so that it could re-generate each time.

I have re-booted after each change (a la Windows!).

OpenOffice still will not run. I still get the error message "The application cannot be started. The user interface language cannot be determined."

I have also tried "setenv....." as suggested in previous post.

Anyone got any ideas please?

Cheers,


Les.
OOo 2.3.X on Fedora other
lessharpe
 
Posts: 6
Joined: Wed Jun 18, 2008 8:19 pm

Re: Running OpenOffice after Yum update

Postby Hagar Delest » Thu Jun 19, 2008 5:58 pm

Can you check the rights on the OOo profile folders and sub-folders? See here: Installation Problem - User interface language.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28815
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Running OpenOffice after Yum update

Postby lessharpe » Thu Jun 19, 2008 8:21 pm

Thank you for the new idea/indication. It is late here now. I will try to act on this tomorrow and will let you know the outcome.

Cheers,


Les.
OOo 2.3.X on Fedora other
lessharpe
 
Posts: 6
Joined: Wed Jun 18, 2008 8:19 pm

Re: Running OpenOffice after Yum update

Postby lessharpe » Sun Jun 22, 2008 12:56 pm

I have tried everything that has been suggested over the past couple of days. I have changed various permissions and have piece by piece uninstalled components to try pinpoint just what is causing the problem. I finally get to no installed components whereupon the error message changes to tell me that there is no application to start. I have uninstalled and re-installed OpenOffice and I still get the same error message:-
"The application cannot be started. The user interface language cannot be determined."
I think I will have to consider another word processing suite.

Cheers,


Les.
OOo 2.3.X on Fedora other
lessharpe
 
Posts: 6
Joined: Wed Jun 18, 2008 8:19 pm

Re: Running OpenOffice after Yum update

Postby Villeroy » Sun Jun 22, 2008 1:34 pm

This is how it works on my system:
I use the original build by Sun under Ubuntu. My system locale is German, the office is the unlocalized US version with an additional German language pack. So I can set user interface language "Default", German or US-English in the OOo options.
With OOo interface language "Default", OOo reads my German system setup and applies the German language pack. I can set my system language to US and OOo will start in English
Code: Select all   Expand viewCollapse view
$ cd /opt/openoffice.org2.4/program/
$ LANG=en_US.UTF-8 ./soffice
[starts without error]

I can set another system locale, not supported by OOo:
Code: Select all   Expand viewCollapse view
LANG=es_ES.UTF-8 ./soffice
[starts without error]

es_ES.UTF-8 is an installed system locale, but I have no language pack for Spanish. The office starts with it's original install language en-US.
Then I can set an invalid (not installed) system locale
Code: Select all   Expand viewCollapse view
LANG=fr_FR.UTF-8 ./soffice
I18N: Operating system doesn't support locale ""
I18N: Operating system doesn't support locale "en_US"

but the office starts anyway using it's original install language en-US.

You should have a look at your package manager. May be your distributor's office needs to add at least one language pack explicitly. Check the integrity of the installed office packages (rpm can do this). Check the Fedora forums for your problem. Normally your office should simply run.
You may prefer the original RPMs provided by Sun http://download.openoffice.org/index.html

For simple word processing I recommend AbiWord.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28149
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Running OpenOffice after Yum update

Postby lessharpe » Mon Jun 23, 2008 11:28 am

This problem has been solved! It took the services of a top-notch professional tech lead programmer. I am lucky enough to be able to call on his services when things are desperate.
We started from scratch and installed the OpenOffice programs from Yum - which was from whence the problem came after an update. I have had non-loading errors with Thunderbird after updating via Yum. It came down to a matter of permissions (as did the Thunderbird difficulties) but it took a long time to isolate the precise problem. What we came up with was as a result of a "last ditch forlorn hope" of finding something somewhere. We ran:-

cd /usr/lib/openoffice
ls -alR|grep -- ---

This revealed a number of files bearing no permissions at all. We assume that when the program was invoked it came across these files and just baled out with whatever error message it felt was appropriate. This was why the message was of no help in pin-pointing the problem. We gave the files what seemed appropriate permissions and the program ran.

It happened then that the PDF and Latex packages did not work. This was simply solved by eliminating them. I don't need to produce PDF documents and I use LYX for serious writing when latex is needed.

This problem and its solution may be specific to my OS and possibly even just my machine.

I do not intend to upgrade to OpenOffice 2.4 nor to Firefox 3.0 until I move to Fedora 9. That will not be until that has proved itself to be stable. Being at the cutting edge with either programs or operating systems is not conducive to reliability. It's fun if computing is a hobby but I am simply a user although I have had to learn enough to keep things going and within reach financially. Therefore I do not use Windows or other Microsoft products.

Cheers,


Les.
OOo 2.3.X on Fedora other
lessharpe
 
Posts: 6
Joined: Wed Jun 18, 2008 8:19 pm

Re: [Solved] Running OpenOffice after Yum update

Postby krabah » Wed Aug 11, 2010 7:52 pm

On Ubuntu 10.04 LTS, if you're having trouble with starting OpenOffice.Org 3.2, and getting error:

"The application cannot be started. The user interface language cannot be determined."

Then do the following:

$ sudo -i
# LAN=en_US.UTF-8 ooffice

This will start OpenOffice.Org

kefa rabah
OpenOffice 2.4 on Ubuntu 10,04
krabah
 
Posts: 1
Joined: Wed Aug 11, 2010 7:44 pm

Re: [Solved] Running OpenOffice after Yum update

Postby Hagar Delest » Wed Aug 11, 2010 8:45 pm

Not a very good idea to run an application as root!
GNU/Linux is very good at rights management, running a non administrative application as root defeats the point.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28815
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests