Constant Disk Access and CPU Activity

Issues with installing under all Linux Distributions

Constant Disk Access and CPU Activity

Postby RayGarrison » Fri Apr 05, 2013 1:25 am

I just installed OpenOffice 3.4.1 (A00341m1 build 9593 Rev 1372282) on Lubuntu 12.10 (LXDE) , computer is a Dell Optiplex Pentium 4 3GHz, 4 gigs RAM, Samsung ATA hard drive

When I open a document (any type) I get constant disk access, monitor shows about 200K/second, and CPU load is over 50%. I can hear the disk thumping away, and the fan is running constantly as a result of the CPU load. Everything seems work okay in OO - no crashes, no problem saving / loading files, etc. Lots of available memory, no swap in use... top shows soffice.bin consuming about 42% of CPU, Xorg with another 12%, and java bouncing between 6 and 8%.

Any idea what might be causing the constant I/O activity and the heavy CPU load?

Thanks,
Ray Garrison
OpenOffice 3.4.1 on Lubuntu 12.10 LXDE
RayGarrison
 
Posts: 1
Joined: Fri Apr 05, 2013 1:13 am

Re: Constant Disk Access and CPU Activity

Postby acknak » Fri Apr 05, 2013 2:09 am

Greetings and welcome to the community forum!

Does this always happen--even right after a cold boot?

I've seen OOo get into some state where it constantly runs the cpu, but it stops if I exit OOo (including quickstarter) and restart. I've never figured out why it happens.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Constant Disk Access and CPU Activity

Postby Hagar Delest » Fri Apr 05, 2013 8:20 am

Was it a first install or an upgrade?
You can try to reset your OpenOffice user profile, in case an old setting is confusing AOO.

Never experienced such behavior on my Ubuntu 12.10 (or older) laptop (64bit). I use Gnome 3.

Please add [Solved] at the beginning of the title in your first post (top of the topic) with the edit button if your issue has been fixed.
AOO 4.1.5 on Xubuntu 18.04 and on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28074
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Constant Disk Access and CPU Activity

Postby RoryOF » Fri Apr 05, 2013 8:31 am

I'm using Ubuntu 12.04 32 bit with Gnome Classic desktop for editing a large (300 page) text file and have not noticed any CPU hogging running on an old 4GB Dell dimension (P4 3GHz, rescued from a dumpster) in a five or six hour session. I normally only run two other concurrent applications, Sylpheed (email) and Firefox (browser), with sometimes System Update when it cuts in. I have two Lubuntu laptops used for presentations and (rarely) for travelling edits and again have not noticed any CPU loading (same usage configuration as above).

Are you running a 32 or 64 bit version of the OS?
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 26693
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Constant Disk Access and CPU Activity

Postby RoryOF » Fri Apr 05, 2013 11:04 am

I've just had AOO 3.4.1 running on the above configuration for two hours, along with email, browser and System Monitor.. Only OpenOffice CPU 100% is sometimes when it does a repaginate; OpenOffice memory usage is stable around 65-70 MB.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 26693
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Constant Disk Access and CPU Activity

Postby stdout » Mon May 06, 2013 6:48 pm

Hi. I have the similar issue on Ubuntu 12.10 (Unity,3.5.0-28-generic x86_64) with 2 versions of LibreOffice: 3.6.2 (bundled with Ubuntu) and 4.0.2.2 (latest official deb package).
Symptoms: CPU load ~20% and ~50 K/s disk activity (HDD is noisy and HDD led is blinking);
How to reproduce: open Calc, enter any data, copy/paste it.
On Windows 7 Calc does not produce this invalid activity, but it can hung after multiple copy/paste operations.

Also sometimes Calc randomly terminates with "error 4 in libsclo.so" exception. I do not understand how to reproduce this problem - looks like it depends on some another running windows/processes.
UPD:Profile reset does not help.
Yet another symptom of this issue: GUI constantly shows blinking progress bar (like during document saving), it is blinking too fast to read operation description, possibly it is "Load document".
Last edited by stdout on Mon May 06, 2013 7:37 pm, edited 1 time in total.
LibreOffice 4.0.2.2 on Ubuntu 12.10 x64 (3.5.0-28) and Windows 7. Dell i7 laptop.
stdout
 
Posts: 1
Joined: Mon May 06, 2013 6:00 pm

Re: Constant Disk Access and CPU Activity

Postby RoryOF » Mon May 06, 2013 7:10 pm

This may be an Ubuntu problem; Ubuntu does not handle fans/cooling as well as Windows. I suggest you try ubuntuforums.org to see have they a fix for over-running fans.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 26693
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests