doesn't open document

Issues with installing under all Linux Distributions doesn't open document

Postby xso » Wed Dec 07, 2011 8:26 pm


I'm working on Ubuntu 10.04.3 LTS, Word Processor Version: 1:3.2.0-7ubuntu4.2

I'm having troubles opening my thesis, a .doc document created with OpenOffice, I hope you can help me!

yesterday, as usual, I saved the document in .doc format (97/2000/XP), but I'm unable to open it, and moreover its dimension is too big (4.2 MB, too much for 20 pages).
Apparently something went wrong during the saving process since it opens any other .doc document.

If I try to open it from command line it said:

I18N: Operating system doesn't support locale "en_US"

So I tried several solutions I found on the internet:

$cd /usr/share/locale
$ln -s en_US.ISO8859-15 en_US

but nothing changed

i opened the file /var/lib/locales/supported.d/en and added the line "en_US UTF-8", then run:
dpkg-reconfigure locales

Now it doesn't generate the error anymore, but it doesn't open the file either!

I've tried also to open it with Microsoft office and it opens the "File conversion" window, asking to specify "the encoding that makes your document readable". I've tried all the encodings, without any success.

Do you have any suggestion?
OpenOffice Writer version 1:3.2.0-7ubuntu4.2 on Ubuntu 10.04.3 LTS
Posts: 1
Joined: Wed Dec 07, 2011 7:05 pm

Re: OpenOffice doesn't open document

Postby Robert Tucker » Wed Dec 07, 2011 10:22 pm

xso wrote:yesterday, as usual, I saved the document in .doc format (97/2000/XP)

One cannot recommend against this too strongly. See:


Always save in native .odt format and always keep a backup copy in that format and only try saving as .doc when document portability is required.
LibreOffice 6.x.x on Fedora 32 and Ubuntu 20.04 (Dual Boot)
User avatar
Robert Tucker
Posts: 1247
Joined: Mon Oct 08, 2007 1:34 am
Location: Manchester UK

Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests