OO 2.4 not running on EL4

Issues with installing under all Linux Distributions

OO 2.4 not running on EL4

Postby gbohannon » Thu Apr 10, 2008 8:21 pm

I have installed OO 2.4 on 2 different RH Enterprise Linux 4 systems and OO fails to start up on either one. I've tried the "unset SESSION_MANAGER" in "soffice" recommended in the install files, with no effect. I am installing using the setup script in this downloaded file: OOo_2.4.0_LinuxIntel_install_wJRE_en-US.tar.gz, and my systems are both current EL4 64-bit; both have 2 dual-core 64-bit processors (4 cores), one using Opterons and the other using Zeons. Nothing happens with I click on the new icons in the GNOME menu. Nothing seemingly related appears in the system logs. SELinux is disabled on one machine, and permissive on the other. In both cases I installed along side the original OO, which is version 1.1.5. That older version still works fine. Any suggestions?
Thanks for any help.
gbohannon
 
Posts: 4
Joined: Thu Apr 10, 2008 7:58 pm

Re: OO 2.4 not running on EL4

Postby acknak » Thu Apr 10, 2008 11:42 pm

Have you run OOo from a command line? What output do you get?
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17399
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: OO 2.4 not running on EL4

Postby gbohannon » Fri Apr 11, 2008 12:37 am

From an xterm window, I enter:

openoffice.org2.4

and it just hangs there until I press ctrl-c, even if I let it hang for several minutes. It does this whether I run as my own user account or as root.

While it is hanging, I can run "ps -ef | grep open" from another window and I see these:

/bin/sh /etc/openoffice.org2.4/program/soffice
/etc/openoffice.org2.4/program/javaldx
gbohannon
 
Posts: 4
Joined: Thu Apr 10, 2008 7:58 pm

Re: OO 2.4 not running on EL4

Postby acknak » Fri Apr 11, 2008 3:06 am

Hmm, maybe it's a javaldx problem, which I can't really help you with.

Try a search (box at upper right) for "javaldx". There have been several discussions lately about javaldx--maybe something in there will give you some ideas.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17399
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: OO 2.4 not running on EL4

Postby kingfisher » Fri Apr 11, 2008 3:25 am

You should have an executable in your path, usually in /usr/bin; check that you are using the correct name. You should also have a folder in /opt unless you have chosen a different location. The folders in /etc are links to folders elsewhere. Did you run the 'redhat' desktop integration rpm when installing the software?
OpenOffice 3.3 on PCLinuxOS. There are 3 kinds of people: those who can count and those who can't.
User avatar
kingfisher
Volunteer
 
Posts: 1860
Joined: Tue Nov 20, 2007 10:53 am

Re: OO 2.4 not running on EL4

Postby AndrewZ » Fri Apr 11, 2008 3:17 pm

Try
Code: Select all   Expand viewCollapse view
strace -f openoffice.org2.4 &>/tmp/ooo.log


Then, view the end of the log to see what it is doing.
<signature>
* Did you solve your problem? Do others a favor: Post the solution
* Visit OpenOffice.org Ninja (blog) and OpenOffice.org Ninja Wiki for news, previews, troubleshooting, etc.
</signature>
OOo 3.0.X on Fedora 9 + XP
User avatar
AndrewZ
Volunteer
 
Posts: 633
Joined: Mon Oct 08, 2007 1:25 am
Location: Colorado, USA

Re: OO 2.4 not running on EL4

Postby wichne » Fri Apr 11, 2008 9:51 pm

I am having a similar (identical?) problem. The strace shows start-up hanging in a loop of:

[pid 6953] gettimeofday({1207943307, 145984}, NULL) = 0
[pid 6953] futex(0xf7ffaec0, FUTEX_WAKE, 1) = 0
[pid 6953] clock_gettime(CLOCK_REALTIME, {1207943307, 146120000}) = 0
[pid 6953] futex(0x804b4a4, FUTEX_WAIT, 117, {9, 999864000}) = -1 ETIMEDOUT (Connection timed out)
[pid 6953] gettimeofday({1207943317, 147480}, NULL) = 0
[pid 6953] futex(0xf7ffaec0, FUTEX_WAKE, 1) = 0
[pid 6953] clock_gettime(CLOCK_REALTIME, {1207943317, 147604000}) = 0
[pid 6953] futex(0x804b4a4, FUTEX_WAIT, 119, {9, 999876000}) = -1 ETIMEDOUT (Connection timed out)
[pid 6953] gettimeofday({1207943327, 148927}, NULL) = 0
[pid 6953] futex(0xf7ffaec0, FUTEX_WAKE, 1) = 0
[pid 6953] clock_gettime(CLOCK_REALTIME, {1207943327, 149087000}) = 0
[pid 6953] futex(0x804b4a4, FUTEX_WAIT, 121, {9, 999840000}) = -1 ETIMEDOUT (Connection timed out)
etc...

After a quick Google seach, I see that futex was implemented and stabilized in kernel versions 2.5 and 2.6. I think I'm running 2.4 - that could be the problem?
thanks,
Bill
wichne
 
Posts: 4
Joined: Fri Apr 11, 2008 9:47 pm

Re: OO 2.4 not running on EL4

Postby AndrewZ » Fri Apr 11, 2008 10:11 pm

wichne wrote: I think I'm running 2.4


Run this command

Code: Select all   Expand viewCollapse view
uname -a
<signature>
* Did you solve your problem? Do others a favor: Post the solution
* Visit OpenOffice.org Ninja (blog) and OpenOffice.org Ninja Wiki for news, previews, troubleshooting, etc.
</signature>
OOo 3.0.X on Fedora 9 + XP
User avatar
AndrewZ
Volunteer
 
Posts: 633
Joined: Mon Oct 08, 2007 1:25 am
Location: Colorado, USA

Re: OO 2.4 not running on EL4

Postby wichne » Fri Apr 11, 2008 11:53 pm

My bad. I'm running 2.6.

$ uname -a
Linux WIES 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:29:47 EST 2005 x86_64 x86_64 x86_64 GNU/Linux
wichne
 
Posts: 4
Joined: Fri Apr 11, 2008 9:47 pm

Re: OO 2.4 not running on EL4

Postby gbohannon » Sat Apr 12, 2008 11:42 pm

Here's the uname:
uname -a
Linux fluffy.localdomain 2.6.9-67.0.7.ELsmp #1 SMP Wed Feb 27 04:47:23 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

As for the strace, I suspect that more than just the last few lines might be relevant, so I'm attaching the whole thing. Actually, the last few lines are probably due to my pressing ctrl-c to end the process.

Indeed, I think it is hung in a "futex" loop, because if I run the strace without piping the output to a file, the process first displays a lot of output as shown in the attachment, but then displays lines such as the following, waits a few seconds, then repeats these lines, and so on:

[pid 7044] gettimeofday({1208031740, 238082}, NULL) = 0
[pid 7044] futex(0xf7ffb140, FUTEX_WAKE, 1) = 0
[pid 7044] clock_gettime(CLOCK_REALTIME, {1208031740, 238166000}) = 0
[pid 7044] futex(0x804b964, FUTEX_WAIT, 23, {9, 999916000}

If using Windows, view the attachment with Wordpad, not Notepad, because it has Unix line endings.

Thanks for any help.
ooo.log.gz
(output from strace)
(114.39 KiB) Downloaded 63 times
gbohannon
 
Posts: 4
Joined: Thu Apr 10, 2008 7:58 pm

Re: OO 2.4 not running on EL4

Postby AndrewZ » Sun Apr 13, 2008 12:28 am

open("/lib64/libtermcap.so.2", O_RDONLY) = 3


Are you running 64-bit binary of OOo? Try the 32-bit instead. Also, for troubleshooting, remove any 64-bit Java.
<signature>
* Did you solve your problem? Do others a favor: Post the solution
* Visit OpenOffice.org Ninja (blog) and OpenOffice.org Ninja Wiki for news, previews, troubleshooting, etc.
</signature>
OOo 3.0.X on Fedora 9 + XP
User avatar
AndrewZ
Volunteer
 
Posts: 633
Joined: Mon Oct 08, 2007 1:25 am
Location: Colorado, USA

Re: OO 2.4 not running on EL4

Postby gbohannon » Sun Apr 13, 2008 8:18 pm

I just installed the Linux RPM from the OOo web site. Not sure whether it is 32-bit or 64-bit. As you pointed out, it does seem to be attempting to use a 64-bit library.
gbohannon
 
Posts: 4
Joined: Thu Apr 10, 2008 7:58 pm

Re: OO 2.4 not running on EL4

Postby AndrewZ » Sun Apr 13, 2008 9:27 pm

The OOo binaries on http://www.openoffice.org are 32-bit only, but it may be trying to access a 64-bit Java JRE. That is why I suggest you remove any 64-bit Java JREs for troubleshooting.
<signature>
* Did you solve your problem? Do others a favor: Post the solution
* Visit OpenOffice.org Ninja (blog) and OpenOffice.org Ninja Wiki for news, previews, troubleshooting, etc.
</signature>
OOo 3.0.X on Fedora 9 + XP
User avatar
AndrewZ
Volunteer
 
Posts: 633
Joined: Mon Oct 08, 2007 1:25 am
Location: Colorado, USA

Re: OO 2.4 not running on EL4

Postby jason Pollitt » Mon Aug 11, 2008 5:26 pm

I had a problem with the non redhat package as well the solution to get it running is to go into /usr/bin and update the OpenOffice.org2.4 script that launches OO I don't have the line with me it is at work but if oyu can't figure out what to change just

ls -ltr /usr/bin/open*
then
a more on the /usr/bin/openoffice.org-2.x file

and I should be able to tell you what to change
jason Pollitt
 
Posts: 1
Joined: Mon Aug 11, 2008 5:16 pm

Re: OO 2.4 not running on EL4

Postby jays0n » Wed Oct 01, 2008 9:41 pm

I was having this issue got to the end of this post was was stuck for a bit. I am running RedHat EL4 on a 64bit machine with a kernel 2.6.9-67.0.4.ELsmp

So it seemed to me that the startup script and the tools/options/java dialog were causing this and running each of those and looking at ps showed

"javaldx" was running and then launching "/usr/bin/gij"

So little searching for that got me another forum someplace with some similar issue and the suggestion to kill "gij" and it would write the config file and continue. This works. I had to do this twice however, as I was trying to configure OO to enable java and detect the JRE to use. So try this.

run the startup script for OO (soffice) and then get the pid for gij and kill it or do a "killall gij" (I had to do this twice here as it seems to launch a second instance when the first is killed or maybe due to my two processors or whatever, jsut kill it until OO continues its startup)

Then I wanted to configure the JRE to use so to do that, it is the same thing. choose tools/options/java and it will again be running "javaldx" then go to your shell again and do the kill gij thing (takes a couple of kills for me) then the thing will detect and continue.

this will create the java config file: ~/.openoffice.org2/user/config/javasettings_Linux_x86.xml and your on your way.

I am sure this is not the proper solutuion but it got me going when I had no more time to spend on this. Hope this is usefull info for someone.
j
OOo 2.4.X on Fedora other + debian linux, osx
jays0n
 
Posts: 1
Joined: Wed Oct 01, 2008 9:14 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 6 guests