Corrupted, where is autosave?

Issues with installing under all Linux Distributions

Corrupted, where is autosave?

Postby say.hello.to.anna » Fri Jul 15, 2011 6:05 pm

have established my VITAL finances calc doc was corrupted when my computer went to sleep (laptop, ubuntu power management issue) mid-auto save. My clever tech friend has helped establish it is corrupted and says I need to find out where the hidden auto-saves are. Any idea?


Love

Anna
OpenOffice.org 3.2.1
OOO320m19 (Build:9505)
ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1.1
Ubuntu 10.10
say.hello.to.anna
 
Posts: 2
Joined: Tue Jul 12, 2011 3:35 pm

Re: corrupted, where is autosave?

Postby TheGurkha » Fri Jul 15, 2011 9:23 pm

If something is vital - back it up. And that means back it up yourself, don't rely on auto-saves or other similar functions. You need to take responsibility for the safety of your data.

You might or might not be lucky - look in the backup folder: [Tutorial] The OOo user profile.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: corrupted, where is autosave?

Postby Hagar Delest » Sat Jul 16, 2011 11:32 am

It may be the same: 22 page term paper replaced with pound signs.

Check the temporary folder of the system (see in OOo Tools>Options>OOo>Paths). If there are folders like sgmlf.tmp with a file having the same name inside, make a copy of that file, rename it in .odt and cross your fingers.

Else, nothing to do I fear.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28919
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Corrupted, where is autosave?

Postby JapurTrench » Mon Jul 18, 2011 10:44 am

I'm afraid I have to follow the same vein:
Yesterday, checked an .ods doc, did some work, saved, closed and shut down system.
On restarting, discovered that said file did not open; in folder, file only had 1,5 K left.
(Less corrupted, more like completely annihilated)
Tried to follow tips in different communities (converting to .zip etc.) to no avail.
No archive left to restore...

Like a fool, only made an incomplete backup.

My question is:
What might have happened?
Why might this have happened? There was no power failure and I shut down normally.
I'll grant that my ubuntu Maverick doesn't seem to be rock stable, there are hibernation and other issues.

Where could the .ods file be?

Aargh. Feeling really dumb. Thanks for some advice.

JR
OpenOffice.org 3.2.1
OOO320m19 (Build:9505)
ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1.1
JapurTrench
 
Posts: 1
Joined: Mon Jul 18, 2011 10:20 am

Re: Corrupted, where is autosave?

Postby Hagar Delest » Mon Jul 18, 2011 12:45 pm

We don't have the answers. Else, the bug would have been tackled already. See the topic linked above and the bug report I've made. Nobody knows what's the problem.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28919
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Linux

Who is online

Users browsing this forum: No registered users and 5 guests