[Solved] Help adding custom fonts to OpenOffice.org 3.2

Issues with installing under all Linux Distributions

[Solved] Help adding custom fonts to OpenOffice.org 3.2

Postby VcDeveloper » Fri Jul 01, 2011 12:30 am

Host OS: Windows 7
Guest OS: Ubuntu 10.04.2 LTS (VBox 4.0.10 r72479) VM
OpenOffice 3.2

Hi, I seem to be unsuccessful installing custom fonts. I use the normal installation and created /usr/share/fonts/truetype/hebrew-fonts and put my .ttf there, ran sudo fc-cache -f with no success.

Then had no success following the OpenOffice help doc's on how to add fonts, installing a font using the font viewer, I just double clicked it again just to see if it installed, but it gave me the [Install Font] button again, BUT, the only success I did have is when I installed a font from the Software Center.

So, I reboot to see if this would do the job, but no. :( I did install "Ubuntu Restricted Extra", but my goal is to install some custom Hebrew fonts to work in OpenOffice.

HELP! :)
Last edited by Hagar Delest on Fri Jul 01, 2011 10:25 pm, edited 1 time in total.
Reason: tagged [Solved].
OpenOffice 3.2 on Ubuntu 10.04.2 LTS
VcDeveloper
 
Posts: 3
Joined: Fri Jul 01, 2011 12:22 am

Re: Help adding custom fonts to OpenOffice 3.2

Postby acknak » Fri Jul 01, 2011 2:03 am

Are these OpenType fonts? OOo has very limited support--it may even ignore them altogether.

You might also double-check that the new fonts are being picked up by fontconfig (which OOo depends on for font information), using something like:
$ fc-list : file family | grep -i fontname

For example:
    $ fc-list : file family | grep -i opens
    /home/joe/.fonts/opens___.ttf: OpenSymbol
    /usr/share/fonts/opensymbol/opens___.ttf: OpenSymbol
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Help adding custom fonts to OpenOffice 3.2

Postby VcDeveloper » Fri Jul 01, 2011 8:05 pm

I found the problem! I had another hebrew font that I used a online tool to create a webfontkit while back ago, I installed it to test and it worked. So I did the same for my new custom fonts and it worked also.

The url is fontsquirrell.com/fontface/generator

it's been a while since I returned back to Ubuntu, so it took me a bit to shake the cob webs out! So I'm good to go na! :)
OpenOffice 3.2 on Ubuntu 10.04.2 LTS
VcDeveloper
 
Posts: 3
Joined: Fri Jul 01, 2011 12:22 am


Return to Linux

Who is online

Users browsing this forum: No registered users and 4 guests