Installing OOo on Slackware

Issues with installing under all Linux Distributions

Installing OOo on Slackware

Postby EMpulse1 » Wed Apr 13, 2011 6:26 pm


I have 32 bit Slackware (v13.?) and I'm trying to install Open Office 3.3.0, I converted the rpm files to tgz with "rpm2tgz" and ran "installpkg", links to all the Open Office applications are visible in KDesktop (Under Applications - Office) but when I click on one of them nothing happens, the program doesn't start.

I was following the instructions at ... kware-13-1

The only wrinkle I had was that the "sudo" command did not work for me, rather than executing "sudo rpm2tgz *.tgz" for example I had to type "su" to become root and then execute "rpm2tgz *.tgz", ditto for the "installpkg *.tgz" command.

Could this be why my installation seems to not work ? I can't get Adobe Reader to work either but one thing at a time I guess !

Thank you very much,


Title Edited. A descriptive title for posts helps others who are searching for solutions and increases your chances of a reply. (TheGurkha, Moderator)
Open Office 3.3.0 Slackware
Posts: 2
Joined: Wed Apr 13, 2011 6:09 pm

Re: Slackware

Postby Villeroy » Wed Apr 13, 2011 6:38 pm

Find out the directory where you installed into. Could be in /opt /usr/lib /usr/local or something else. Let's say /opt
cd /opt/openoffice.org3/program

watch out for errors
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Posts: 28341
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Slackware

Postby EMpulse1 » Wed Apr 13, 2011 9:17 pm

Thanks for the help, I found it in /opt/openoffice.org3/program and it works fine. Any ideas how I can get it to work properly from KDesktop ?


Open Office 3.3.0 Slackware
Posts: 2
Joined: Wed Apr 13, 2011 6:09 pm

Re: Installing OOo on Slackware

Postby westburian » Wed Aug 22, 2012 10:52 am

sure, now you need to go back to where you unpacked the tar.gz and find the dir named desktop-integration, here is mine:

westburian@mattsw12:/fatd/files/en-US/rpms/desktop-integration$ ls

I had missed this part myself and had also been launching directly from /opt/...../.soffice but just saw a youtube video of a guy doing this on a Vector Linux box and he simply converted the 'redhat' menu rpm to tgz and installed that and it gave him his /usr/bin/openoffice.org3 files he needed AND it even put the links in his Kmenu iirc --- you should be able to figure it out.

I use slackware 12.2 on my main box as I prefer KDE 3.5.10 to KDE 4.x and I had to update my glibc but other than that, it was just a matter of getting those rpm's converted to tgz mainly. :)

this was done on my older sw 12.2 installation which I always *experiment* on before I actually do it on my main install.

hope this helps !


as a footnote, I had been using the openoffice.org3 version 3.0 oracle (or is it Sun?) and now I have the newer Apache Open Office 3.4 ---- but first I used Kpackage to remove the 3.0 PACKAGE that I had installed from some time ago, then I proceeded with the Apache OO version 3.4 install :)
Open Office v 3.0
westburian@mattsw12:~$ uname -a
Linux mattsw12 #2 SMP Thu Nov 20 22:32:43 CST 2008 i686 AMD Sempron(tm) Processor 3000+ AuthenticAMD GNU/Linux
Posts: 2
Joined: Mon Jul 04, 2011 8:13 am

Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest