[Solved] Openoffice is very slow with a network connection

Issues with installing under all Linux Distributions

[Solved] Openoffice is very slow with a network connection

Postby fdservices » Sat Mar 15, 2008 10:58 am

If I bring down my network connection OO 2.3.1 starts in around 3 seconds. If I bring the network up it takes around 21 seconds to start. DOes anyone know why?

I am running under Mandriva 2008.0 Linux

Andrew
Last edited by Hagar Delest on Mon Jun 09, 2008 11:10 pm, edited 2 times in total.
Reason: tagged the thread as Solved.
fdservices
 
Posts: 9
Joined: Sat Mar 15, 2008 10:15 am

Re: Openoffice is very slow with a network connection

Postby Hagar Delest » Sat Mar 15, 2008 11:15 am

have you tried to disable the Check for updates option in Tools>Options>OOo>Online update?
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28731
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Openoffice is very slow with a network connection

Postby fdservices » Sat Mar 15, 2008 2:56 pm

Yes done that in the past with no effect.
fdservices
 
Posts: 9
Joined: Sat Mar 15, 2008 10:15 am

Re: Openoffice is very slow with a network connection

Postby Hagar Delest » Sat Mar 15, 2008 4:26 pm

Have you tried to ask in the Mandriva forum?

Usually, I remove the version from my distro and I install the official (Sun) version.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28731
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Openoffice is very slow with a network connection

Postby James » Sat Mar 15, 2008 5:54 pm

Do you have any network paths in Tools > Options > OpenOffice.org > Paths?
James
www.8daysaweek.co.uk - A User-Focused OOo site.
Windows Easy Installation CDs & OOo on USB Keys, OOo for Mac OS X + Ubuntu CDs

Please read: Survival Guide for the forum
OOo 3.1.1 on Ubuntu 9.x + Windows XPP, Mac OS X
User avatar
James
Volunteer
 
Posts: 264
Joined: Sun Oct 07, 2007 7:23 am
Location: UK

Re: Openoffice is very slow with a network connection

Postby fdservices » Sat Mar 15, 2008 10:01 pm

No, I have no network paths, but I will try a virgin install of 2.4 in
fdservices
 
Posts: 9
Joined: Sat Mar 15, 2008 10:15 am

Re: Openoffice is very slow with a network connection

Postby fdservices » Sat Mar 15, 2008 10:49 pm

Right I have uninstalled 2.3 and deleted the .ooo2.0 directory from my home directory.

I have installed 2.4, opting not to search for updates, and with no changes to the options I get:

With the network connection - 42 seconds to load
Without the network connection - 2 seconds to load (may be, it is very quick!)

So what does Openoffice do with the network connection when it loads?!?

If it helps I could upload a wireshark dump?

It would help me a lot if I knew whether anyone else had similar problems/timings?
fdservices
 
Posts: 9
Joined: Sat Mar 15, 2008 10:15 am

Re: Openoffice is very slow with a network connection

Postby James » Sat Mar 15, 2008 10:53 pm

I'm using 2.4 on Ubuntu Gutsy at the moment, with a Network connection and haven't noticed a lag, certainly not that long.

It just reminded me, the last time I remember hearing about issues like this, it was something to do with networked Printers, but IIRC that was on Windows.
James
www.8daysaweek.co.uk - A User-Focused OOo site.
Windows Easy Installation CDs & OOo on USB Keys, OOo for Mac OS X + Ubuntu CDs

Please read: Survival Guide for the forum
OOo 3.1.1 on Ubuntu 9.x + Windows XPP, Mac OS X
User avatar
James
Volunteer
 
Posts: 264
Joined: Sun Oct 07, 2007 7:23 am
Location: UK

Re: Openoffice is very slow with a network connection

Postby acknak » Sat Mar 15, 2008 11:37 pm

Don't forget to try running OOo with a clean user settings directory. Either rename, or remove, the one from your regular user account, or create a new user account, log in there and try OOo. You should get a new first-run wizard and OOo will create new settings. That will have the update check enabled again, so if it still slow, turn that off, exit OOo and try again.

Make sure Mandriva is not running the Quickstarter (actually from your 2s load time, it sounds like they may be).
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Openoffice is very slow with a network connection

Postby fdservices » Sun Mar 16, 2008 12:40 pm

No I am not running Quickstarter and yes I did remove the old user settings directory, and did the first-time wizard. This does not appear to be to do with printers but with DNS lookups.

Any other ideas?
fdservices
 
Posts: 9
Joined: Sat Mar 15, 2008 10:15 am

Re: Openoffice is very slow with a network connection (SOLVED)

Postby fdservices » Sun Mar 16, 2008 1:20 pm

I have looked into the wireshark analysis of the traffic on the eth0 interface and here is a summary of the problem:

After 1.7 seconds something, presumably Openoffice, sends a DNS Standard query A message for the name "ezcool" to the gateway address, which is also the DNS server address.

It seems to ignore the DNS servers in the resolv.conf file, and also the /etc/hosts file.

This query times out after five seconds.

Then, every five seconds thereafter it sends a repeat query, seven times until it gives up.

All of which takes 40 seconds.

Further information: "ezcool" is the name of my PC, which is on a fixed network address, which is listed in /etc/hosts. I tried installing a DNS server on ezcool and listed the local machine in resolv.conf.

"dig ezcool" replies with

; <<>> DiG 9.4.1-P1 <<>> ezcool
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14711
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ezcool. IN A

;; ANSWER SECTION:
ezcool. 0 IN A 192.168.100.5

;; Query time: 1 msec
;; SERVER: 192.168.100.5#53(192.168.100.5)
;; WHEN: Sun Mar 16 12:13:57 2008
;; MSG SIZE rcvd: 40

immediately, but this made no difference since the queries listed above only query the gateway router. Since the gateway router lists the internet DNS servers, then ezcool will not be found there and the queries will time out.

All this activity does not seem to have any purpose since Openoffice seems to start without any problem if the network interface is down.

So what is going on, and why doesn't it affect anyone else?
Last edited by fdservices on Fri Apr 04, 2008 9:13 am, edited 1 time in total.
fdservices
 
Posts: 9
Joined: Sat Mar 15, 2008 10:15 am

Re: Openoffice is very slow with a network connection

Postby fdservices » Fri Apr 04, 2008 9:13 am

Does Openoffice take a long time to start on your PC? If it does then try disabling your network interface:

First "su" to root and
# ifconfig eth0 down
or using "sudo"
# sudo ifconfig eth0 down
where eth0 is the name of your network interface.

Now start Openoffice. If it now starts like greased lightning read on.
(You can restart your interface by using "ifconfig eth0 up" instead of down in the above examples.)

Openoffice does a DNS lookup when it starts. If it does not get a response then it times out after a few seconds and retries seven times. That is eight timeouts before it starts.

To avoid this delay make sure that:

* if you have manually set up your network interface then set the DNS server addresses to the DNS servers supplied by your ISP. Do not set the DNS server to the router address or gateway address.

* if you are using DHCP set the DNS server addresses to either the DNS servers supplied by your ISP or use "Get DNS servers from DHCP" if it is available.

The improvement on my machines was from a start up time of between 20 and 40 seconds to a time of between 2 and 4 seconds!
fdservices
 
Posts: 9
Joined: Sat Mar 15, 2008 10:15 am

Re: [Solved] Openoffice is very slow with a network connection

Postby Hagar Delest » Fri Apr 04, 2008 9:55 am

Many thanks for this information, I hope it will help other users too!

NB: I've tagged the thread as Solved, it has to be done in the first post title (first of the thread, not of the page).
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28731
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Openoffice is very slow with a network connection

Postby acknak » Sat Apr 05, 2008 4:49 am

Yes, nice follow-up!

I am wondering though, a broken DNS configuration that slows OOo down like you experienced will also have a similar effect on every other application that needs to use the 'Net.

Is there some detail I've missed? Otherwise, did you not notice the problem with other apps, such as your browser?

If OOo is somehow uniquely affected by certain DNS (mis-)configurations, it may need to be reported as a bug.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests