[Solved] Calc is painfully slow

Issues with installing under all Linux Distributions

[Solved] Calc is painfully slow

Postby paddlaren » Tue Feb 02, 2010 6:10 pm

Hi!

I have OO installed on two computers, one laptop with Kubuntu and one stationary with Gentoo. On both machines Cal i spainfully slow but on the stationary (AMD Dualcore X64, 4 Gig RAM, 32-bit Gentoo linux optimized for my CPU) there should be no reason. The problem is in Calc. I have a sheet with about 500 lines and 15 columns of data. When I write in one cell and move to next it might take 2-5 seconds before anything happens. I have removed filters and hidden columns but still slow.

Is this just me with bad luck? :(

Regards,
Erik
Last edited by paddlaren on Fri Feb 05, 2010 10:47 pm, edited 1 time in total.
OpenOffice 3.1 on Gentoo and Kubuntu 9.10
paddlaren
 
Posts: 3
Joined: Tue Feb 02, 2010 5:56 pm

Re: Calc is painfully slow

Postby Hagar Delest » Tue Feb 02, 2010 6:55 pm

Hi and welcome to the forum!

First try to reset your OOo user profile. But during the welcome process, don't transfer your personal data (if you had 2.x), former configuration files might corrupt the new profile.

If no change, try the Sun version: [Ubuntu] Installing OOo on Debian and Co.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Calc is painfully slow

Postby paddlaren » Tue Feb 02, 2010 8:22 pm

I tried to reset the profile and copied all information to a new sheet making sure no formulas was copied but no improvments. Seems to be when I leave a cell it takes time.
I disabled spelling-check as well, no improvement.

Hesitates a bit for fiddling with Sun-version (well, it is Oracle version now days I beleve :? ). The most important is my computer at work and there is no rooms for downtime right now.

Will continue looking for a source to the delay.

// Erik
OpenOffice 3.1 on Gentoo and Kubuntu 9.10
paddlaren
 
Posts: 3
Joined: Tue Feb 02, 2010 5:56 pm

Re: Calc is painfully slow

Postby keme » Fri Feb 05, 2010 1:32 am

As a workaround until you have the problem sorted out, try to disable auto recalculation (and perhaps autoinput). Tools - Cell content - ... It should make cell input faster, but then you'll need to initiate recalc manually (Tools - Cell content - Recalculate or function key F9) to update your results.
OOo 3.3.0 and Apache OOo 3.4.1/4.0.0, on Ms Windows 7 and Mac OS-X.
User avatar
keme
Volunteer
 
Posts: 1601
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: Calc is painfully slow

Postby paddlaren » Fri Feb 05, 2010 10:47 pm

By some reason it seems to work better now. What I did was to open it as XLS-format in Gnumeric, make some changes and save. Cant explain why but it seems to do the trick.

It is reasonable that the problem lies in the file as it first worked just fine and sudenly become very slow on two different linux machines with different lixues (kubuntu and gentoo).

I will put this thread to solved as I no longer have the problem.

Regards,
Erik
OpenOffice 3.1 on Gentoo and Kubuntu 9.10
paddlaren
 
Posts: 3
Joined: Tue Feb 02, 2010 5:56 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests