[Solved] Base hanging

Issues with installing under all Linux Distributions

[Solved] Base hanging

Postby Mr-Z » Fri Feb 01, 2008 5:45 am

Hello everybody, I just registered on this forum so that I could get in on this thread. I too am having some issues with extreme delay and hanging, using OOo Base.

I'm running Ubuntu 7.10, with a fair amount of the fancy desktop add-ons running. My system is not very potent; I'm running an AMD Duron 1.3Ghz on a generic board with 756mb ddr1 ram and 2gig swap (reads as 1.6gb for some reason). The system runs fine generally, with usually 20-25% CPU usage when I'm not manipulating windows or switching desktops (when I do the processor usage goes skyrockets because of the add-ons), and my RAM/SWAP usage never seems to exceed 38%. I can use Calc without any problems, but OOo gets real touchy once I break out the Base program. I'm trying to put together a database/basic management prog for my small-time eBay business.

Base has trouble right from the get-go. Takes a good moment to load up, from double clicking the file on my desktop without OOo running. Then I click on the "tables" section. It will hang, go gray for a moment, and then come back eventually and display my tables. Same thing when I use the designer to add a table, takes a good moment for it to get there. Same for saving. I've tried to load the Form Wizard several times, each time resulting in a terminal hang requiring a forced quit. During each delay or hang, the processor usage jumps up max and just bobs up and down between 94% and 100% (with only a minimal increase in memory usage). Basically, every step seems really difficult for OOo Base the first time, altho after the first time using each function it usually doesn't have any major delays on the next use (assuming I making through each function's first use without having to force-quit and start over). I do tend to have other things going on (MP3 player, Pidgin and Firefox and such windows open in other desktops) but like I said, this doesn't cause any such issues with Calc or Writer.


So yeah, all I needed was the proper OOo distro. Uninstalled the Ubuntu version and did a manual install of the Debian version downloaded directly from the OOo website, per the instructions in the link that Hagar provided. She works like a charm now. I should have searched harder, probably could've found it on my own. Anyway, thanks for your help!
Last edited by Mr-Z on Sat Feb 02, 2008 9:29 pm, edited 1 time in total.
Posts: 2
Joined: Fri Feb 01, 2008 5:13 am

Re: Base hanging

Postby Hagar Delest » Fri Feb 01, 2008 9:19 am

Please read the Survival Guide for the forum. You've replied a thread dealing with MS Windows, no relation at all.

So I moved your thread in the Linux forum.

Ubuntu version of OOo is known to be rather sluggish. You should install the official version of OOo : [Ubuntu] Installing OOo on Debian and Co.

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Posts: 28893
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Base hanging

Postby Mr-Z » Fri Feb 01, 2008 4:35 pm

Sorry about that, didn't realize I was on a Windows thread. I'll try a re-install with the version you've recommended when I get a chance, will be back later to report on whether or not this did the trick for me. Thanks!
Posts: 2
Joined: Fri Feb 01, 2008 5:13 am

Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest