[Solved] X server interaction error with 2.3.1?

Issues with installing under all Linux Distributions

[Solved] X server interaction error with 2.3.1?

Postby shelxcns » Thu Jan 24, 2008 5:32 pm

I upgraded to 2.3.1 last week and everything was running just fine as of Monday. I try to run openoffice today and the following pops up in my terminal:

X Error: BadValue (integer parameter out of range for operation) 2
Major opcode: 78
Minor opcode: 0
Resource id: 0x0
X Error: BadColor (invalid Colormap parameter) 12
Major opcode: 84
Minor opcode: 0
Resource id: 0x500007
X Error: BadColor (invalid Colormap parameter) 12
Major opcode: 84
Minor opcode: 0
Resource id: 0x500007
X Error: BadColor (invalid Colormap parameter) 12
Major opcode: 1
Minor opcode: 0
Resource id: 0x500007
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 18
Minor opcode: 0
Resource id: 0x500008
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 18
Minor opcode: 0
Resource id: 0x500008
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 2
Minor opcode: 0
Resource id: 0x500008
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 55
Minor opcode: 0
Resource id: 0x500009
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 55
Minor opcode: 0
Resource id: 0x50000a
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 55
Minor opcode: 0
Resource id: 0x50000b
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 55
Minor opcode: 0
Resource id: 0x50000c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 55
Minor opcode: 0
Resource id: 0x50000d
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 53
Minor opcode: 0
Resource id: 0x50000e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 55
Minor opcode: 0
Resource id: 0x50000f
X Error: BadPixmap (invalid Pixmap parameter) 4
Major opcode: 54
Minor opcode: 0
Resource id: 0x50000e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 53
Minor opcode: 0
Resource id: 0x500010
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 55
Minor opcode: 0
Resource id: 0x500011
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 72
Minor opcode: 0
Resource id: 0x500011
X Error: BadGC (invalid GC parameter) 13
Major opcode: 60
Minor opcode: 0
Resource id: 0x500011
X-Error: BadColor (invalid Colormap parameter)
Major opcode: 1 (X_CreateWindow)
Resource ID: 0xa0
Serial No: 249 (249)
These errors are reported asynchronously,
set environment variable SAL_SYNCHRONIZE to 1 to help debugging

The odd thing is I have not made any changes to the system aside from updating to firefox 2 and my flash installation. I removed and reinstalled openoffice (and I had removed the previous version before upgrading originally), but the errors remain the same. SELinux is running at setenforce 0, as recommended for checking errors. This looks like some issue with the X server, but I have not touched it at all. Given the only things I have changed are firefox and flash, and it was working just fine three days ago, this is really confusing, not to mention work-related frustrating. Anyone have a clue of what is going on or how to fix? I could not find any related posts.

System info:
CentOS 4.6 kernel 2.6.9-55.0.6.EL (32bit)
Nvidia driver 1.0-8762
glibc 2.3.4
Last edited by shelxcns on Thu Jan 24, 2008 5:58 pm, edited 1 time in total.
shelxcns
 
Posts: 3
Joined: Thu Jan 24, 2008 5:17 pm

Re: X server interaction error with 2.3.1?

Postby shelxcns » Thu Jan 24, 2008 5:58 pm

Solved - reinstalled the nvidia driver and it seems to be working fine now. I have no idea how updating firefox and flash could have resulted in something getting screwed up with the nvidia driver interacting with openoffice, especially as everything else including my various special work graphics programs was fine, but there it is. I vaguely remembered reinstalling the nvidia driver fixing some X related issues for an unrelated program, so thought I'd give it a crack.
shelxcns
 
Posts: 3
Joined: Thu Jan 24, 2008 5:17 pm

Re: [SOLVED] X server interaction error with 2.3.1?

Postby acknak » Thu Jan 24, 2008 7:50 pm

Do you have any automatic updates enabled? Perhaps security-tagged only?
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [SOLVED] X server interaction error with 2.3.1?

Postby shelxcns » Thu Jan 24, 2008 8:05 pm

Not for open office; in fact I have automatic updates turned off for everything on this system to try to avoid update-related breakage. Good question. No one else has root access (work machine, but I'm the primary user and administrator), so I do not think it was someone else changing something. Hence the oddness...
shelxcns
 
Posts: 3
Joined: Thu Jan 24, 2008 5:17 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests