[Solved] All menus are in Greek letters

Issues with installing under all Linux Distributions

[Solved] All menus are in Greek letters

Postby moving fusion » Tue Jan 22, 2008 4:06 am

I'm using openoffice 2.3.0 in Fedora core 8. I have tried the bundled version, the add remove software version and the official download, all three gave the same results. All the menu teat is in Greek letters, yet I have not installed any language packs and the language, by default, is set too English. As far as I can see the is no option to change the characters used and therefore I am at a complete loss on how to solve the problem. Any help hugely appreciated. Thank You.
Last edited by moving fusion on Thu Jan 24, 2008 5:14 am, edited 1 time in total.
moving fusion
 
Posts: 3
Joined: Tue Jan 22, 2008 3:59 am

Re: All menues are in greek letters

Postby acknak » Tue Jan 22, 2008 5:24 am

... the language, by default, is set too English.

Set for your system, or for OOo? How did you check this?

Your other menus (desktop, panels, etc.) are in English, right?

Try logging in as a different user (create one if necessary) and running OOo.

If that works, you can fix your normal login by removing your OOo configuration: rm -fr ~/.openoffice2*

The next time you start OOo, it will create a new configuration for you.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: All menues are in greek letters

Postby Hagar Delest » Tue Jan 22, 2008 9:14 am

If removing the OOo user profile doesn't work, try to change the applications fonts set for the system. Under Ubuntu and Gnome it happens sometimes. Rather weird but it does.

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28461
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: All menues are in greek letters

Postby kingfisher » Tue Jan 22, 2008 9:23 am

You may be able to fix the problem by re-naming your user settings folder. It's normally a hidden folder in your home folder. I suggest re-naming it rather than removing it so that you can reinstate it if that is not the problem. The folder will be re-created when OO is re-launched. Make sure all OO processes are closed when you re-name the folder, including any quick starter.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Re: All menues are in greek letters

Postby moving fusion » Thu Jan 24, 2008 5:13 am

As it turns out it was my system set fonts. Which I find strange as there has never been a problem with any other application. I have changed the fonts and it all works now. OpenOffice must be the only program on my system that uses system fonts, which can't be the case, so that means its the way it uses system fonts that is the problem. Either way, i have now sorted the problem. Thank you for the suggestions.
moving fusion
 
Posts: 3
Joined: Tue Jan 22, 2008 3:59 am

Re: [Solved] All menues are in greek letters

Postby acknak » Thu Jan 24, 2008 5:29 am

I have changed the fonts and it all works now.

In the interest of helping someone else who runs into this, can you describe exactly what you changed?
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: All menues are in greek letters

Postby Hagar Delest » Thu Jan 24, 2008 9:02 am

moving fusion wrote:that means its the way it uses system fonts that is the problem.

Yes. The strange thing is that it doesn't occur systematically. Personally, I've never experienced that. But it's a rather common issue on Ubuntu forums.

There is also an issue with backgrounds and fonts color in menus (if you use a dark theme), it may be related.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28461
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] All menues are in greek letters

Postby moving fusion » Thu Jan 24, 2008 1:31 pm

The system fonts I changed are found in the following menu: System>>Preferences>>Look and Feel>>Appearance. Then click on the fonts tab. I changed them all to Cursor bold. The important thing is I changed them from Standard Symbols, which is what was causing the problem. I run my own theme which is all black with green text. The only issue with this is some 3D buttons appear totally black, however, I don't consider this a problem as I know why they are like that. I hope this helps.
moving fusion
 
Posts: 3
Joined: Tue Jan 22, 2008 3:59 am

Re: [Solved] All menues are in greek letters

Postby acknak » Thu Jan 24, 2008 6:32 pm

Ok, I see now. Thanks for the update!
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3


Return to Linux

Who is online

Users browsing this forum: No registered users and 4 guests