[Solved] OOo 3: why en-GB dictonary is not working?

Issues with installing under all Linux Distributions

[Solved] OOo 3: why en-GB dictonary is not working?

Postby xywa » Thu Nov 13, 2008 2:58 pm

Hi!

I am using for a short time Open Office 3 (linux Gentoo), but I can not use en-GB dictonary. Someone told me that the dictionary should be installed by default, but is not working (in my case). I have Polsih dictionary (works fine), I found US English dictionary on the web (works fine)
...but I can not find enywhere UK English dictionary.
Can anyone help me?
Or maybe is better to downgrade Open Office to 2.x version (wich used to work with aspell pretty well)?
Last edited by xywa on Wed Nov 19, 2008 6:40 pm, edited 1 time in total.
OOo 3.0.X on Linux-Other
xywa
 
Posts: 4
Joined: Thu Nov 13, 2008 2:28 pm

Re: Open Office 3 - why en-GB dictonary is not working?

Postby Villeroy » Thu Nov 13, 2008 3:46 pm

Don't believe what other people tell about installed packages on your computer.
Open a new document.
Call Tools>Options...LangSettings>Languages
Western language: English (UK) [<-- if this entry has a blue checkmark, this language's dictionary is installed]
[X] Current document only
[OK]

[Tutorial] Spell check and Language configuration
You'll find language packs on http://extensions.services.openoffice.org/ in case you are using the vanilla binaries from Sun, otherwise you may need to look in the Gentoo sources for appropriate language packs (I never used Gentoo).
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28445
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Open Office 3 - why en-GB dictonary is not working?

Postby xywa » Fri Nov 14, 2008 11:18 pm

Villeroy wrote:Don't believe what other people tell about installed packages on your computer.
Open a new document.
Call Tools>Options...LangSettings>Languages
Western language: English (UK) [<-- if this entry has a blue checkmark, this language's dictionary is installed]
[X] Current document only
[OK]


The problem is... there is NO blue checkmark. It shold be, is it NOT. I was using OO 2.x for two years and I was using few different languages so I know how to use it...

Villeroy wrote:[Tutorial] Spell check and Language configuration
You'll find language packs on http://extensions.services.openoffice.org/ in case you are using the vanilla binaries from Sun,


The problem is... there is NO answer for my question here. I have NO problems in instaling any extra dictionary, and I know how to use it. As I siad before I know the link you provided, but there is NO UK-English, there is US_English and many, many more but NOT UK_English.

Villeroy wrote:otherwise you may need to look in the Gentoo sources for appropriate language packs (I never used Gentoo).

The problem is... in new Open Office 3, you can NOT chage lagunguages form Gentoo, as everything you have to do from manager inside the OO so...
OOo 3.0.X on Linux-Other
xywa
 
Posts: 4
Joined: Thu Nov 13, 2008 2:28 pm

Re: Open Office 3 - why en-GB dictonary is not working?

Postby Hagar Delest » Fri Nov 14, 2008 11:26 pm

If you still have the old dictionary files, see that thread: Spellcheck wont work in Star Office 8.0, Eee PC Linux. Could you confirm if you've the dict-en.oxt extension in the .../share/extension/install folder? Perhaps it's not included in the sources.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28919
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Open Office 3 - why en-GB dictonary is not working?

Postby xywa » Wed Nov 19, 2008 6:07 pm

I have got those files:
# equery f openoffice-bin | grep oxt
/usr/lib64/openoffice/share/extension/install/dict-en.oxt
/usr/lib64/openoffice/share/extension/install/dict-es.oxt
/usr/lib64/openoffice/share/extension/install/dict-fr.oxt
OOo 3.0.X on Linux-Other
xywa
 
Posts: 4
Joined: Thu Nov 13, 2008 2:28 pm

Re: Open Office 3 - why en-GB dictonary is not working?

Postby Hagar Delest » Wed Nov 19, 2008 6:08 pm

Then in Tools>Extension Manager, try to Add the dict-en.oxt one.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28919
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Open Office 3 - why en-GB dictonary is not working?

Postby xywa » Wed Nov 19, 2008 6:39 pm

Hagar de l'Est wrote:Then in Tools>Extension Manager, try to Add the dict-en.oxt one.


You are great!
Finally works!

THX!!!!!!!!!!!!!!!!!!
OOo 3.0.X on Linux-Other
xywa
 
Posts: 4
Joined: Thu Nov 13, 2008 2:28 pm

Re: [Solved] Open Office 3 - why en-GB dictonary is not work

Postby cjw » Tue Aug 23, 2011 12:06 am

I know that it was claimed that this problems was solved many months ago,

This is not true for 3.3.

Locale en-ca seems to treat en-gb language as en-us.

I worked around the problem by changing my locale from en-ca to en-nz.

This seems to fix things.

Colin W.
Windows XP PRO Open Office 3.2
cjw
 
Posts: 1
Joined: Mon Mar 22, 2010 5:54 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests