[Solved] Passwords not recognised in KDE5

Issues with installing under all Linux Distributions

[Solved] Passwords not recognised in KDE5

Postby HowardJ » Wed Jun 03, 2020 3:03 pm

I use AOO and PCLinuxOS. I have two flavours of the OS, one using the no longer supported LXDE desktop, and the other using KDE5 fully up to date.

Both also have Libreoffice, but I have been using the vanilla OpenOffice Suite since the time it was StarOffice5 and don't like the MS-ised character of the other version.

Both OS's are on the same computer and have access to all the same data files.

AOO under KDE5 will not save or open writer or calc files with passwords - but Libreoffice will. Under LXDE both work OK.

It seems to me that some dependency is missing from the KDE5 suite, has anyone any idea what it might be?
Last edited by HowardJ on Thu Jun 04, 2020 8:32 pm, edited 1 time in total.
AOO 4.1.2 on various machines running PCLinuxOS (LXDE desktop). It all began with StarOffice 5.2 - I've still got the disk!
HowardJ
 
Posts: 118
Joined: Thu Aug 01, 2013 1:49 am
Location: Newfoundland

Re: Passwords not recognised in KDE5

Postby Bill » Wed Jun 03, 2020 5:33 pm

I don't usually use document passwords, but I was able to save and open some simple ODT and DOC files with passwords on Kubuntu 20.04 with KDE5.18.5. Are you getting an error message?
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7916
Joined: Sat Nov 24, 2007 6:48 am

Re: Passwords not recognised in KDE5

Postby HowardJ » Wed Jun 03, 2020 8:32 pm

I use them to protect details of my financial affairs on my laptop.

The version of KDE5 installed is the mini version so that may be the problem. I find the full version is full of stuff I would never use and prefer to build up what I actually want. Maybe this policy has caught me out here. But I'd rather find the missing file(s) than have to clutter up my computer.
AOO 4.1.2 on various machines running PCLinuxOS (LXDE desktop). It all began with StarOffice 5.2 - I've still got the disk!
HowardJ
 
Posts: 118
Joined: Thu Aug 01, 2013 1:49 am
Location: Newfoundland

Re: Passwords not recognised in KDE5

Postby Bill » Thu Jun 04, 2020 4:18 pm

Running pclinuxos64-kde5-darkstar-2020.05 live (the mini version), I used Synaptic to install dpkg then used dpkg to install AOO 4.1.7. AOO 4.1.7 was able to save an ODT file with a password, so it appears that the problem is not caused by a missing dependency.
Last edited by Bill on Thu Jun 04, 2020 5:14 pm, edited 1 time in total.
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7916
Joined: Sat Nov 24, 2007 6:48 am

Re: Passwords not recognised in KDE5

Postby HowardJ » Thu Jun 04, 2020 5:03 pm

Thanks Bill,

I've just installed a new, full version of KDE5 on a different computer, and also downloaded and installed a fresh version of AOO 4.1.7. (Completely removed the original installation.) I still cannot get the passwords to work.

If I try to open a file already with a password I get the "Wrong Password" message. If I try to save a file with a password I get "Error saving the document Fred: General Error: General input/output error" And the name is not changed if I have edited it.

It does not happen with my old LXDE installation of PCLinuxOS but does with all the KDE5 ones. For my purposes, it makes KDE5 in PCLINUXOS unuseable.
AOO 4.1.2 on various machines running PCLinuxOS (LXDE desktop). It all began with StarOffice 5.2 - I've still got the disk!
HowardJ
 
Posts: 118
Joined: Thu Aug 01, 2013 1:49 am
Location: Newfoundland

Re: Passwords not recognised in KDE5

Postby MrProgrammer » Thu Jun 04, 2020 6:14 pm

HowardJ wrote:AOO under KDE5 will not save or open writer or calc files with passwords - but Libreoffice will. Under LXDE both work OK.
Note Issue 125431 - The Password is incorrect. The file cannot be opened, especially comments 52, 73, and 78 about the Mozilla profile.ini file. Much of the discussion is about MacOS, but the problem seemed to affect Linux as well. Perhaps if you create a new user it will not contain the profile.ini setting which causes the problem. I didn't study the issue enough to determine if there is a way to correct the problem with your current user ID.

Screen Shot 2020-06-04 at 12.29.10.png
Your AOO 4.1.2 was released about the time of those comments. Issue 125431 was marked RESOLVED in 2016.

If this solved your problem please go to your first post use the Edit button and add [Solved] to the start of the title. You can select the green checkmark icon at the same time.
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 3942
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: Passwords not recognised in KDE5

Postby HowardJ » Thu Jun 04, 2020 8:32 pm

Amazing MrProgrammer, thanks for tracking that down! I'm not sure what most of it was about but I picked up the message that it was something to do with the mozilla profiles.ini file. Like the original poster I also use the same .mozilla and .thunderbird folders for all my systems. I use symbolic links for more than one OS on the same computer and copy over using a usb stick between computers.

I renamed the original profiles.ini, opened and closed firefox to create a new set of files, and then renamed my old xxxxxx.default-release folder with the name on the new one that appeared.

Firefox opened with all my familiar links and AOOs passwords now work.

But why on earth does AOO use the mozilla profiles.ini, Why was it still OK on my ol LXDE installation (usingthe same mozilla profile) and why was LibreOffice unaffected. Never mind, it works!
AOO 4.1.2 on various machines running PCLinuxOS (LXDE desktop). It all began with StarOffice 5.2 - I've still got the disk!
HowardJ
 
Posts: 118
Joined: Thu Aug 01, 2013 1:49 am
Location: Newfoundland


Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests