[Solved] Linux: No text in OpenOffice.org menus

Issues with installing under all Linux Distributions

[Solved] Linux: No text in OpenOffice.org menus

Postby giabaio » Sun Sep 28, 2008 7:10 pm

Hi all,
I am a new user of this forum and a relatively new user of ubuntu (8.04 is the version I'm currently using). I'm having a very weird problem with Oo. As I open any Oo application, no text is displayed in the menus (see the attached screenshot). Oo seems to work, I assume is a problem with fonts, although no other application seems to have been affected (LaTeX, Firefox, Terminal and many others work just fine).

I tried to search the web, but couldn't find any similar issue. Anyone has any idea of what could be going on?=
Cheers,
Gianluca

Screenshot.png
Last edited by MrProgrammer on Tue Aug 27, 2019 12:49 am, edited 2 times in total.
Reason: Added keyword "Linux" to title
OOo 2.4.X on Ubuntu 8.x
giabaio
 
Posts: 4
Joined: Sun Sep 28, 2008 7:03 pm

Re: No text in opeonoffice menus

Postby Hagar Delest » Sun Sep 28, 2008 7:15 pm

See here: [Solved] All menues are in Greek letters.
Or you can try to install the gtk package for OOo in Synaptic, I've seen that it works too IIRC.

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28595
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: No text in opeonoffice menus

Postby giabaio » Sun Sep 28, 2008 7:33 pm

Thanks Hagar,
I tried that, but no luck... Neither renaming my .openoffice2 directory, nor changing settings for the fonts did the trick.
I should say that when I try to write something, e.g. in Oowriter, I can't actually see any text at all (as if the textcolour was set to white on a white page). I opened a spreadsheet document, for which I can see some text (randomly fiddling with the font menu, since I can't actually see what font I'm selecting -- see attached screenshots)
Screenshot2.png
Screenshot1.png


Thanks!
Gianluca
OOo 2.4.X on Ubuntu 8.x
giabaio
 
Posts: 4
Joined: Sun Sep 28, 2008 7:03 pm

Re: No text in opeonoffice menus

Postby Hagar Delest » Sun Sep 28, 2008 8:29 pm

AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28595
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: No text in opeonoffice menus

Postby giabaio » Sun Sep 28, 2008 10:54 pm

Thanks,
I reinstalled the new version (2.4.1) and it now seems to work ok!
Gianluca
OOo 2.4.X on Ubuntu 8.x
giabaio
 
Posts: 4
Joined: Sun Sep 28, 2008 7:03 pm

Re: [Solved] Informantional Post No text in OpenOffice menus

Postby Bubba123 » Fri Nov 14, 2008 12:28 am

this is strictly informational post, but I had this same problem. When I first opened Oo none of the apps had menus that i could read. there were only lines where the text should have been. After I lot of digging I realized that these were not lines but text that was so small that it could not be read. I cold click on one and the drop down would open but I could not read anything in the dropdown either. Here is how I fixed it. Start Oo word processor. Click on the tools menu (7th from left, 3rd from right in Oo 3.0 ) The last (bottom)option on the tools menu is options. That will open a dialog box that you won't be able to read but in the left pane just click down the options until you see "Options-OpenOffice.org-View" in the dialog title bar. At this stage you should see several check boxes in the right pane. Uncheck all of them and then click the ok button at the bottom of the dialog box. You won't be able to read it but it is the leftmost of the bottons at the bottom. The dialog should close and your menus should be readable now.
OOo 3.0.X on Ubuntu 8.x + xp pro
Bubba123
 
Posts: 1
Joined: Fri Nov 14, 2008 12:09 am

Re: [Solved] No text in OpenOffice menus

Postby roadstar » Sat Nov 22, 2008 9:23 pm

I've tried un-installing and re-installing with no luck at all. I still can't see any text in the menus.

Suggestions??

Thanks
OOo 3.0.X on Ubuntu 8.x
roadstar
 
Posts: 2
Joined: Sat Nov 22, 2008 9:18 pm

Re: [Solved] No text in OpenOffice menus

Postby ikis » Sat Nov 22, 2008 10:11 pm

Do as Bubba123 said.Actually the only box to disable is 'screen font anti-aliasing'. Since you wont see anything that's written, it is the second of the five checked squares in the first column of the tools>options>view box. At the end the fonts will be a bit jagged ( anti-aliasing smoothes them). I have ubuntu 8.10 and the problem is related with NVIDIA accelerated graphics driver (version 96) since when I deactivated it and restarted the anti-aliasing would work in OO. Well, but without NVIDIA drivers one can't enable visual effects so it would be nice to be able to use 'screen font anti-aliasing' in OO with NVIDIA driver enabled. It has nothing to do with OO being 2.4 or 3.0. See my post at ubuntu forum:
http://ubuntuforums.org/showthread.php? ... ost6230724
ikis
 
Posts: 4
Joined: Sat Nov 22, 2008 9:59 pm

Now completely solved!

Postby ikis » Sun Nov 23, 2008 11:35 am

I deactivated nVidia driver and reactivated it some times to make some tests and now OpenOffice 'screen font anti-aliasing' is working perfectly well.
To put short, the solution could have been: uncheck 'screen font antialiasing' in OO tools>options>view; deactivate nVidia driver: restart; activate nVidia driver; restart; check 'screen font antialiasing' and it's done.
OOo 3.0.X on Ubuntu 8.x
ikis
 
Posts: 4
Joined: Sat Nov 22, 2008 9:59 pm

Re: [Solved] No text in OpenOffice menus

Postby Ross_Copeland » Mon Nov 24, 2008 7:13 am

How do I deactivate nVidia driver? I have tried unticking everything under Tools, but without any text I have no idea what I am Unticking. I am not sure that the order of things under Tools is the same as indicated by Bubba123.

I am using Open Office 2.4 with Ubuntu Linux 8.1
OOo 2.4.X on Ubuntu 8.x
Ross_Copeland
 
Posts: 5
Joined: Sun Nov 23, 2008 6:40 am

Re: [Solved] No text in OpenOffice menus

Postby roadstar » Mon Nov 24, 2008 1:50 pm

Thanks! Deactivatiing the video driver, unchecked anti-aliasing then reactivated the video driver and success :P

I thought it might be a font issue but didn't think it was also the video driver.

Thanks again.
OOo 3.0.X on Ubuntu 8.x
roadstar
 
Posts: 2
Joined: Sat Nov 22, 2008 9:18 pm

Re: [Solved] No text in OpenOffice menus

Postby ikis » Mon Nov 24, 2008 4:39 pm

roadstar, did you enable antialiasing again to see if it's working? 'Cause I reinstalled the system and now my own tips didn't work, so I had to disable the visual effects (System>Preferences>Appearance, go to 'Visual Effects' tab and select 'None').
Since yesterday it started to work kind of miraculously, maybe it will work again one of these days. But if anyone who knows how OOo works has any clues about what's happening maybe this issue could be fixed (although it's just an appearance issue, and I'm yet to discover if those ubuntu visual effects are really helpul in any way).
OOo 3.0.X on Ubuntu 8.x
ikis
 
Posts: 4
Joined: Sat Nov 22, 2008 9:59 pm

Re: [Solved] No text in OpenOffice menus

Postby Hagar Delest » Mon Nov 24, 2008 6:37 pm

Have you tried the Sun version of OOo? Many times in the past, it has proved to have less bug than the Ubuntu version of OOo (like the tiny dialog coming from macros for example).
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28595
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] No text in OpenOffice menus

Postby ikis » Mon Nov 24, 2008 8:07 pm

If you mean like in this tutorial:
viewtopic.php?f=74&t=68
I've already downloaded this file:
OOo_3.0.0_LinuxIntel_install_en-US_deb.tar.gz and extracted it.
Now I'm with version 3.0 updated via Update Manager. I wont change it now, but if it's that what you mean I'll replace it anytime.
OOo 3.0.X on Ubuntu 8.x
ikis
 
Posts: 4
Joined: Sat Nov 22, 2008 9:59 pm

Re: [Solved] No text in OpenOffice menus

Postby Hagar Delest » Mon Nov 24, 2008 10:43 pm

Yes, follow the tutorial. Remove the Ubuntu delivered version and install the one you've downloaded.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28595
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] No text in OpenOffice menus

Postby Ross_Copeland » Tue Nov 25, 2008 4:45 am

I removed NVidia 96 using Synaptic Package Manager (Linux). When I restarted my computer I got a pop up box saying my graphics were now in low resolution mode (I don't have the exact wording) and giving a choice of options, including restoring default setting. I restarted again and everything is back to normal. So it was a graphics problem not an Open Office problem. :D
OOo 2.4.X on Ubuntu 8.x
Ross_Copeland
 
Posts: 5
Joined: Sun Nov 23, 2008 6:40 am

Re: [Solved] No text in OpenOffice menus

Postby Ron Burgundy » Wed Nov 26, 2008 11:09 pm

There is an easier way to fix this one. It is absolutely related to the antialiasing and nVidia 96 driver. When you reset your "Visual Effects" to none, the nVidia 96 driver will work with antialiasing enabled. (This occurred when I upgraded to 8.10 thanks to the nVidia driver support in the new version. Also, I'm using OpenOffice 2.4.1.)

1. Ubuntu: System > Preferences > Appearance > Visual Effects Tab > None.
2. Open Office: Tools > OpenOffice.org Entry > View Entry > Uncheck "Screen font antialiasing."
3. Ubuntu: System > Preferences > Appearance > Visual Effects Tab > Normal/Extra.

It's worth noting that it looks awful without the antialiasing, but hey... at least you can see. :)

You stay classy.
Ron

ps. If you are attached to 96 and upset about the lack of antialiasing, there's an open bug for it, here: https://bugs.launchpad.net/ubuntu/+sour ... bug/294076. These are nVidia drivers, so support may not be forthcoming, but there are other solutions (xorg.conf tweaks) to get the Oo/QT3 apps working, again. Cheers.
OOo 2.4.X on Ubuntu 8.x + Windows XP Pro (32-bit)
Ron Burgundy
 
Posts: 1
Joined: Wed Nov 26, 2008 10:52 pm

Re: [Solved] No text in OpenOffice menus

Postby PhilippeFB » Tue Dec 30, 2008 5:28 pm

I had same issue, when "upgrading" my newly set up (from scratch, 2 days ago ) ubuntu 8.10 with the recommended NVIDIA-96 driver.
Tried installing and uninstalling several applications and fonts but issue definitely graphical.

I settled for "no visual effects" and "Screen font antialiasing", this is the most practical.

(I use already OOo 3.0 on XP and it's a bit of a dissapointment to go back to 2.4. Will attempt to upgrade soon)

Thanks for hints,

Philippe
PhilippeFB
 
Posts: 1
Joined: Tue Dec 30, 2008 5:08 pm

Re: [Solved] No text in OpenOffice menus

Postby promptcritical » Fri Jan 02, 2009 4:45 am

Actually I found the solution was simpler than deactivating anything. I got everything to work by changing the value for anti-aliasing. It just has to be greater than 13. Once I got to 14, everything worked normally.
OOo 3.0.X on Ubuntu 8.x
promptcritical
 
Posts: 1
Joined: Fri Jan 02, 2009 4:41 am

Re: [Solved] No text in OpenOffice menus

Postby Lawfer » Sat Jan 03, 2009 11:05 pm

This issue can be easily solved without having to disabling anti-aliasing . Thanks to the user "TexasRanger" who showed the right method to solve this, in the bugs section of launchpad.net, this issue can be easily solved by doing these few easy steps:

Run this command in the terminal; "sudo dpkg-reconfigure fontconfig-config" then select "Autohinter", "Always" (for subpixel rendering on LCD display), and "No" for Enable bitmapped fonts. Then, change in System/Preferences/Appearance/Fonts to "Subpixel" smoothing. Viola! Problem solved.

Now, something that "TexasRanger" forgot to mention was that, by enabling subpixel smoothing for the LCD display, fonts get bigger by enabling bold textures to them, so what you do to change that, right there in the fonts tab of the appearance menu, just below subpixel smoothing, you will see the "Details" button, just click it and it will open up another menu, now in the top left corner of the menu you will see an option to change the dots per inch values, just keep lowering the values until you get to the right size for the system fonts.

This problem might show as solved, but was probably solved by using the wrong/less convenient procedures. These few steps will allow you to see the Oo menu letters without having to disable anti-aliasing or without having to change the value of it. Hope it helped :)
OOo 2.4.X on Ubuntu 8.x + Windows XP Pro SP3
Lawfer
 
Posts: 1
Joined: Sat Jan 03, 2009 10:42 pm

Re: [Solved] No text in OpenOffice menus

Postby stanislove » Fri Nov 20, 2009 9:41 pm

Oh, Bubba123, you da Man! That worked as advertised, and I can use my spreadsheet again. Many Blessings!
OpenOffice 3.1 on Ubuntu 9.10
stanislove
 
Posts: 2
Joined: Thu Nov 19, 2009 2:03 am

Re: [Solved] No text in OpenOffice.org menus

Postby jmccoy » Wed Jun 09, 2010 7:45 pm

Bubba123, you've just gained another fan! I got the menu text open box problem after an Ubuntu kernel update, and tried all sorts of absurdly techie solutions before I came on your elegant solution. Thanks!
OpenOffice 3.0, Ubuntu 9.04
jmccoy
 
Posts: 1
Joined: Wed Jun 09, 2010 7:34 pm

Re: [Solved] No text in OpenOffice.org menus

Postby rclesueur » Sun Jul 25, 2010 7:06 pm

Hi guys and thanks for the suggestions. They don't work. Let me be more specific about what I'm running - Ubuntu Linux 10.04 and OO 3.2. When I go to option and then the dialog box that shows "OpenOffice.org-View" there are no checked boxes there at all. I've tried the "TexasRanger" solution and it does not work as described. There never comes up a selection for "Autohinter". The reconfigure program just runs and then completes. What other solutions might there be? I use a Samsung LCD screen, model number LS17MJCKS/XAA. Any other suggestions? :0)
Open Office 2.4 on Ubuntu 10
rclesueur
 
Posts: 1
Joined: Sun Jul 25, 2010 6:07 pm

Re: [Solved] No text in OpenOffice.org menus

Postby Hagar Delest » Sun Jul 25, 2010 10:05 pm

Have you tried to change the applications font in the Gnome>System preferences?
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28595
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests