[Solved] AOO 4.1.7 under Ubuntu 19.10 - Error on start

Issues with installing under all Linux Distributions

[Solved] AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Netzmeister » Wed Feb 26, 2020 4:42 pm

Hy everybody

I installed Ubuntu 19.10 on my computer (i7-7700, 32 GB RAM, 1 TB SSD). Unfortunately I get the following error messages when I start AOO 4.1.7:

Code: Select all   Expand viewCollapse view
** (soffice:14715): WARNING **: 08:25:26.834: Unknown type: GailWindow
Application Error

Fatal exception: Signal 6
Stack:
/opt/openoffice4/program/libuno_sal.so.3(+0x37c3a)[0x7efdeb816c3a]
/opt/openoffice4/program/libuno_sal.so.3(+0x37d6c)[0x7efdeb816d6c]
/opt/openoffice4/program/libuno_sal.so.3(+0x37e09)[0x7efdeb816e09]
/lib/x86_64-linux-gnu/libc.so.6(+0x46470)[0x7efdeaed3470]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xcb)[0x7efdeaed33eb]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x12b)[0x7efdeaeb2899]
/opt/openoffice4/program/libvcl.so(+0x1557b9)[0x7efde7adc7b9]
/opt/openoffice4/program/libsofficeapp.so(+0x2359b)[0x7efdeb57559b]
/opt/openoffice4/program/libvcl.so(+0x17ff0a)[0x7efde7b06f0a]
/opt/openoffice4/program/libuno_sal.so.3(+0x36a02)[0x7efdeb815a02]
/opt/openoffice4/program/libuno_sal.so.3(+0x37dea)[0x7efdeb816dea]
/lib/x86_64-linux-gnu/libc.so.6(+0x46470)[0x7efdeaed3470]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xcb)[0x7efdeaed33eb]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x12b)[0x7efdeaeb2899]
/lib/x86_64-linux-gnu/libfontconfig.so.1(+0x7805)[0x7efddf4a5805]
/lib/x86_64-linux-gnu/libfontconfig.so.1(+0x1cbf4)[0x7efddf4babf4]
/lib/x86_64-linux-gnu/libfontconfig.so.1(+0x1cf2e)[0x7efddf4baf2e]
/lib/x86_64-linux-gnu/libfontconfig.so.1(+0x1d079)[0x7efddf4bb079]
/lib/x86_64-linux-gnu/libfontconfig.so.1(FcFontMatch+0x71)[0x7efddf4bbe01]
/opt/openoffice4/program/libvcl.so(+0x137351)[0x7efde7abe351]
/opt/openoffice4/program/libvcl.so(+0x1373e2)[0x7efde7abe3e2]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager20countFontconfigFontsERSt8hash_mapIN3rtl7OStringEiNS2_11OStringHashESt8equal_toIS3_EE+0x35)[0x7efde7abfc17]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager10initializeEv+0x247)[0x7efde7acb21f]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager3getEv+0x49)[0x7efde7acc0e3]
/opt/openoffice4/program/libvclplug_gen.so(_ZN14X11SalGraphics14GetDevFontListEP15ImplDevFontList+0x2c)[0x7efde03db146]
/opt/openoffice4/program/libvcl.so(+0x25a05c)[0x7efde7be105c]
/opt/openoffice4/program/libvcl.so(+0x260bb4)[0x7efde7be7bb4]
/opt/openoffice4/program/libvcl.so(_ZNK12OutputDevice13GetTextHeightEv+0x12)[0x7efde7bea276]
/opt/openoffice4/program/libvcl.so(+0x2637fe)[0x7efde7bea7fe]
/opt/openoffice4/program/libvcl.so(_ZN12OutputDevice8DrawTextERK9RectangleRK6StringtPSt6vectorIS0_SaIS0_EEPS3_PN3vcl11ITextLayoutE+0x195)[0x7efde7bee5f5]
/opt/openoffice4/program/../program/libspl.so(+0x11a1e)[0x7efdccde9a1e]
/opt/openoffice4/program/../program/libspl.so(+0x1129c)[0x7efdccde929c]
/opt/openoffice4/program/../program/libspl.so(+0x128dd)[0x7efdccdea8dd]
/opt/openoffice4/program/libsofficeapp.so(+0x3c1ec)[0x7efdeb58e1ec]
/opt/openoffice4/program/../program/deployment.uno.so(+0x54938)[0x7efdc203a938]
/opt/openoffice4/program/libdeploymentmisc.so(_ZN7dp_misc16syncRepositoriesERKN3com3sun4star3uno9ReferenceINS2_3ucb19XCommandEnvironmentEEE+0x460)[0x7efdea38a170]
/opt/openoffice4/program/libsofficeapp.so(+0x3c290)[0x7efdeb58e290]
/opt/openoffice4/program/libsofficeapp.so(+0x2c8a7)[0x7efdeb57e8a7]
/opt/openoffice4/program/libvcl.so(+0x1807ef)[0x7efde7b077ef]
/opt/openoffice4/program/libvcl.so(_Z6SVMainv+0x1e)[0x7efde7b078ba]
/opt/openoffice4/program/libsofficeapp.so(soffice_main+0x9c)[0x7efdeb5a6ffc]
/opt/openoffice4/program/soffice.bin(main+0xb)[0x400f7b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3)[0x7efdeaeb41e3]
/opt/openoffice4/program/soffice.bin(__gxx_personality_v0+0xb9)[0x400eb9]


What I did
    Java 8 install and configure
    Code: Select all   Expand viewCollapse view
    sudo apt install openjdk-8-jdk
    sudo update-alternatives --config java
    sudo  update-alternatives --config javac
    export JAVA_HOME=$(readlink -f /usr/bin/java | sed "s:bin/java::")

      Alternative: JRE 8 von https://www.java.com/en/download/linux_manual.jsp downloaded, extracted and moved to /opt/Oracle_Java/
      Code: Select all   Expand viewCollapse view
      sudo update-alternatives --install "/usr/bin/java" "java" "/opt/Oracle_Java/jre1.8.0_VERSION/bin/java" 1
      sudo update-alternatives --install "/usr/bin/javaws" "javaws" "/opt/Oracle_Java/jre1.8.0_VERSION/bin/javaws" 1
      sudo update-alternatives --set "java" "/opt/Oracle_Java/jre1.8.0_VERSION/bin/java"
      sudo update-alternatives --set "javaws" "/opt/Oracle_Java/jre1.8.0_VERSION/bin/javaws"

    OpenOffice 4.1.7 install
    Code: Select all   Expand viewCollapse view
    sudo apt install -y wget
    wget https://sourceforge.net/projects/openofficeorg.mirror/files/4.1.7/binaries/de/Apache_OpenOffice_4.1.7_Linux_x86-64_install-deb_de.tar.gz
    tar xvf Apache_OpenOffice_4.1.7_Linux_x86-64_install-deb_de.tar.gz
    cd de/DEBS
    sudo dpkg -i *.deb
    cd desktop-integration
    sudo dpkg -i *.deb


When I googled, I didn't find any usable solutions.

I tried both types of Java: openjdk-8-jdk and jre-8u241 . The hint: https://forum-test.openoffice.org/en/fo ... 16&t=85895 does not help to solve the prolbem. Still the same error (see above).

On Ubuntu 18.04.1 I do not have problems to start AOO 4.1.7.

Who has an idea how I can solve the problem? Thank you in advance for your help!
Last edited by robleyd on Thu Feb 27, 2020 7:46 am, edited 3 times in total.
Reason: Add green tick
OpenOffice 4.1.7 on Ubuntu 19.10
Netzmeister
 
Posts: 7
Joined: Wed Feb 26, 2020 4:32 pm

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Villeroy » Wed Feb 26, 2020 6:37 pm

It looks as if some libraries are no longer compatible with your environment which is not a big surprise since OpenOffice is unmaintained since too many years. OpenOffice is not a Java program. 95% of it can be used without any Java being installed on the computer.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28651
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby RoryOF » Wed Feb 26, 2020 6:41 pm

On Xubuntu 18.04.4 OO 4.1.7 gives such an error when started in a terminal ((in terminal type openoffice4) but runs OK.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31541
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Villeroy » Wed Feb 26, 2020 7:20 pm

Code: Select all   Expand viewCollapse view
$ /opt/openoffice4/program/soffice
Gtk-Message: 18:16:00.201: Failed to load module "canberra-gtk-module"

** (soffice:23289): WARNING **: 18:16:00.209: Unknown type: GailWindow

This is just a warning about some missing gtk widgets or something. The program starts with warnings. Same warnings since many years. But the errors that occur under 19.10 refer to C++ libraries. I would think that OpenOffice needs to be recompiled for that platform (if possible).
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28651
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Netzmeister » Wed Feb 26, 2020 7:46 pm

Thanks. All canberra-gtk-modules are installed. Thats an idea. To compile it. I'll try.
OpenOffice 4.1.7 on Ubuntu 19.10
Netzmeister
 
Posts: 7
Joined: Wed Feb 26, 2020 4:32 pm

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Villeroy » Wed Feb 26, 2020 7:53 pm

Netzmeister wrote:Thanks. All canberra-gtk-modules are installed. Thats an idea. To compile it. I'll try.

Compiling OpenOffice makes a grown man cry. All Linux distributions come with a well working LibreOffice suite.
Last edited by Villeroy on Wed Feb 26, 2020 7:54 pm, edited 1 time in total.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28651
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby RoryOF » Wed Feb 26, 2020 7:53 pm

I didn't get the gailwindow error starting a pre-release version of OpenOffice in a terminal in Xubuntu 20.04.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31541
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby RoryOF » Wed Feb 26, 2020 8:17 pm

It is my understanding that the canberra modules are to do with sound; the gailwindow is something to do with GNOME Accessibility Implementation Library; from its name I think it should be graphic related rather than sound related.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31541
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Netzmeister » Wed Feb 26, 2020 8:44 pm

Build failed. Error: "No package 'gnome-vfs-2.0' found" .gnomevfs and libs are installed:

Code: Select all   Expand viewCollapse view
ii  gvfs:amd64
ii  gvfs-backends
ii  gvfs-bin
ii  gvfs-common
ii  gvfs-daemons
ii  gvfs-fuse
ii  gvfs-libs:amd64
ii  libgnome2-vfs-perl
ii  libgnomevfs2-0:amd64
ii  libgnomevfs2-bin
ii  libgnomevfs2-common
ii  libgnomevfs2-extra:amd64
ii  samba-vfs-modules:amd64
OpenOffice 4.1.7 on Ubuntu 19.10
Netzmeister
 
Posts: 7
Joined: Wed Feb 26, 2020 4:32 pm

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby RoryOF » Wed Feb 26, 2020 9:13 pm

Build problems should be queried on the Dev mailing list at dev@openoffice.apache.org

Use synaptic to see that you have installed a vfs version greater than 2.0. In 18.04.4, the version offered is 1.36.1; version 2.24 needs to be specifically chosen and installed.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31541
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Netzmeister » Wed Feb 26, 2020 10:28 pm

Ok. Thats the problem. On 19.10 vfs 1.42.1 is installed.
OpenOffice 4.1.7 on Ubuntu 19.10
Netzmeister
 
Posts: 7
Joined: Wed Feb 26, 2020 4:32 pm

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby RoryOF » Wed Feb 26, 2020 10:35 pm

I think Synaptic will offer you a higher version, but you need to select and install it.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31541
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Netzmeister » Wed Feb 26, 2020 10:39 pm

Yes. The packages of libgnomevfs2 are 2.24.4-6.

My reason for installing AOO was the extension writer2epub. I know it for years. LibreOffice 6 includes an epub-Export. But it is not so configurable as the writer2epub Extension.

I'll import the odt Document to calibre and convert it there to an epub.

For me. It is ok.

Thanks for your help!
OpenOffice 4.1.7 on Ubuntu 19.10
Netzmeister
 
Posts: 7
Joined: Wed Feb 26, 2020 4:32 pm

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Netzmeister » Wed Feb 26, 2020 10:44 pm

By the way. How do I "close" the post?
OpenOffice 4.1.7 on Ubuntu 19.10
Netzmeister
 
Posts: 7
Joined: Wed Feb 26, 2020 4:32 pm

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby RoryOF » Wed Feb 26, 2020 11:07 pm

You go to your first post, select Edit from its the top right, put [Solved] at the start of the Subject line, and check the green tick radio button.

I normally use Calibre's ability to generate an electronic reader file of whatever sort is needed from an .odt file.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31541
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Villeroy » Wed Feb 26, 2020 11:43 pm

https://wiki.documentfoundation.org/Rel ... PUB_export

Netzmeister wrote:My reason for installing AOO was the extension writer2epub. I know it for years. LibreOffice 6 includes an epub-Export. But it is not so configurable as the writer2epub Extension.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28651
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] AOO 4.1.7 under Ubuntu 19.10 - Error on start

Postby Netzmeister » Thu Feb 27, 2020 6:54 am

;-) Thanks
OpenOffice 4.1.7 on Ubuntu 19.10
Netzmeister
 
Posts: 7
Joined: Wed Feb 26, 2020 4:32 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest