[Solved] Cannot Meet Dependencies

Issues with installing under all Linux Distributions

[Solved] Cannot Meet Dependencies

Postby alphagenius » Mon Dec 16, 2019 1:21 pm

I am using Linux Mint 19.2 Tina Cinnamon and I am trying to install OpenOffice using the DEB files, I downloaded the latest version and the also the language pack. I unzip them and I started installing OpenOffice one DEB at a time. Everything went great but now I am down to just a few files left, and I cannot go any further because they all depend on “openoffice-en-US.” I thought that I had installed that DEB already but I thought maybe I was wrong. I tried again and it was already installed. I even tried reinstalling it but still I get nothing. Will someone please help me fix this so that I can finish installing OpenOffice?
Last edited by MrProgrammer on Mon Dec 16, 2019 10:24 pm, edited 1 time in total.
Reason: Tagged ✓ [Solved]
OpenOffice 4.1.7
Kubuntu 20.04
alphagenius
 
Posts: 13
Joined: Mon Dec 16, 2019 12:44 pm
Location: Tennessee

Re: Cannot Meet Dependencies

Postby RoryOF » Mon Dec 16, 2019 1:58 pm

My experience, using Xubuntu 18.04, was that I downloaded the deb version from the download page (linked off the OpenOffice icon at bottom right of Forum window). Expand that file, then in a terminal do

Code: Select all   Expand viewCollapse view
sudo apt purge libreoffice*


to remove all traces of LibreOffice. If you do not wish to do this, then read no further.

Then
Code: Select all   Expand viewCollapse view
cd ~/Downloads/en-US/DEBS
sudo dpkg -i *.deb
cd desktop-integration
sudo dpkg -i *.deb


the en-US portion of the directory path may differ according to the language version you downloaded.

I cannot recollect that I had to download anything else to satisfy dependencies.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31535
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Cannot Meet Dependencies

Postby Bill » Mon Dec 16, 2019 6:46 pm

alphagenius wrote:I downloaded the latest version

Was this the EN-US version or some other language?
alphagenius wrote:...and the also the language pack.

What language?
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7911
Joined: Sat Nov 24, 2007 6:48 am

Re: Cannot Meet Dependencies

Postby alphagenius » Mon Dec 16, 2019 6:53 pm

This was the en-US version.
OpenOffice 4.1.7
Kubuntu 20.04
alphagenius
 
Posts: 13
Joined: Mon Dec 16, 2019 12:44 pm
Location: Tennessee

Re: Cannot Meet Dependencies

Postby Bill » Mon Dec 16, 2019 8:15 pm

I loaded LM 19.2 on a live USB and ran into the same problem when using GDEBI to install the packages one at a time. Try using dpkg to install the packages that GDEBI won't install.
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7911
Joined: Sat Nov 24, 2007 6:48 am

[SOLVED] Re: Cannot Meet Dependencies

Postby alphagenius » Mon Dec 16, 2019 8:23 pm

Since I did not get to many things installed on the laptops with Linux Mint, I decide to start over and put Debian KDE on them. I am working to get things setup now. When I get to OpenOffice and I run into any more problems, I will be sure to come back to these forums. Thanks everyone for your input.
OpenOffice 4.1.7
Kubuntu 20.04
alphagenius
 
Posts: 13
Joined: Mon Dec 16, 2019 12:44 pm
Location: Tennessee


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests