How do I stop alt from selecting the file menu?

Issues with installing under all versions of MS Windows

How do I stop alt from selecting the file menu?

Postby Question » Thu Dec 27, 2018 4:58 am

Im alt-tabbing between openoffice calc and another program to fill in data, and pressing alt seems to select the file menu. This is slowing me down a lot. Instead of alt-tabbing back to open office and then typing, I have to select the cell again before I can start typing.
OOo 3.2 on Windows 7
Question
 
Posts: 13
Joined: Sun Sep 28, 2008 12:32 pm

Re: How do I stop alt from selecting the file menu?

Postby RusselB » Thu Dec 27, 2018 5:59 am

From the conversation at https://superuser.com/questions/309005/disable-the-activation-of-the-menu-bar-when-alt-is-pressed-in-windows-7, it appears that it is possible using 3rd party software, but not via a Windows setting.
I've not used the 3rd party software referred to in the conversation, thus I recommend using it with caution if you decide to do so.
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
RusselB
Volunteer
 
Posts: 4875
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: How do I stop alt from selecting the file menu?

Postby Bill » Fri Dec 28, 2018 1:59 am

Please confirm that you're using OOo 3.2 on Windows 7. There was a bug in some older versions of OOo, but that was only on Linux, not Windows. You should have to release the Alt key before the File menu pops up which wouldn't interfere with Alt-tabbing.

Issue 81846 - Alt key menu behavior changed in Linux from 2.2->2.3, and is now inconsistent with Windows
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7157
Joined: Sat Nov 24, 2007 6:48 am

Re: How do I stop alt from selecting the file menu?

Postby Question » Mon Jan 28, 2019 10:07 pm

Bill wrote:Please confirm that you're using OOo 3.2 on Windows 7. There was a bug in some older versions of OOo, but that was only on Linux, not Windows. You should have to release the Alt key before the File menu pops up which wouldn't interfere with Alt-tabbing.

Issue 81846 - Alt key menu behavior changed in Linux from 2.2->2.3, and is now inconsistent with Windows


Well, when i alt-tab, i release the alt key...theres no way to get OO to change what alt does?
OOo 3.2 on Windows 7
Question
 
Posts: 13
Joined: Sun Sep 28, 2008 12:32 pm

Re: How do I stop alt from selecting the file menu?

Postby Bill » Mon Jan 28, 2019 10:55 pm

Are you using Alt-Ctrl-Tab instead of just Alt-Tab? That doesn't work in my OS and I have no idea how it works in Windows 7.
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7157
Joined: Sat Nov 24, 2007 6:48 am

Re: How do I stop alt from selecting the file menu?

Postby RusselB » Tue Jan 29, 2019 3:06 am

When you press the Tab key, are you still holding down the Alt key? If you aren't, then the release of the Alt key activates the menu, then the Tab key does, whatever it does at that point.
To do a Window change/cycle, you have to hold the Alt key down while pressing the Tab key. This sequence is part of the Windows OS, and has been since version 3.0
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
RusselB
Volunteer
 
Posts: 4875
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: How do I stop alt from selecting the file menu?

Postby Question » Wed Jan 30, 2019 7:15 am

Okay to clarify, lets say that I have OO as the main window right.

So I press alt+tab to switch to the 2nd window.

Then I press alt+tab to switch back to OO.

When i switch back to OO, i find that OO has selected the file menu which is not what i want it to do. I dont have any issues doing this in any other application like notepad ++ or whatever, this is an OO specific thing.
OOo 3.2 on Windows 7
Question
 
Posts: 13
Joined: Sun Sep 28, 2008 12:32 pm

Re: How do I stop alt from selecting the file menu?

Postby Bill » Wed Jan 30, 2019 6:54 pm

That doesn't happen on my system running Linux. I don't have a Windows system to test, so I don't know if this is a Windows thing or something that may be happening because of some setting on your system. There is no option to change the way it works in AOO.

Issue 80604 - lone alt keybinding in menu considered harmful
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7157
Joined: Sat Nov 24, 2007 6:48 am


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 5 guests