Page 1 of 1

[Solved] Error 1935 on Vista

PostPosted: Tue Dec 18, 2007 1:53 pm
by gchris
hi all,

I tried to upgrade my OpenOffice with 2.3.1 version but i got an Error 1935 with these informations (i translate them from french) :

Error 1935. An error occur during the assembly installation : di_types,publicKeyToken="ce2cb7e279207b9e", version="1.1.11.0",culture="neutral".
For more informations, bla bla bla ....

My PC is a Dell Laptop with Windows Vista Int├ęgral

For the installation i did :

- Uninstall previous openoffice version
- Download official package from fr.openoffice.org

I found informations on fews board for this trouble but all tips are for windows XP and are not up to date for vista.

Hope we will find a solution with your help

Regards

Christophe

Re: Error 1935 on Vista

PostPosted: Tue Dec 18, 2007 2:24 pm
by Bill
Did you search the forum for the error and try anything which has already been suggested?

Re: Error 1935 on Vista

PostPosted: Tue Dec 18, 2007 2:45 pm
by gchris
hi Bill,

Yes, i found information about trouble with .NET so i tried to upgrade it but a message appear telling that .NET is int├ęgrated to system and can't be upgraded.
I tried all solutions i found on the board but none permit the installation...

Re: Error 1935 on Vista

PostPosted: Tue Dec 18, 2007 3:30 pm
by gchris
hi,

I post here the solution i just found that permit the correct installation :

- In the the /windows/system32 directory you'll find a file named 'mscoree.dll'
- rename mscoree.dll to mscoreebak.dll
- install OpenOffice
- rename mscoreebak.dll to mscoree.dll

That's all

Hope this will help

Regards

Christophe

Re: [Solved] Error 1935 on Vista

PostPosted: Fri Jul 11, 2008 7:51 am
by rABiD_kittEn
Thanks, Christophe, for putting your solution here!

I have been battling with Vista trying to install OpenOffice. I have updated my Firefox, & then switched to IE to try to update .NET to 3.5. I came to find out that that was a waste of a lot of time. I took the time to download Vista's SP1, to find that it was already installed (oops)!

When I read your solution, I had a lot of trouble trying to get "permission" to rename the file. That did eventually do it for me, so thanks. But, I wanted to add a link in here for anyone who is having trouble renaming the file, even when they are logged in as Administrator.

To find out how to get "permission" to change the file name: http://www.tech-recipes.com/rx/2204/vista_how_to_take_ownership_system_file

Re: [Solved] Error 1935 on Vista

PostPosted: Thu Dec 04, 2008 10:19 pm
by moxtundra
tried that solution and i got the same error message. i have not been able to update vista for over six months because of their problems. (I tried real hard. I quit trhing.) maybe that's it. too bad. I lost open office 2.4. Guess that's it for open office for me. Thanks Bill Gates!

Re: [Solved] Error 1935 on Vista

PostPosted: Sun Feb 15, 2009 2:22 pm
by saintdanny
Hi Christophe,

I was able to install Openoffice3 after I renamed the mscoree.dll file to mscoreebak.dll as suggested. But I had to get "permission" to rename the file so I followed rABiD_kittEn suggestion and followed the instructions in http://www.tech-recipes.com/rx/2204/vis ... ystem_file .

The steps are shown in blue below:
1. Click the Start button.
2. Click All Programs.
3. Go into Accessories.
4. Right-click on Command Prompt.
5. Select Run as administrator.
6. When the UAC Prompt appears, click Continue.
Once you have your elevated command prompt, follow these steps:
For our example, we are going to use the Bubbles screensaver file (Bubbles.scr)
1. At the command prompt, input takeown /f filepath (takeown /f c:\windows\system32\Bubbles.scr).
2. Press Enter on the keyboard.
3. A message will be displayed that this completed successfully.
4. Now input icacls filepath /grant yourusername:f (icacls c:\windows\system32\Bubbles.scr /grant shamanstears:f).
5. A message will be displayed that this completed successfully.
You will now be able to modify or replace the file. When you are done, simply remove the permissions to keep the file secure.


One inportant thing is that I had to rename mscoreebak.dll to mscoree.dll as later when I used Microsoft XPS document writer, there was an error message regarding mscoree.dll. It worked again after I renamed mscoreebak.dll to mscoree.dll .

My only question remains is that how do you "remove the permissions to keep the file secure" as in the last point 5 above?

Thanks to all for the solutions.

Re: [Solved] Error 1935 on Vista

PostPosted: Sat Oct 03, 2009 6:46 am
by channyb
Hello all,

This problem has occurred on me whilst I was trying to install OpenOffice v3.1. Thank you to all the help you guys have provided me. I was able to install OpenOffice successfully by renaming mscoree.dll to mscoreebak.dll and then later renaming it back to mscoree.dll after the installation.

As a Windows Vista user, I had a lot of trouble granting permission. Apart from using the Command Prompt, an alternative way is to follow the steps on given on http://www.tipandtrick.net/2008/how-to-take-ownership-and-full-control-permissions-of-files-and-folders-in-vista/. Permission can then be easily removed by following http://www.vistax64.com/tutorials/159360-trustedinstaller-restore-owner.html.

It has taken me 2 long, frustrating days to sort things out. Hope this post has helped anyone in need.

Re: [Solved] Error 1935 on Vista

PostPosted: Wed Dec 02, 2009 7:21 pm
by Plux
I managed to rename the mscoree.dll to mscoreebak.dll, but I still get the 1935 error!! :(

Any other sollutions?

Re: [Solved] Error 1935 on Vista

PostPosted: Wed Dec 02, 2009 7:43 pm
by Hagar Delest
Have you searched the forum? There are plenty topics about that 1935 error.

Re: [Solved] Error 1935 on Vista

PostPosted: Tue Mar 23, 2010 5:25 pm
by ritergal
Hooray! This worked. Not only did OO 3.2 not install properly, 3.1 was trashed in the process, and system restore didn't recover it. I was ready to reformat and reinstall Vista. This tip worked, and learning how to obtain permission to mess with system files is a mighty fine bonus.

Re: [Solved] Error 1935 on Vista

PostPosted: Wed Dec 29, 2010 6:51 am
by ravendawson
I used to get vista error 1935 when trying to install OpenOffice. Tried versions 2.4 & 2.3.1 and currently running Windows Vista Ultimate 32-bit and my OpenOffice is running fine before the reinstall.

I tried disabling Anti-Virus software and Windows Firewall, uninstalling .NET and using Aaron Stebner's cleanup tool. I also tried setting the install folder permissions to full control for "Everyone".

Unfortunately, none of the above actions worked.

After doing further research, it turned out to be a .NET problem. Being that I'm on Vista I couldn't uninstall/reinstall .NET so I had to update it to .NET 3.5. This update was failing too and I had to run the following two commands in the command prompt (Start > All Programs > Accessories > Right-Click Command Prompt and click Run as Administrator):

sfc /scannow
%windir%\Microsoft.NET\Framework\v2.0.50727\ngen.exe update

That let me install the .NET 3.5 update which in turn allowed me to install OpenOffice 3.1. Hope this helps anyone who experiences the same issue.

Re: [Solved] Error 1935 on Vista

PostPosted: Thu Jan 26, 2012 1:21 pm
by AlexisSmith077
Its a very irritating error, i also faced this error many times but i fixed it.
Following are the various ways you can implement to fix error 1935

1. Reinstall Microsoft .NET Framework
2. Perform a Full Virus Scan
3. Full Scan your Registry
4. Reregister Windows Installer
5. Check System Files for Corruption
6. Clean the System Junk

The Error 1935 in Windows 7 may still occur if your registry is not properly configured.
If you have already been experiencing the error 1935 error, you can also get some help from this article.

ezinearticles.com/?Error-1935-Windows-7---What-Causes-Windows-7-Error-1935,-How-Can-We-Fix-It?&id=5242325

Hope it fix your problem.