[Solved] Windows Defender prevents file opening

Issues with installing under all versions of MS Windows

[Solved] Windows Defender prevents file opening

Postby jackimsw » Mon Dec 25, 2017 10:49 pm

today when I tried to open my calc sheet the message error came up from windows defender and it just took me to the short cut link when I clicked to allow ap. I've used this for a long time so it has to be something in microsoft. I have question into their forum. I lost the sheet and it's not a problem because we are at the end of the year but it won't let me save in new year. same error so I uninstalled openoffice and it now won't let me reinstall. So I don't know what to do. Hope someone here can help.
Attachments
error message.png
error message.png (43.42 KiB) Viewed 3329 times
Last edited by thomasjk on Tue Dec 26, 2017 7:26 pm, edited 1 time in total.
Reason: Mark thread [Solved] and add green checkmark
jackimsw
 
Posts: 2
Joined: Mon Dec 25, 2017 10:40 pm

Re: Windows Defender prevents file opening

Postby Hagar Delest » Tue Dec 26, 2017 12:48 pm

Hi and welcome to the forum!

Before resetting the profile, I would first try to add OpenOffice to the whitelist of Defender.
Else, try: reset your OpenOffice user profile.

Please add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.5 on Xubuntu 18.04 and on Windows 7 (with winPenPack port).

Of fline until Sep. 1st.
User avatar
Hagar Delest
Moderator
 
Posts: 28155
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Windows Defender prevents file opening

Postby Bill » Tue Dec 26, 2017 3:09 pm

Soffice.bin has been blocked by Controlled Folder Access. You need to change the Virus & threat protection settings to allow soffice.bin through Controlled Folder Access.

Security System Change Windows Defender Controlled Folder Access Settings - Windows 10
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6762
Joined: Sat Nov 24, 2007 6:48 am

Re: Windows Defender prevents file opening

Postby John_Ha » Tue Dec 26, 2017 3:26 pm

Bill wrote:Soffice.bin has been blocked by Controlled Folder Access.

You might need to do it for all the AOO exe files as well - swriter.exe, scalc.exe etc.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5671
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Windows Defender prevents file opening

Postby jackimsw » Tue Dec 26, 2017 4:40 pm

Since I'm not a programmer the directions to go in and change files just seemed a bit to complicated for this old mind. It was like going back to my first computer that didn't even have windows. Since I realized/remembered that I just started using the defender again and I've used the open office only in the old virus protection mode I simply took out everything that was old and connected to open office, restarted, turned off the folder control in defender and downloaded it again and this time it went through no problem. Back in business so to speak. Keep it simple guys when giving some of us directions. There is easier fixes.
OpenOffice4.1 on Windows 10
jackimsw
 
Posts: 2
Joined: Mon Dec 25, 2017 10:40 pm

Re: Windows Defender prevents file opening

Postby Bill » Tue Dec 26, 2017 4:44 pm

I haven't found it necessary to allow the .exe files. Allowing the .exe files without allowing soffice.bin doesn't solve the problem. Allowing soffice.bin without allowing the .exe files does. It's the same for LibreOffice.

Defender Controlled folder access exception for LibreOffice
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6762
Joined: Sat Nov 24, 2007 6:48 am

Re: Windows Defender prevents file opening

Postby John_Ha » Tue Dec 26, 2017 5:23 pm

Bill wrote:I haven't found it necessary to allow the .exe files. Allowing the .exe files without allowing soffice.bin doesn't solve the problem. Allowing soffice.bin without allowing the .exe files does. It's the same for LibreOffice.[/url]

That suggests soffice.bin is the I/O handler for all the AOO applications meaning only it needs to be enabled in Defender. I note that when I start only swriter.exe, soffice.bin is also started.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5671
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Windows Defender prevents file opening

Postby John_Ha » Tue Dec 26, 2017 5:26 pm

jackimsw wrote:Keep it simple guys when giving some of us directions.

Bill's instructions were short, correct and simple to follow; and the link gave mind-boringly detailed instructions. Basically he told you that "you must tell Windows Defender that AOO is an authorised application". It is a Windows Defender problem, not an AOO problem.

If your problem is solved please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5671
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Windows Defender prevents file opening

Postby Bill » Wed Dec 27, 2017 4:04 pm

Adding soffice.bin as an allowed app in the Controlled Folder Access (CFA) settings solves the problem of using OpenOffice if it is already installed, but removing and trying to reinstall OpenOffice creates a second problem.

Some of the default settings in the AOO installation aren't compatible with CFA. While turning off CFA is one option, that turns off the ransomware protection. Another option is to keep CFA enabled and change a couple of settings during the installation.

If CFA is enabled, the Desktop is protected and unpacking the AOO installation files in the default Installation Files folder on the Desktop will be blocked by CFA. The solution is to change the location for unpacking. Change the Destination Folder when asked to "Choose Install Location" on the OpenOffice 4.1.4 Setup window. The Downloads folder isn't protected by CFA so a subfolder of the Downloads folder should work. The only other modification to the installation settings is to uncheck the option to create a link on the Desktop on the OpenOffice 4.1.4 - Installation Wizard. That will also be blocked. A link on the Desktop can be added manually after the installation is complete.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6762
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Windows Defender prevents file opening

Postby John_Ha » Thu Dec 28, 2017 6:00 pm

Bill wrote:Some of the default settings in the AOO installation aren't compatible with CFA. While turning off CFA is one option, that turns off the ransomware protection. Another option is to keep CFA enabled and change a couple of settings during the installation.

It's probably worth while to submit that as a bug or enhancement request.

Hundreds and thousands of applications must be affected. Is this typical ******* Microsoft arrogance? For years and years people have been writing stuff to the desktop and to My Documents, and ******* Microsoft now decides that is forbidden. Why not just ask the user if they will allow it??????
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5671
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Windows Defender prevents file opening

Postby John_Ha » Tue Jan 02, 2018 1:14 pm

See also Re: General error or General input/output error opening word where files may be corrupted in the user profile.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5671
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 8 guests