Page 1 of 1

Spell Checking

PostPosted: Sat Nov 04, 2017 7:04 am
by jimjinphx
I'm having multiple problems with spellcheck after installing Version 4.1.4

I) I tried "%appdata%\OpenOffice\4" without any luck.

2) I tried a manual reset of user, but there was no "Roaming" subfolder (I have done this before successfully).

3) I tried uninstalling OpenOffice completely and got an error message "Please exit OpenOffice 4.1.4 and the OpenOffice 4.1.4 Quickstarter etc." No OpenOffice items were open and Quickstarter was not checked on.

4) I even tried uninstalling in safe mode unsuccessfully.

Any suggestions to fix this would be most appreciated.

Jim

Re: Spell Chceking <g>

PostPosted: Sat Nov 04, 2017 4:19 pm
by erbsenzahl
Try out programs like REVO uninstaller or any you can find on the internet, there are some.

Also try the portable version of Apache OpenOffice; it is still 4.1.3 version. Or X-Apache Office, also 4.1.3 version. Or try out Libreoffice.
Cheers

Re: Spell Chceking <g>

PostPosted: Sat Nov 04, 2017 4:55 pm
by Bill
You can't reset the user profile if soffice is running. Open the Task Manager and close all soffice processes.

Re: Spell Chceking <g>

PostPosted: Sun Nov 05, 2017 8:45 pm
by jimjinphx
Thanks for the soffice suggestion. For some reason the "Roaming" subfolder was (and remains) hidden. By searching for soffice, the subfolder showed up and that allowed me to change the user (again). Anyone have any idea why this is such a recurring problem?

Re: Spell Checking

PostPosted: Mon Nov 06, 2017 12:58 am
by robleyd
RoryOF has mentioned likely causes here and here and here, among many other posts.

Re: Spell Checking

PostPosted: Mon Nov 06, 2017 2:34 am
by Bill
For Windows 10, the Roaming folder can be opened by clicking the Start button and typing %appdata% or by typing %appdata% in the File Explorer Address Bar and pressing Enter. It is not hidden from either method. It is only hidden when trying to navigate to it by clicking on folders in the File Explorer window. %appdata% is the environment variable that Windows interprets as C:\Users\<user>\AppData\Roaming.

Re: Spell Checking

PostPosted: Sat Nov 25, 2017 7:01 pm
by Prenchant
I hate to add to the crowd struggling with Spellcheck, but I would very much appreciate help getting it to work.

Platform: Windows 10, OO 4.1.4

Symptom:
Spellcheck has never worked; when run, it immediately reports no errors on pages with errors

Trouble shooting efforts:
Upgraded to 4.1.4
Renamed the User directory twice
Downloaded and installed English language extension file. When run it a second time, it reports that the files already exist (enabled)

Present settings:
When Spellcheck is run, the "Text Language" box is empty; when the "Spellcheck is complete" OK button is clicked, the pop-up disappears so it's not possible to see if any languages are listed in the "Text Language" drop-down.
At Options/Language/, everything set to default
At Options/Language/Writing Aids, the "Available language modules" box is empty.; "User defined dictionaries" all checked
Largest file in the folders under C:\Users\[my name]\AppData\Roaming\OpenOffice\4\user\extensions is 135 bytes

Re: Spell Checking

PostPosted: Sat Nov 25, 2017 10:00 pm
by RoryOF
When you renamed the User directory and restarted OpenOffice, were you prompted for your Name/initials?

Re: Spell Checking

PostPosted: Sat Nov 25, 2017 11:23 pm
by Prenchant
Yes

Re: Spell Checking

PostPosted: Sat Nov 25, 2017 11:35 pm
by RoryOF
I suggest - and this is a wild guess - installing a language module over your existing installation, even if the same language. You can download the language module from http://www.openoffice.org/download/, making the version selection using the dropdowns and pressing the right-hand button below them.

Re: Spell Checking

PostPosted: Sat Nov 25, 2017 11:40 pm
by floris v
Does this only happen with new documents that you start by right clicking in the Windows desktop and selecting `OpenDocument - Text`? That method is flawed, for some reason the created documents doesn't have a proper language assigned. So, better start new documents in LibreOffice.

Re: Spell Checking

PostPosted: Sat Nov 25, 2017 11:43 pm
by RoryOF
Or start them via Text document from the Start Center, which offers links to all the OO applications.

Re: Spell Checking

PostPosted: Sat Nov 25, 2017 11:44 pm
by floris v
RoryOF wrote:Or start them via Text document from the Start Center, which offers links to all the OO applications.

That's what I meant. :)