[Solved] AOO 4.1.3 spell check won't work

Issues with installing under all versions of MS Windows

[Solved] AOO 4.1.3 spell check won't work

Postby KevanJ » Tue Feb 28, 2017 6:24 pm

Running 4.1.3 ona Windows 7 laptop which I have networked to a server. The spell checker doesn't work. Re-installed the English Language Extension still no success. Suspect a path issue but it isn't clear where the OO looks for the dictionary. The AOO files sit in an application data folder on the server.

Tried the OOo spell checker troubleshooter but it appears to refer to an older version and doesn't seem applicable to the latest one.
Last edited by Hagar Delest on Tue Mar 14, 2017 10:07 pm, edited 1 time in total.
Reason: tagged [Solved].
OpenOffice 4.1 on Windows 7
KevanJ
 
Posts: 6
Joined: Tue Feb 28, 2017 6:01 pm

Re: AOO 4.1.3 spell check won't work

Postby RoryOF » Tue Feb 28, 2017 6:25 pm

The quick cure for this is to rename the OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter. Open File
Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer
Address Bar and press Enter. Rename the "user" folder - "user.old" is a
good choice. Start OpenOffice.

This cures most spellcheck problems
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28132
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.3 spell check won't work

Postby KevanJ » Wed Mar 01, 2017 6:04 pm

Done that, no joy. The spell check with underline button is highlighted but does not pick up errors whilst typing. Highlighting text with errors and clicking the spell check with blue tick button just flashes up no errors.
OpenOffice 4.1 on Windows 7
KevanJ
 
Posts: 6
Joined: Tue Feb 28, 2017 6:01 pm

Re: AOO 4.1.3 spell check won't work

Postby RoryOF » Wed Mar 01, 2017 6:19 pm

What language is shown for the text in middle of the bottom bar (the Status Bar) of OO window? This should be the same as the language selected in /Tools /Options/ Language settings /Languages : "Default languages for documents" : Western. If it is not, use /Tools /Language /For all text to change the text to the installed language. If that fixes the spellcheck problem we can work on a permanent fix.

When you deleted the OO User Profile, were you prompted for Name/Initials on next startup?:
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28132
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.3 spell check won't work

Postby Hagar Delest » Wed Mar 01, 2017 10:08 pm

The tutorial still applies.
Have you tried with a new file created from the AOO interface or from a right click in the Windows (file) Explorer?
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28347
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: AOO 4.1.3 spell check won't work

Postby KevanJ » Thu Mar 02, 2017 6:41 pm

RoryOF

The document shows "English (UK)". this is the same as the Tools/Options/Language Settings/Languages shows in "User Interface"; "Locale"; and "Default Languages for Documents - Western".
----------------------------------------------------------------------------------------------------------------
Hagar

From the Apache Open Office 4 start screen I select "Text Document" which gives me a new blank page in writer. No spell check.
----------------------------------------------------------------------------------------------------------------
From the "Options - Language Settings - Writing Aids" the "Available language modules" field is blank. Should it not display "English"?
OpenOffice 4.1 on Windows 7
KevanJ
 
Posts: 6
Joined: Tue Feb 28, 2017 6:01 pm

Re: AOO 4.1.3 spell check won't work

Postby RoryOF » Thu Mar 02, 2017 6:52 pm

In Available Language modules, check Hunspell SpellChecker, Libhyphen Hyphenator, OpenOffice.org New Thesaurus. Under Options on same screen check "Check spelling as you type". Go to Language Settings : Languages and for "Default languages for Documents : Western" select English (UK) or as appropriate.

It may help to restart OpenOffice after these changes.
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28132
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.3 spell check won't work

Postby KevanJ » Mon Mar 06, 2017 6:28 pm

Available language modules field is blank and the "Edit" button is greyed out.
OpenOffice 4.1 on Windows 7
KevanJ
 
Posts: 6
Joined: Tue Feb 28, 2017 6:01 pm

Re: AOO 4.1.3 spell check won't work

Postby tonyooffice » Tue Mar 14, 2017 1:20 pm

thank you RoryOF for your answer about changing the user profile to restore the spell checker brilliant.
openoffice 4.1.3 on windows 10
tonyooffice
 
Posts: 1
Joined: Tue Mar 14, 2017 1:06 pm

Re: AOO 4.1.3 spell check won't work

Postby RoryOF » Tue Mar 14, 2017 1:25 pm

To prevent this happening again, be leisurely in your closing down (powering off or hibernating) of the computer after properly closing your OO file and OO.

Use the formal computer closedown procedure and wait for a few seconds before powering off to be certain all disk activity has ceased - damage to the spellchecker often occurs if the computer is powered down before the hardware/software write buffers have flushed. It is only a matter of a few seconds - these few extra seconds will be less than the time needed to correct the problem, or, more likely, to rebuild a damaged file which can also occur through such over-hasty shutdown.
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28132
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO 4.1.3 spell check won't work

Postby RoryOF » Tue Mar 14, 2017 1:32 pm

KevanJ wrote:Available language modules field is blank and the "Edit" button is greyed out.


If "Available language modules" is blank your OpenOffice installation may be incomplete. You might install a language pack for your desired language (even if your OO installation is for that language). If that does not populate "Available language modules", then you should reinstall OO, using a fresh download only from http://www.openoffice.org/download/
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28132
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] AOO 4.1.3 spell check won't work

Postby KevanJ » Mon May 08, 2017 2:29 pm

This is still not solved for me but I haven't had the time to look at it for a few weeks.
I uninstalled AOO. I backed up the registry and then removed all reference to OpenOffice.
I downloaded a new installer and reinstalled AOO. I updated the language pack.
Still no spell checker.
I have en_gb files in ...\Application Data\OpenOffice\4\user\uno_packages\cache\uno_packages\svmrx5.tmp and in ...\Application Data\OpenOffice\4\user\extensions\bak\extensions\svmp5h.tmp. These include en_gb.dic; hyph_en_gb.dic; en_gb.aff. svmrx5.tmp includes the folder dict-en-20170501.oxt. I tried copying this folder directly into the extensions folder with no result. I then stripped out the files directly into the extensions folder but again this doesn't give the desired result.
The path is correct for my installation and everything else in AOO works fine apart from the spelling, hyphenation and thesaurus.
On the "Options - Language Settings - Writing Aids" pop-up menu the Available Writing Aids box is still blank.
Can somebody please tell me which files I should have where to make this work. My old OO 3 worked fine so this is really frustrating.
OpenOffice 4.1 on Windows 7
KevanJ
 
Posts: 6
Joined: Tue Feb 28, 2017 6:01 pm

Re: [Solved] AOO 4.1.3 spell check won't work

Postby RoryOF » Mon May 08, 2017 2:38 pm

Did you explicitly delete the old OpenOffice user profile? This must be done explicitly; otherwise a fresh install of OO will pick it up, maintaining the faulty setting.

The quick cure for this is to rename the OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter. Open File
Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer
Address Bar and press Enter. Rename the "user" folder - "user.old" is a
good choice. Start OpenOffice.

This cures most spellcheck problems. Do nothing else until you see if this works.
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28132
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] AOO 4.1.3 spell check won't work

Postby KevanJ » Mon May 08, 2017 2:45 pm

I had tried renaming the user folder previously and have tried it again now following your instructions precisely, still no success.
OpenOffice 4.1 on Windows 7
KevanJ
 
Posts: 6
Joined: Tue Feb 28, 2017 6:01 pm


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 1 guest