OO4 on Windows, no English Dictionary; download/install fail

Issues with installing under all versions of MS Windows

OO4 on Windows, no English Dictionary; download/install fail

Postby materribile » Wed Sep 18, 2013 7:13 am

Somehow my OO4 installation lost its English Language dictionary and everything is wavy-red underlined. I downloaded the matching dictionary and Firefox asked if I wanted to open it. I said I did, with OO4. It didn't find the file. I hunted it down with a Windows search and attempted to install it with the extensons manager. Unfortunately, what I have is a directory (folder) with the correct file-extension which the OO4 extension manager's invocation of the file-browse window just won't open. Every attempt to open it takes me down into the directory instead of turning it over to OO4 and installing it.

What am I doing wrong?
OpenOffice.org 3.4.1 AOO341m(Build:9593) - Rev. 1372282
Windows 7 64 bit
materribile
 
Posts: 3
Joined: Wed Jun 12, 2013 6:46 pm

Re: OO4 on Windows, no English Dictionary; download/install

Postby RoryOF » Wed Sep 18, 2013 7:18 am

Please verify, at system level, that the file extension is .oxt not .zip. Some browsers (IE particularly) silently rename .oxt to .zip and one needs to rename them back to .oxt for OpenOffice to know what to do with them.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31534
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: OO4 on Windows, no English Dictionary; download/install

Postby Bill » Wed Sep 18, 2013 8:55 am

materribile wrote:Somehow my OO4 installation lost its English Language dictionary and everything is wavy-red underlined. I downloaded the matching dictionary and Firefox asked if I wanted to open it. I said I did, with OO4. It didn't find the file. I hunted it down with a Windows search and attempted to install it with the extensons manager. Unfortunately, what I have is a directory (folder) with the correct file-extension which the OO4 extension manager's invocation of the file-browse window just won't open. Every attempt to open it takes me down into the directory instead of turning it over to OO4 and installing it.

What am I doing wrong?

When all words become underlined, it's usually a corruption of the user profile. You should try resetting your user profile instead of downloading and installing another English dictionary.

[Tutorial] The OpenOffice User Profile
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7909
Joined: Sat Nov 24, 2007 6:48 am

Re: OO4 on Windows, no English Dictionary; download/install

Postby NotLeftBehind » Mon Sep 23, 2013 4:05 am

Hmmm, my account was removed from the database? Was there a databases conversion that went bad?

Anyway, am having the same issue. Downloaded dict-en.oxt (from the OpenOffice update) on two computers. Vista and XP. Both have same issue: every document's words are underscored in red and no settings in the spelling section changes that.

:crazy:
OpenOffice 4 on XP and Vista
NotLeftBehind
 
Posts: 53
Joined: Mon Sep 23, 2013 3:57 am
Location: NC, USA, Earth, Sector 001

Re: OO4 on Windows, no English Dictionary; download/install

Postby RoryOF » Mon Sep 23, 2013 10:54 am

Your registration under that User name is on the other forum.

In both cases, delete or rename your User Profile. Details are at
[Tutorial] The OpenOffice User Profile

 Edit: Have you checked the file type of the downloads? Some browsers silently rename them to .zip. You should rename then to .oxt and then install them as they won't have installed using the wrong extension. 
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31534
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: OO4 on Windows, no English Dictionary; download/install

Postby fthynne » Sat Jan 04, 2014 2:45 am

On updating OO from 3 to 4 and again on 4.0.0 to 4.0.1 the British dictionary was not working. Renaming ...\Application_Data\OpenOffice\\4\user to user.old and restarting OO fixed that. Exporting my personal macro libraries using the old profile and importing to the new profile worked, but I shouldn't have needed to do that, and I couldn't find a way to retain my toolbar customisations. Is the failure to migrate the user profile correctly after an OO update logged as a bug?
OO 4 on Ms Windows XP + Linux
fthynne
 
Posts: 16
Joined: Fri Oct 10, 2008 9:10 pm

Re: OO4 on Windows, no English Dictionary; download/install

Postby Hagar Delest » Sat Jan 04, 2014 1:19 pm

I don't think it has been logged as a bug, you can check: [Tutorial] Reporting bugs or suggestions.
But the feature may fail in some cases due to changes in the profile structure.
You can try to copy files from your former profile to the new one and check if you recover the customization: [Tutorial] The OpenOffice User Profile.
perhaps customization is not only in the registrymodifications.xcu file.
Or you can try to keep the reset profile, backup it and restart the transfer data, once completed, close AOO of course and replace the registrymodifications.xcu file by the reset version.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28995
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 6 guests