[Solved] Saved documents are only in machine language

Issues with installing under all versions of MS Windows

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sat Oct 20, 2012 8:18 am

The sample document looks like it is misinterpreting an included picture (perhaps a .pdf - too early in my morning for exact analysis). Perhaps a useful test is to ask 75FXE if he can open this document properly
Attachments
Monkey.odt
(64.14 KiB) Downloaded 221 times
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28919
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sat Oct 20, 2012 10:59 am

You say you are pasteing data into Notepad, saving it as txt, and then it does not open correctly in OpenOffice?

I can't see how you are pasteing pictures into Notepad; I've just tried, and as I remembered and have just confirmed, notepad does not have filters for pictures as it is a very basic editor - little more than the computer equivalent of a pocket notebook.

Wordpad may offer more facilities and you could try that, but to be frank, I can't see why you cannot paste direct into OpenOffice Writer; I think we should explore that path. In what way is pasteing into Writer deficient? Remember that in OpenOffice /Edit there are two Paste options, plain ordinary dumb Paste and Pastte Special, which allows pasteing in various formats, dependent on the formatting of the original data.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28919
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sat Oct 20, 2012 4:33 pm

Usually problem-free for me also, but only been with v3.4.1 a few weeks and likewise with WIN7 prior was v3.3 and VISTA. What I am doing is activating from the Notepad icon in the taskbar and saving as whatever default is, usually .txt. This is the first example of the problem out of many uses of this, therefore somewhat unique. It has happened at least one other time. As far as pictures goes, I don't recall saying that, but if so, sorry to mislead. This specific case was assembling a mailing list by visiting individual websites, copy & pasting solo or lists of addresses onto the notepad document, then later organizing them by location with another copy/paste within the document. Oops, sorry, just noticed you had two responses, so to be explicit, if any graphics are there it is unintended or some sort of encroaching pollution - none of my sources included graphics or photos. As to the "can I open the doc" yes, I get the top address in normal text, then the rest of the document is in machine language. I don't recall any pdf source, but certainly is possible since it was online, but multiple sites were involved so doubt all would have been pdf,
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sat Oct 20, 2012 6:02 pm

Did you try my document monkey.odt two posts before this? It should give you a paragraph of text, then a nice picture of Fay Wray being terrorised by the real King Kong (the 1933 one).
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28919
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby peterroots » Sat Oct 20, 2012 9:31 pm

I am no expert on the insides of odt files but this one looks seriously messed up. Sure it opens but it contains, what look like to me, bits of at least 2 odt files and when opened it is displaying part of the xml content of one of them as text.
Some of what you describe as 'machine language' would appear to be the xml tags of styles and the configuration information about something or other you have that provides status bar information, popups and other bits and pieces. I have no idea what this is.
Your document seems to be using complex text layout for Asian text using a variety of fonts like Microsoft YaHei (A Chinese font) and Mangal (a Hindi Font) - Perhaps you 'Machine Language' is your systems attempt to display these characters without the right fonts. Do you have either of the above fonts installed?
LibreOffice 4.0.3 OpenSUSE 12.3 : OpenOffice 4 Linux Mint 15
User avatar
peterroots
Volunteer
 
Posts: 299
Joined: Mon Mar 03, 2008 6:33 pm
Location: UK

Re: Saved documents are only in machine language, not text

Postby peterroots » Sat Oct 20, 2012 9:41 pm

Just realised that I missed the few posts above as I had not spotted the second page of posts! oops
Aside from the fragments of at least 2 odt files there is a thumbnail image of one of your addresses which would support Rory's suggestion that perhaps you have copied and pasted an image of text, rather than text somewhere. (but not sure how you could have done that via notepad)
LibreOffice 4.0.3 OpenSUSE 12.3 : OpenOffice 4 Linux Mint 15
User avatar
peterroots
Volunteer
 
Posts: 299
Joined: Mon Mar 03, 2008 6:33 pm
Location: UK

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sun Oct 21, 2012 4:47 am

I just copy/pasted from a link sent me to a blog column. The article contained both text and photos. I opened a "New Text Document by right clicking on my desktop, selecting New, then selecting New Text Document. Everything seems to have saved properly, even pictures, and once again, the default file extension was that extension that does not exist in AOO: .txt. I'm going back now to see if this one opens properly.....Well, I saved it in both the default .txt, and as a rich text doc just to see if anything differin g happened....both were the same when reopened, perfect text, no pictures. When I saved it the second time, an icon flashed on the desktop too briefly to read, but I did see the beginning started "~lock" . Given the other hassles I had with locked spreadsheets I'm wondering how that factors in.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sun Oct 21, 2012 4:53 am

RoryOF wrote:Did you try my document monkey.odt two posts before this? It should give you a paragraph of text, then a nice picture of Fay Wray being terrorised by the real King Kong (the 1933 one).


I followed your King Kong link and it opened properly, text and big black grasping paw picture.

Again, something new to me with v3.4.1 that may shed light: each time I use Save As I get a pop-up entitled ASCII filter listing three lines to select: language, font, character set. Never encountered this prior to the latest go-round. I'm attaching a snip for review just in case.
Attachments
AOO Save As pop-up filter.PNG
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby kingfisher » Sun Oct 21, 2012 7:33 am

That right-click option almost certainly has nothing to do with AOO. Create a desktop short cut for Writer from the programs menu if you like to work that way.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sun Oct 21, 2012 7:46 am

Without detailed overview of your actual method of working, it seems to me that there may be some problem attaching to the method by which you are building your files. Your ability to open ranges.odt and monkey.odt (posted earlier in this thread) getting similar results to others suggest that your OpenOffice installation is correct. An ASCII filter request on opening a file usually suggests one of two things - either you have saved the file without a valid file extension, or OpenOffice is confused about the internals of the file. This latter can happen if the file is corrupted (frequent occurence, often due to hasty computer shutdown) or it can be a genuine query trying to sort out the structure of a text file (much rarer occurence).

If the notepad you refer to and use in attempting to build your files is Windows Notepad (check by /Help / About in that program) then I strongly suggest you cease using it and use OpenOffice Writer to build your files, adjusting your pasteing from ihe Internet by judicious use of /Edit /Paste and /Edit /Paste Special to get a result you find satisfactory. Save your files using /File /Save As, selecting the file type by using the dropdown filetype selector and ensuring that the "Automatic file name extension" box is checked.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28919
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby peterroots » Sun Oct 21, 2012 6:10 pm

I am with Kingfisher on this - a new text file, from a desktop right click has nothing to do with AOO it is a text file that can contain text, only text and nothing but text! Pasting in
both text and photos
is not going to work. If you want to create an .odt (OpenDocumentText) file (that can contain text, images etc) then you need to use AOO.
LibreOffice 4.0.3 OpenSUSE 12.3 : OpenOffice 4 Linux Mint 15
User avatar
peterroots
Volunteer
 
Posts: 299
Joined: Mon Mar 03, 2008 6:33 pm
Location: UK

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sun Oct 21, 2012 6:23 pm

I have removed the notepad icon so as not to trigger future problems. My choices now are from rightr clicking on the desktop which yields a number of document options: WORD,Journal, WIN.zip, OO Presentation, OO Spreadsheet, Open Document Drawing, New text document .txt which opens as OO writer with full surrounding OO toolbars, measuring grids frame. (Opens after selecting the three options from the ASCII options pop-up.)
Properties show it as OO 1.1 and plants a ~lock mirror on the desktop

New Rich Text Document also opens as OO writer (.rtf) with full surrounding OO toolbars, measuring grids frame. The ASCII options pop-up does not appear.
Properties show it as OO without specified version.

The ASCII Filter Options pop-up appears on most, possibly all of my OO docs from prior use - annoying, but not on the .rtf or .odt docs.

" use of /Edit /Paste and /Edit /Paste Special to get a result you find satisfactory". This is new terminology to me which I shall have to snoop out.

" Save your files using /File /Save As, selecting the file type by using the dropdown filetype selector and ensuring that the "Automatic file name extension" box is checked." I assume I will have these options since I will not be using the .txt TO WHICH OPEN OFFICE DEFAULTS.

My behavior when using OO will now change to avoid things with which I had no problems in years past use of OO (start 2008?) My vexations are now: 1 how to prevent the spreadsheets from resuscitating the ~lock mirror after I manually change attribute, delete mirror, save result, 2 get rid of the new ASCII filter options pop-up that appears on every use of an old file, 3 Salvage the file written in whatever it is that was my origination of this thread.
I have saved it with a number of extensions hoping to convert, but unsuccessfully. I attach a snip of the folder menu in case it may trigger a thought.

Thanks again to all for all the effort you've expended trying to rescue this dummy.
Attachments
AOO Ranges saved versions.PNG
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby peterroots » Sun Oct 21, 2012 7:13 pm

The ASCII Filter Options pop-up appears on most, possibly all of my OO docs from prior use
suggest that they are not actually openoffice files.
I have saved it with a number of extensions hoping to convert, but unsuccessfully
nope, changing the extension changes the extension, that is all it does. You end up with whatever file type you started with, but with the wrong extension - confuses everything. The only way to fix it is to put the extension back to what it should be
LibreOffice 4.0.3 OpenSUSE 12.3 : OpenOffice 4 Linux Mint 15
User avatar
peterroots
Volunteer
 
Posts: 299
Joined: Mon Mar 03, 2008 6:33 pm
Location: UK

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sun Oct 21, 2012 7:21 pm

The only way to change a file type successfully is to use Save As, and change the file type using the dropdown options. These invoke different filters to change the save format as needed.

Suppose you have a stall at a cake sale. Putting a "fruit cake" label on a cream sponge cake does not turn it into a fruit cake; if a fruit cake is required, it has to start earlier, passing through the "filters" of the fruit cake recipe. Changing the file type is simply relabelling the file - it doesn't change what is in the package.

There are exceptions, mostly concerned with plain text files which, if of the correct format, may need to be relabeled for correct import into spreadsheets; these are not in question at this time.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28919
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby 75FXE » Mon Oct 22, 2012 3:47 am

peterroots wrote:
The ASCII Filter Options pop-up appears on most, possibly all of my OO docs from prior use
suggest that they are not actually openoffice files.

I'm uploading a snip of the properties pop-up on the first one I found. It thinks it is OO 1.1, but what would it know? It seems to think it was modified a couple years befor being created....









I have saved it with a number of extensions hoping to convert, but unsuccessfully
nope, changing the extension changes the extension, that is all it does. You end up with whatever file type you started with, but with the wrong extension - confuses everything. The only way to fix it is to put the extension back to what it should be
I'll dump the extras, then save in all the files types I'm offered, probably .txt or all files if the original conditions return. The reason for trying this was that once before, appx2-3 years ago this happened on a file, and the advice that solved it was to change the extension. Unfortunately, I lost that file with the failure of my Vista machine so can't relate details.
Attachments
Propertries of Franklin file.PNG
Propertries of Franklin file.PNG (12.22 KiB) Viewed 10513 times
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby kingfisher » Mon Oct 22, 2012 4:34 am

Looking at the snapshot attached to your post of Mon 22.10.12 3:23 am, you have a rich mixture of formats. If you want to standardise your files to open document formats, you will have to do one of the following with each file in some other format:
* open the file with AOO and save it as a file using an open document format or
* copy and paste to a file created in open document format with AOO.

PS: Your signature needs to be updated.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Re: Saved documents are only in machine language, not text

Postby Bill » Mon Oct 22, 2012 6:55 am

75FXE wrote:I have removed the notepad icon so as not to trigger future problems. My choices now are from rightr clicking on the desktop which yields a number of document options: WORD,Journal, WIN.zip, OO Presentation, OO Spreadsheet, Open Document Drawing, New text document .txt which opens as OO writer with full surrounding OO toolbars, measuring grids frame. (Opens after selecting the three options from the ASCII options pop-up.)

You are missing an option to create a new OpenDocument Text document. That is the option you need to create a document in the native file format for Writer, having the .odt file name extension.

75FXE wrote:Properties show it as OO 1.1...

The complete Type of file in Properties is "OpenOffice.org 1.1 Text (.txt). That is a plain text document, not an OpenDocument Text document.

75FXE wrote:... and plants a ~lock mirror on the desktop

That's normal. AOO always creates a ~lock file when a file is opened. It is normally closed automatically when the file is closed.

75FXE wrote:" Save your files using /File /Save As, selecting the file type by using the dropdown filetype selector and ensuring that the "Automatic file name extension" box is checked." I assume I will have these options since I will not be using the .txt TO WHICH OPEN OFFICE DEFAULTS.

Writer doesn't generally default to .txt. It will default to .txt if you open a .txt file.

75FXE wrote:I attach a snip of the folder menu in case it may trigger a thought.

Your system is set to open .txt files with AOO. That, combined with creating files by right-clicking on the desktop and selecting New > Text Document (.txt) is why you have .txt files instead of .odt files. If you wan't to use the native .odt files, create new files by opening Writer and selecting New > Text Document. When you save this new document, the format should default to .odt instead of .txt.
Bill
Volunteer
 
Posts: 7216
Joined: Sat Nov 24, 2007 6:48 am

Re: Saved documents are only in machine language, not text

Postby Hagar Delest » Mon Oct 22, 2012 10:08 am

And please change the default application for .txt. Set it to Notepad for example. AOO being associated to .txt seems to be the main problem and misunderstanding here.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28474
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Saved documents are only in machine language, not text

Postby 75FXE » Tue Oct 23, 2012 3:42 am

PS: Your signature needs to be updated.

Thank-you for the link to the profile page I previously visited trying to update o/s & version back when I posted it here. I still can't find where to change it. I'm looking for the keywords Vista, 3.3 or for a footer and I just don't see the location, nor do I see a line to fill in o/s or version.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby 75FXE » Tue Oct 23, 2012 4:00 am

Bill wrote:
75FXE wrote:I have removed the notepad icon so as not to trigger future problems. My choices now are from rightr clicking on the desktop which yields a number of document options: WORD,Journal, WIN.zip, OO Presentation, OO Spreadsheet, Open Document Drawing, New text document .txt which opens as OO writer with full surrounding OO toolbars, measuring grids frame. (Opens after selecting the three options from the ASCII options pop-up.)

You are missing an option to create a new OpenDocument Text document. That is the option you need to create a document in the native file format for Writer, having the .odt file name extension. OK H-m-m-m-m...........

75FXE wrote:Properties show it as OO 1.1...

The complete Type of file in Properties is "OpenOffice.org 1.1 Text (.txt). That is a plain text document, not an OpenDocument Text document.

OK, so if Properties say it is aqn Open document, that really means it is not an OO document.....pretty crafty.


75FXE wrote:... and plants a ~lock mirror on the desktop

That's normal. AOO always creates a ~lock file when a file is opened. It is normally closed automatically when the file is closed. OK, I'll buy that.

75FXE wrote:" Save your files using /File /Save As, selecting the file type by using the dropdown filetype selector and ensuring that the "Automatic file name extension" box is checked." I assume I will have these options since I will not be using the .txt TO WHICH OPEN OFFICE DEFAULTS.

Writer doesn't generally default to .txt. It will default to .txt if you open a .txt file. OK, it was doing it on everything I did since I was using the icon I've since deleted.

75FXE wrote:I attach a snip of the folder menu in case it may trigger a thought.

Your system is set to open .txt files with AOO. That, combined with creating files by right-clicking on the desktop and selecting New > Text Document (.txt) is why you have .txt files instead of .odt files. If you wan't to use the native .odt files, create new files by opening Writer and selecting New > Text Document. When you save this new document, the format should default to .odt instead of .txt.
I'm now gathering that what I thought was AOO actually wasn't. My new o/s has a MS starter set built in that wasn't there in Vista. Apparently the icon that used to send me to AOO no longer does but the menu names remain the same.


One other part to this mess has been cleared up - as part of the spreadsheets creating mirror lock files and marking all folders Read-Only. This apparently is a known flaw in MS o/s since XP which happens randomly in XP VISTA, WIN7 and Microsoft has chosen not to develop a fix:
http://itexpertvoice.com/home/fixing-the-windows-7-read-only-folder-blues/
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby Bill » Tue Oct 23, 2012 5:12 pm

75FXE wrote:
Bill wrote:
75FXE wrote:I have removed the notepad icon so as not to trigger future problems. My choices now are from rightr clicking on the desktop which yields a number of document options: WORD,Journal, WIN.zip, OO Presentation, OO Spreadsheet, Open Document Drawing, New text document .txt which opens as OO writer with full surrounding OO toolbars, measuring grids frame. (Opens after selecting the three options from the ASCII options pop-up.)

You are missing an option to create a new OpenDocument Text document. That is the option you need to create a document in the native file format for Writer, having the .odt file name extension. OK H-m-m-m-m...........

75FXE wrote:Properties show it as OO 1.1...

The complete Type of file in Properties is "OpenOffice.org 1.1 Text (.txt). That is a plain text document, not an OpenDocument Text document.

OK, so if Properties say it is aqn Open document, that really means it is not an OO document.....pretty crafty.


75FXE wrote:... and plants a ~lock mirror on the desktop

That's normal. AOO always creates a ~lock file when a file is opened. It is normally closed automatically when the file is closed. OK, I'll buy that.

75FXE wrote:" Save your files using /File /Save As, selecting the file type by using the dropdown filetype selector and ensuring that the "Automatic file name extension" box is checked." I assume I will have these options since I will not be using the .txt TO WHICH OPEN OFFICE DEFAULTS.

Writer doesn't generally default to .txt. It will default to .txt if you open a .txt file. OK, it was doing it on everything I did since I was using the icon I've since deleted.

75FXE wrote:I attach a snip of the folder menu in case it may trigger a thought.

Your system is set to open .txt files with AOO. That, combined with creating files by right-clicking on the desktop and selecting New > Text Document (.txt) is why you have .txt files instead of .odt files. If you wan't to use the native .odt files, create new files by opening Writer and selecting New > Text Document. When you save this new document, the format should default to .odt instead of .txt.
I'm now gathering that what I thought was AOO actually wasn't. My new o/s has a MS starter set built in that wasn't there in Vista. Apparently the icon that used to send me to AOO no longer does but the menu names remain the same.

How did you come to that conclusion? Does it say "MS starter" in your document title bars? I don't recall any previous mention of MS starter.


75FXE wrote:One other part to this mess has been cleared up - as part of the spreadsheets creating mirror lock files and marking all folders Read-Only. This apparently is a known flaw in MS o/s since XP which happens randomly in XP VISTA, WIN7 and Microsoft has chosen not to develop a fix:
http://itexpertvoice.com/home/fixing-the-windows-7-read-only-folder-blues/

What is a "mirror lock file"? Is that the lock file created by AOO when a document is opened? I don't see how this is connected to folder attributes or the "machine language" problem.
Bill
Volunteer
 
Posts: 7216
Joined: Sat Nov 24, 2007 6:48 am

Previous

Return to MS Windows

Who is online

Users browsing this forum: No registered users and 6 guests