Randomly Slow Copy & Paste?

Issues with installing under all versions of MS Windows

Randomly Slow Copy & Paste?

Postby alexe » Mon May 12, 2008 12:08 pm

Hi,

I'd appreciate some help - but have not found much on Google or FAQs so far.

We have a few Windows XP PC's running Open Office 2.4. Generally things are good.

However, sometimes it takes several seconds (~10) to paste something _out_ of OO into another application - like from Office Writer to a text editor, database form, etc. Frustratingly, a few minutes later a copy & paste is instantaneous - so hard to see what's going on exactly. But it seems Open Office specific.

When the problem does show, it seems like it takes time (~10 secs) from the first attempted CTRL-V paste to actually "unlock" and actually paste the clipboard content. This is particularly frustrating for some of our users doing data entry.

This is on a reasonably performant 1 Gig RAM PC, which is idling. It just seems as if somehow the cut & paste buffers are "locked" for a few seconds.

Though this does seem Open Office specific, I do wonder if Windows Clipboard, AVG anti-virus and/or ZoneAlarm might be adding to the issue?

Thanks in advance for your help,

Alex
alexe
 
Posts: 1
Joined: Mon May 12, 2008 11:41 am

Re: Randomly Slow Copy & Paste?

Postby squenson » Tue May 13, 2008 10:04 pm

I have similar behavior from time to time, mainly when I copy lines of code from one macro to another. As you described, it seems that the PC is frozen for a few seconds, but it buffers the keystrokes normally. And it only happens with OOo, never with any other software. I checked the CPU usage and could not notice anything special. It never disappeared by itself, I had to completely stop soffice.bin and soffice.exe and restart the quickloader to eliminate the problem... until the next time it happened. I have noticed that since I upgraded my PC, this is happening much less.
LibreOffice 4.2.3.3. on Ubuntu 14.04
User avatar
squenson
Volunteer
 
Posts: 1885
Joined: Wed Jan 30, 2008 9:21 pm
Location: Lausanne, Switzerland

Re: Randomly Slow Copy & Paste?

Postby Phil » Wed May 14, 2008 10:08 am

Hi,

this is a very interesting behavior - although I cannot reproduce it on my system (OOo 2.4.0 on Win XP Pro SP2).
However, a couple of other people seem to have the problem as well: Issue 49907 exactly describes the problem.
So I would strongly recommend to vote for that issue!

Apart from CPU usage - did you check memory usage? Maybe the copy&paste action allocates a lot of memory. If it cannot be provided, the system may have to swap memory, which can result in a notable delay.

Alex, you could also try what squenson did: Restart OOo by closing all its application and ending the quick starter via the tray icon.
Could be interesting to know if the problem then stops (temporarily).

KR, phil
OOo 3.0.1 & DEV-3.1 • WinXP pro 32-bit + SP3 + current patches
Looking for OpenOffice-related information? Try the search engine on OpenOfficeNinja - a great tool!
My favorite extension: Alt. Find & Replace for Writer. All you need and much more...
OOo 2.4.X on Ms Windows XP
Phil
Volunteer
 
Posts: 802
Joined: Fri Nov 30, 2007 5:35 pm
Location: Germany

Re: Randomly Slow Copy & Paste?

Postby Phil » Wed May 14, 2008 10:38 am

I forgot one point:
alexe wrote:Though this does seem Open Office specific, I do wonder if Windows Clipboard, AVG anti-virus and/or ZoneAlarm might be adding to the issue?

This could indeed be the case!
Maybe you could both try to find out if the problem persists if all protection software (personall firewall, antivirus, antispyware etc.) is shut down.
This information could also be helpful for the developpers to fix that bug.

KR, phil
OOo 3.0.1 & DEV-3.1 • WinXP pro 32-bit + SP3 + current patches
Looking for OpenOffice-related information? Try the search engine on OpenOfficeNinja - a great tool!
My favorite extension: Alt. Find & Replace for Writer. All you need and much more...
OOo 2.4.X on Ms Windows XP
Phil
Volunteer
 
Posts: 802
Joined: Fri Nov 30, 2007 5:35 pm
Location: Germany

Re: Randomly Slow Copy & Paste?

Postby squenson » Wed May 14, 2008 9:04 pm

I do have AVG anti-virus and do not have Zone Alarm, so this can be an indication. As there is a totally new version of AVG (version 8.0), may be the problem will not reproduce. At least it didn't in the past 10 minutes!
LibreOffice 4.2.3.3. on Ubuntu 14.04
User avatar
squenson
Volunteer
 
Posts: 1885
Joined: Wed Jan 30, 2008 9:21 pm
Location: Lausanne, Switzerland

Re: Randomly Slow Copy & Paste?

Postby Phil » Thu May 15, 2008 9:48 am

OK, this is an indication that AVG Antivirus could be the cause.
Alex, which version of AVG Antivirus are you using?
squenson, maybe you can post a follow-up whether the issue is resolved for you.

Thanks!
phil
OOo 3.0.1 & DEV-3.1 • WinXP pro 32-bit + SP3 + current patches
Looking for OpenOffice-related information? Try the search engine on OpenOfficeNinja - a great tool!
My favorite extension: Alt. Find & Replace for Writer. All you need and much more...
OOo 2.4.X on Ms Windows XP
Phil
Volunteer
 
Posts: 802
Joined: Fri Nov 30, 2007 5:35 pm
Location: Germany

Re: Randomly Slow Copy & Paste?

Postby the-wes » Fri Jun 13, 2008 4:31 pm

This is happening to me also, and I am not running AVG or Zonealarm. I do run Clamwin, but it still happens when I shut it down. It is nearly 100% of the time for me.
OOo 2.4.X on Ms Windows XP
the-wes
 
Posts: 1
Joined: Fri Jun 13, 2008 4:26 pm

Re: Randomly Slow Copy & Paste?

Postby Phil » Fri Jun 13, 2008 5:05 pm

Hi the-wes and welcome to the forum!
Do you run any other system protection software like anti-spyware etc.?

I am not quite sure, but the other descriptions in this thread say it is occasionally happening, however you seem to encounter the problem almost all the time.
What status is the system in when this happens? You can check the state (i.e. CPU and Memory consumption) using the task manager. Or use Windows Sysinternals Process Explorer for a more in-depth analysis.

HTH!
phil
OOo 3.0.1 & DEV-3.1 • WinXP pro 32-bit + SP3 + current patches
Looking for OpenOffice-related information? Try the search engine on OpenOfficeNinja - a great tool!
My favorite extension: Alt. Find & Replace for Writer. All you need and much more...
OOo 2.4.X on Ms Windows XP
Phil
Volunteer
 
Posts: 802
Joined: Fri Nov 30, 2007 5:35 pm
Location: Germany

Re: Randomly Slow Copy & Paste?

Postby affinity » Sun Aug 31, 2008 4:36 pm

I'm also experiencing this. Its quite frustrating, although it doesn't stop me going back to Office just yet, but if I have loads of copying and pasting I have to. I am running on Vista, I have Zonealarm and Avast!.
Thanks
affinity
 
Posts: 2
Joined: Sun Aug 31, 2008 4:29 pm

Re: Randomly Slow Copy & Paste?

Postby Phil » Mon Sep 01, 2008 3:56 pm

Hi affinity and welcome to the forum!

Does it occur permanently or occasionally in your case?

Can you check the status of your system (i.e. CPU and Memory consumption) when this happens using the task manager and let us know.
Or use Windows Sysinternals Process Explorer for a more in-depth analysis.

You could also try to Reset user's application profile.

Regards, phil
OOo 3.0.1 & DEV-3.1 • WinXP pro 32-bit + SP3 + current patches
Looking for OpenOffice-related information? Try the search engine on OpenOfficeNinja - a great tool!
My favorite extension: Alt. Find & Replace for Writer. All you need and much more...
OOo 2.4.X on Ms Windows XP
Phil
Volunteer
 
Posts: 802
Joined: Fri Nov 30, 2007 5:35 pm
Location: Germany

Re: Randomly Slow Copy & Paste?

Postby ahkow » Thu Sep 04, 2008 4:09 pm

I have experienced these slowness in both my XP Pro SP2 and Vista Ultimate SP1 64-bit.
The XP one has Kaspersky Antivirus which has Auto-Protect disabled, the Vista one does not have antivirus.
Both of them run Windows Firewall.
Both machines run Thunder from www.xunlei.com, which is a file downloader that watches the clipboard.
Both of the machine experience clipboard slowness.

Let's define two operations:
-Operation A = Copy from Writer and paste to other programs
-Operation B = Copy from a non-OOo program and paste to other programs, including Writer.

This is what I found out in the Vista machine:
Experiment 1: Run Writer, then run Thunder.
-Operation A and B are fast.

Experiment 2: Run Thunder, then run Writer.
-Operation A is noticeably slow. I have to wait about 5 seconds to paste to another program. Nothing come out if I paste within this 5 seconds.
-BUT Operation B for those programs running BEFORE or AFTER Thunder are still fast.
-If I quit Thunder now, Operation A become fast again.

For those experiencing the same, try looking for running programs which watch the clipboard. And experiment as above.
OOo 2.4.X on MS Windows Vista + MS Windows XP SP2
ahkow
 
Posts: 1
Joined: Thu Sep 04, 2008 3:32 pm

Re: Slow Copy & Paste?

Postby saul11 » Tue Dec 09, 2008 11:54 am

This happens on my system too (XP/OOo 2.4.1). Always when I copy something in Writer and want to paste it in any other program (not tried to paste into any other OOo suite application though) the first attempts don't work. I have to press several times ctrl+v and only after some seconds it has effect and the content is pasted. I just noticed that this also happens in Calc, so I guess this happens in every app of the OOo suite, but I don't use any other than Writer and Calc myself. I don't have the quickstarter up.

As this thread suggested that other applications might conflict, I tried turning of some and just found out that when I have HDDLife Pro (2.9.109) off the problem is gone?! This works when I have to copy paste much for a moment, but I am not going to offer it over OOo of course.
OOo 2.4.X on Ms Windows XP
saul11
 
Posts: 2
Joined: Tue Dec 09, 2008 11:37 am
Location: NL

Re: Slow Copy & Paste?

Postby saul11 » Tue Dec 09, 2008 12:47 pm

The issue remained with OOo 3.0.0
OOo 2.4.X on Ms Windows XP
saul11
 
Posts: 2
Joined: Tue Dec 09, 2008 11:37 am
Location: NL

Re: Randomly Slow Copy & Paste?

Postby AnrDaemon » Sat Mar 28, 2009 4:34 am

Been using OOo from 2.4.1 to 3.0.1, it's consistent on all versons and systems i've tried.
Win2kSP4, XPSP3, Ubuntu 8.04
Cut/Copy of the text from inside of the Calc cell (from the formula bar) or the Calc cells - no matter, takes no less than 5 sec.
At the same time, cut and copy from Writer works ok'.
It's... frustrating - not the word to describe the fact that it's blocking my work. A bit more and i'll feel the sum of $200 for MS Office not big enough to justify the loss of nerves spent on waiting for simple text string to copy.
No, i'm not running any kind of monitoring antivirus or mem-blocking firewall. I do not have enough CPU cycles to spare to what I can do myself absolutely transparently.
AOo 3.4.1 on Ms Windows XP/ OOo 3.3.0 on Mac OS X 10.7
AnrDaemon
 
Posts: 23
Joined: Fri Mar 27, 2009 6:53 pm

Re: Randomly Slow Copy & Paste?

Postby AnrDaemon » Tue Jul 07, 2009 6:47 am

Still actual for 3.1.0 (build 9399)
AOo 3.4.1 on Ms Windows XP/ OOo 3.3.0 on Mac OS X 10.7
AnrDaemon
 
Posts: 23
Joined: Fri Mar 27, 2009 6:53 pm

Re: Randomly Slow Copy & Paste?

Postby RevRichard » Tue Jul 07, 2009 11:39 pm

I was having the same problem, along with random crashes of OO 3.0.1. I finally broke down and ran CCleaner. Problem solved. (using Windows XP)
RevRichard
 
Posts: 21
Joined: Fri Mar 14, 2008 5:55 pm

Re: Randomly Slow Copy & Paste?

Postby alexspecht » Thu Mar 03, 2011 10:42 pm

I've been having the same problem for a while now. I didn't realize it was an open office problem until it started hapening on my laptop.

Something interesting: When this problem starts occuring at the office, I open remote desktop and connect to our local server (no login). Now the copy paste is instant again. Weird

Zen quote I came across which seems to relate to above:
"If you understand, things are as they are. If you do not understand, things are as they are." -theincoherent.com
OpenOffice 3.1 on Windows XP
alexspecht
 
Posts: 1
Joined: Thu Mar 03, 2011 10:31 pm

Re: Randomly Slow Copy & Paste?

Postby 1StepAhead » Thu Sep 15, 2011 4:36 am

This is without any doubt an issue caused by Open Office.

I do not find the clipboard copy to be a problem within Open Office Writer.

When Open Office Writer has a document open a Ctrl-C in my programming Text Editor freezes for about 5+ seconds. If I attempt to do anything in the Editor, I get an hour glass and "Not Responding" added to the Editor's Title Bar.

When I examine Task manager sorted by CPU usage, swriter.exe is near the top process with CPU percent usage.

When I exit Open Office Writer, The clipboard Copy issue goes away. Very repeatable.
Open Office 3.3.0 Build 9567 on
Windows XP Pro Version 2002 Service Pack 3
1StepAhead
 
Posts: 1
Joined: Thu Sep 15, 2011 4:27 am

Re: Randomly Slow Copy & Paste?

Postby DfTg » Mon Dec 19, 2011 12:58 pm

Does anybody have any new information regarding this subject? I have an OpenOffice 2.4 on a Windows 7 machine which has exactly the same behaviour: When I press CTRL+C and go to whatever other programme you want to paste the copied data in, I have to wait for about 10 seconds before it pastes. This 'time lag' only happens with OpenOffice on my machine and also on another machine that has Vista running!

Oh, BTW: I use an somewhat older of OpenOffice, because any version newer than this crashes! This also happens on another (quite different) machine with Windows 7 installed... There a more users complaining about this (mis)behaviour, but OO didn't seem to fix this yet.
OpenOffice 2.4 on Windows 7 64 bit
DfTg
 
Posts: 2
Joined: Mon Dec 19, 2011 12:54 pm

Re: Randomly Slow Copy & Paste?

Postby RoryOF » Mon Dec 19, 2011 1:03 pm

DfTg wrote:Oh, BTW: I use an somewhat older of OpenOffice, because any version newer than this crashes! This also happens on another (quite different) machine with Windows 7 installed... There a more users complaining about this (mis)behaviour, but OO didn't seem to fix this yet.


The crash on Windows 7 is fixable; you have two choices: either disable (remove) Internet Explorer 9 (IE8 is automatically reinstalled) or do a custom installation of OpenOffice selecting not to use Automatic Updates.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27308
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Randomly Slow Copy & Paste?

Postby AnrDaemon » Wed Dec 21, 2011 5:14 pm

I still have this issue, with OOo 3.3 now. It randomly manifests in writer, but 1) I rarely use writer, 2) for Calc it's much more consistent. (Read: persistent.)
AOo 3.4.1 on Ms Windows XP/ OOo 3.3.0 on Mac OS X 10.7
AnrDaemon
 
Posts: 23
Joined: Fri Mar 27, 2009 6:53 pm

Re: Randomly Slow Copy & Paste?

Postby Herwet » Tue Nov 27, 2012 7:51 pm

Same problem for me. Using Windows XP + OO 3.41, 4 Gb ram, pretty fast computer, no other performance issues in other programs.
When I copy parts of a cell content, Calc freezes for about 5 seconds. It happens almost every time.
Copying whole cells works just fine.

Disabling various services and functions have so far not solved the problem.
OpenOffice 3.41 on Windows XP
Herwet
 
Posts: 1
Joined: Tue Nov 27, 2012 7:42 pm

Re: Randomly Slow Copy & Paste?

Postby fredrikl » Wed Feb 20, 2013 5:25 pm

I had the same type of problem using Ctrl+C in the basic editor in Calc. Around a 5 sec delay. Zone Alarm created the problem on my computer. Tried to change settings in Zone Alarm but could not get the problem to go away. Uninstalled Zone Alarm and installed Windows Firewall Notifier instead to get outgoing internet traffic pop up messages. Everything works fine now.
OpenOffice.org Portable 3.2.0, Windows 7
fredrikl
 
Posts: 8
Joined: Wed Feb 20, 2013 5:17 pm

Re: Randomly Slow Copy & Paste?

Postby zeeh1975 » Thu Jun 19, 2014 6:48 pm

Problem still present on OO 4.1
OpenOffice 4.1.0 / Windows XP sp3
zeeh1975
 
Posts: 1
Joined: Thu Jun 19, 2014 6:36 pm

Re: Randomly Slow Copy & Paste?

Postby soloi34 » Thu Jul 17, 2014 10:30 am

Same issue.

I solved with a start and kill of soffice.bin

Here the bat code on startup:

TIMEOUT /T 10
START soffice -norestore -writer

:anothertime
TIMEOUT /T 10
tasklist /FI "IMAGENAME eq soffice.bin" | findstr "soffice.bin" >nul
if %ERRORLEVEL% == 1 goto anothertime

taskkill /F /IM soffice.bin
OpenOffice 4.1 on Windows 7
soloi34
 
Posts: 1
Joined: Thu Jul 17, 2014 9:43 am

Re: Randomly Slow Copy & Paste?

Postby catherinelee99 » Mon Sep 25, 2017 8:51 pm

I had this problem but it was for files while copying files and folders the transfer speed was quite slow. I regret upgrading my windows, they get shittier with each update. My friend suggested me to use GS Richcopy 360 to fix the slow transfer speed and it did worked for me. Its 100% multi threaded file transfer mechanism helped me in saving my precious time. You can also try it, hope this comment helps!
OpenOffice 4.1 on Windows 8.1
catherinelee99
 
Posts: 1
Joined: Mon Sep 25, 2017 8:47 pm

Re: Randomly Slow Copy & Paste?

Postby solid1 » Thu Dec 21, 2017 6:38 pm

Same thing here, going on for years. :crazy:
Win7 64bit Oo 4.1.2
Sometimes the copy of one cell to another, sometimes between different open documents, the program stalls but recovers, and sometimes the program freezes hard, necessitating Task manger to kill the process.
I have ZoneAlarm, but I have not seen a pop-up, my documents have hyperlinks, but problem involved in the copy of these.
openoffice 4.1.1 on windows 7
solid1
 
Posts: 11
Joined: Mon Feb 02, 2015 5:18 pm

Re: Randomly Slow Copy & Paste?

Postby John_Ha » Thu Dec 21, 2017 7:28 pm

1. Do you use a clipboard utility? They can affect AOO copy and paste.

2. Also, check by starting your PC in Safe Mode - does the problem disappear?

If neither help then please upload a small document file (eg .odt) showing the problem so that it can be analysed. Use the Upload attachment tab below where you type (128 kB max) or use a file share site for a larger file.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5737
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Randomly Slow Copy & Paste?

Postby solid1 » Thu Dec 21, 2017 10:41 pm

So far the error has not occurred since I unchecked the option:
Tools > Options > Load/Save > General > Save URLs relative to internet. (unchecked)

I set the auto-recovery information to every 2 minutes.

I had the copy problem with cells NOT having URLs. Not sure if this is a network timeout thingy, slow https:// connections could be at play? In any case, anything that I do needs to happen fast, and if not I need to know why. The program should not be allowed to take more than ~0.3 seconds to copy ~5 characters. The program should keep a timer on how long processes take, and if too long there should be an option to bail out.

Using Calc for ~50,000 cells making a graph is easy in MS-excel, and almost impossible in Oo.
openoffice 4.1.1 on windows 7
solid1
 
Posts: 11
Joined: Mon Feb 02, 2015 5:18 pm

Re: Randomly Slow Copy & Paste?

Postby solid1 » Fri Dec 22, 2017 12:19 am

oops, it happened again.
This time I was copying two cells, one had a simple formula , sum=(a*b) , the other on simple text, $cost.
I had it saved as a .ods, as I incorrectly suspected this was a .xls problem.
openoffice 4.1.1 on windows 7
solid1
 
Posts: 11
Joined: Mon Feb 02, 2015 5:18 pm

Next

Return to MS Windows

Who is online

Users browsing this forum: No registered users and 6 guests