Java (1.7) there but missing for OOo

Issues with installing under all versions of MS Windows

Java (1.7) there but missing for OOo

Postby another_xp_user » Sat Mar 17, 2012 5:27 pm

Hi,

I removed all Java from my PC.

I then reinstalled it.

I then checked it was there: http://www.java.com/en/download/testjava.jsp

"How do I test whether Java is working on my computer?"

This page says:

Your Java is Working
Your Java configuration is as follows:
Vendor Oracle Corporation
Version Java SE7 Update 03
Operating System Windows XP 5.1
Architechture x86

And you get a nice picture of a java coffee cup.

Then go into Control Panel / Java / [Java Tab] / Java Runtime Environment Settings / View
which says Platform 1.7, Product 1.7.0_0.3 Location http://java.sun.com/products/autod/j2se
and path C:\Program Files\Java\jre7\bin\javaw.exe

I'd say that I had Java running.

But OOoBase says otherwise: JREis Defective
OpenOffice.org requires a Java runtime environment (jre) to perform the task. The selected JRE is defective. Please select another version or install a new JRE. and select it under Tools - Options - OpenOffice.org - Java.

Defective, eh? Well I got it from Oracle Corporation. Where else I am supposed to get it from?

So I go for Tools - Options - OpenOffice.org - Java.and the popup shows:
Java runtime environments (JRE) already installed.

But it doesn't know where it is installed and shows a blank Vendor / Version and Features.

If I try to add a new JRE and tell it EXACTLY where Java is (ie C:\Program Files\Java\jre7\bin\) it argues with me and tells me that there is NO java there. Well I know that it is there.

All this "There is it, now it's gone" is fine for Paul Daniels and Debbie McGee, but not very suitable for me trying to get OOoBase to work!

Is this likely to be fixed anytime soon?

Thanks.

Title Edited. A descriptive title for posts helps others who are searching for solutions and increases the chances of a reply (Hagar, Moderator).
WIN XP service pack 2
OpenOffice.org 3.3.0
OOO330m20 (Build:9567)
another_xp_user
 
Posts: 1
Joined: Thu Mar 01, 2012 4:45 pm

Re: Java there but not there but missing but there

Postby Bill » Sat Mar 17, 2012 6:01 pm

Java.com recommends Java 6, Update 31 for users. Java 7 is recommended for developers. OOo requires Java 6.
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: Java there but not there but missing but there

Postby FJCC » Sat Mar 17, 2012 6:01 pm

OOo 3.3 cannot use Java 1.7. I believe that has been fixed in Apache OpenOffice 3.4. In the meantime, try the last 1.6.xx version of Java.
AOO 3.4 or 4.0 on MS Windows XP ( before 2013-08-03) or Windows 7
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 3669
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 7 guests