[Solved+Issue] OOo Won't Start - Error Loading VCRT Library

Issues with installing under all versions of MS Windows

[Solved+Issue] OOo Won't Start - Error Loading VCRT Library

Postby Ruler2112 » Thu Jan 05, 2012 8:39 pm

One of my users is having problems. Something I just discovered may actually help lend insight to the various VCRT errors which are reported. I posted at the old forums and was directed here for more help. Below is a copy & paste of the the problem:

One of my users is having trouble with OpenOffice and I really don't know what else to try. The computer is a dual-core AMD running XP SP3 with 2 gig of RAM. She gets the following:
Code: Select all   Expand viewCollapse view
---Microsoft Visual C++ Runtime Library---

Runtime Error!

Program: c:\Program Files\OpenOffice.org 3\program\soffice.bin

R6034
An application has made an attempt to load the C runtime library incorrectly.
Please contact the application's support team for more information.

OK

This messagebox comes up and the program immediately dies when you hit OK. It doesn't matter what component (writer, calc, draw, etc) you open or if you double-click on a document (OO or otherwise).

So far, I've tried reinstalling OpenOffice 3.2. I tried 3.1. I tried 3.3. I tried LibreOffice 3.4. I tried removing OpenOffice, deleting all directories remotely connected with OpenOffice, rebooting, and then installing fresh. I tried downloading and installing the M$ Visual C++ runtime for 2005, 2008, and 2010. (At least I think those were the years; I know I tried 3 different ones, rebooting between each.) I tried different version of JRE. After all this had no effect, I finally gave up and reinstalled windoze. Great – OpenOffice worked and opened without erroring out! The next day, she called me and the above error was popping up again and OO was inaccessible.

I've found references to this error online at M$, but don't understand most of it (I haven't coded for windoze in years – unix/linux is where I code). Plus, I know it's not a problem with the program itself, as the same exact thing works on other systems without any problems. I'm frankly out of ideas and at a loss of what to try at this point.

------------------------

There's only one .manifest file on the machine

------------------------

I've reset the user profile directory multiple times.

------------------------

I've used revo uninstaller to remove OO.

The interesting thing that I just discovered is that when a web chat program is running, OO doesn't work. The program is closed - OO starts without problem. It's started and OO complains about the above VCRT error.

I'm going to contact the web chat program provider, but honestly don't expect to get much out of them. Anybody here have ideas of how to further troubleshoot? (I'm thinking that many of the VCRT errors reported with OO may be due to the same problem - another program is doing something that creates a condition which makes the manifest unreadable.)
Last edited by Hagar Delest on Thu Jan 05, 2012 9:49 pm, edited 2 times in total.
Reason: tagged [Issue] (link to a bug report).
OpenOffice 3.3 on Windoze XP / LibreOffice 3.4 on FreeBSD 8.1
Ruler2112
 
Posts: 2
Joined: Thu Jan 05, 2012 8:03 pm

Re: OO Won't Start - Error when Loading VCRT Library

Postby Ruler2112 » Thu Jan 05, 2012 9:35 pm

I contacted the web chat vendor and much to my surprise, they already knew all about the problem. She said that it was a problem with the way OO is distributing the VCRT runtime and that there's an open bug on it already. Surprisingly, the bug was opened in October of 2009 and is flagged as trivial. The problem DLL is Microsoft.VC80.CRT.MANIFEST. I downloaded a different version of the web chat software customized for OO users and things are now working normally again, but wanted to report back for the benefit of those who may find this information useful in the future. I'd wager that many of the errors similar to this could be traced back to the same root cause, but that's little more than gut feeling.
OpenOffice 3.3 on Windoze XP / LibreOffice 3.4 on FreeBSD 8.1
Ruler2112
 
Posts: 2
Joined: Thu Jan 05, 2012 8:03 pm

Re: [Solved+Issue] OOo Won't Start - Error Loading VCRT Libr

Postby rudolfo » Thu Jan 05, 2012 10:02 pm

Thanks for posting your findings, Ruler2112.
There was actually a similar thread Runtime Error R6034 just a view weeks ago with the same problem. We had not much luck then, so I will post there a link to this thread.
OpenOffice 3.1.1 (2.4.3 until October 2009) and LibreOffice 3.3.2 on Windows 2000, AOO 3.4.1 on Windows 7
There are several macro languages in OOo, but none of them is called Visual Basic or VB(A)! Please call it OOo Basic, Star Basic or simply Basic.
rudolfo
Volunteer
 
Posts: 1488
Joined: Wed Mar 19, 2008 11:34 am
Location: Germany


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 10 guests