OpenOffice.org File Self-Mutilation

Issues with installing under all versions of MS Windows

OpenOffice.org File Self-Mutilation

Postby VexTheWarlord » Sun Jan 02, 2011 5:41 am

I'm not terribly familiar with this forum, being as I only registered around five minutes ago, and only to report an error and make this attempt to resolve it.

Now I've just discovered that one of my Open Office files has for lack of a better description, mutilated itself.

Now I have a back-up to this file, but since I'm apparently very stupid, it's over three months old at this point. Now that wouldn't be a world-ending set-back, but I'd much rather be able to recover this one.

And unfortunately this fits nicely into the overall theme of my experiences with electronics. Any problems I have almost always involve all three of the following elements, being

1. Without any form of visible cause or logical reasoning. Last I tampered with this particular file was four days ago, it was working perfectly fine at that time. I have not updated OpenOffice, nor installed any updates to my operating system in the interim period.
2. Utterly random in effect, and I am one of the few, if not the only person on the planet ever to see this particular error. Which is at the very least an astounding defiance of probability.
3. Not easily fixed, as a result of the above two, and of course for inexplicable side-errors that are so conveniently inconvenient to the situation that the whole thing seems almost as though it were planned by some sort of thinking entity.

But regardless, I hope I can get some help here. Hopefully some of you are technically minded enough to be able to lend some assistance. And onto the crux of the matter.

Whenever I try to open this particular file, I get this rather ominous looking pop-up.

OpenOfficeError.png

This is particularly ominous given I have never, ever seen it before, including earlier today when I was working on other OpenOffice Writer files.

I should also note that this pop-up will only appear in front of an existing instance of an Open Office file, meaning if Open Office is not already open, this pop-up simply will not appear. It also appears every time, and thus is not simply some sort of one-off error window or something of the sort.

The character set was originally set to "Western Europe (Windows-1252 WinLatin 1)", but I changed it to unicode once when attempting to resolve the issue myself. It had no effect, and subsequent attempts to change it back have had no effect.

The settings of this pop-up seem to have little, if any actual effect on the error itself unfortunately, but is a curiosity that is almost surely related, as the timing would otherwise seem too coincidental.

Once passed this pop-up, the file itself does open up,

OONonsense.png

However, as you can see, the contents leave something to be desired, being composed of six and a half million characters of... Whatever '#' these things are called, and ONLY that character.

As you can imagine, what was originally contained in this file was slightly more useful, and significantly more difficult to replace. As I've said, I would have to resort to a very outdated back-up, and I would prefer not to lose what I had.

Now I've already tried some self-fixes for this issue. I've restarted OpenOffice. I've restarted my computer.

I've also tried copying the file, and while the copy was as flawed as the original, when I tried to delete the copy, I discovered that the file was also errored in such a way as to render itself unable to be directly deleted, I suspect I could be rid of it by selectively deleting the entire folder it is contained within (Copying everything else in the directory safely somewhere else of course), but that does nothing to solve my primary issue, IE: the recovery of the data contained within the file.

Now I also had a very useful idea. With all, or at least nearly all of my OpenOffice files I enable version saving, and as this file, bugged as it may be, is still ridiculously bloated in size, which says to me that the versions contained within the file are either still as they were, or have been similarly translated into garbage. Since I have no idea what's happened, it's essentially become Schrodinger's Versions, with an equal chance of being useless or useful, and no way to know until I obtain more information on the subject.

Unfortunately, as you can see in the screen shot, the versions option in edit is unavailable.

Now as I've already said, my primary concern is the recovery of the information contained within this file, everything else is secondary to that purpose. So if anyone can tell me what's happened, or offer ideas as to how to get at the information, or confirm if it is or isn't recoverable, please let me know.

I haven't reinstalled OpenOffice as this seems to be an issue specific to this file, and therefore reinstalling OpenOffice should have no effect.
OpenOffice 3.2 on Windows 7
VexTheWarlord
 
Posts: 1
Joined: Sun Jan 02, 2011 4:36 am

Re: OpenOffice File Self-Mutilation

Postby therabi » Sun Jan 02, 2011 6:35 am

This is not the first time the problem has been brought up. Windows 7 seems to have the most problem but XP has also been brought up. There is no way that I have see post that the file can be recovered. There is not a simple search here as the search requires at least four characters.
OpenOffice.org v3.3, LibO v3.32 on Ubuntu 10.10 and Win7
User avatar
therabi
Volunteer
 
Posts: 763
Joined: Wed Sep 01, 2010 10:01 pm
Location: USA

Re: OpenOffice File Self-Mutilation

Postby TheGurkha » Sun Jan 02, 2011 1:19 pm

Anything can happen at any time when you are using a computer. The only safe way to use any Office type of product is to make backups, and make them frequently. That file is beyond recovery.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: OpenOffice.org File Self-Mutilation

Postby Hagar Delest » Sun Jan 02, 2011 9:17 pm

AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 5 guests