[Solved] Cut, copy, and paste not working

Issues with installing under all versions of MS Windows

[Solved] Cut, copy, and paste not working

Postby gdc555 » Mon Aug 03, 2009 1:40 am

I've been using Open Office for over a year, but just within the last week, copy, cut, and paste functionality simply stopped working from the edit menu and the shortcut keys. It works fine in any other application that I use, but not in Open Office. I can use drag and drop to copy and paste between applications, however, which is annoying as hell. I figure that I somehow triggered some weird setting in OOo. Yesterday I upgraded from 3.0.1 to 3.1.0 hoping to correct the problem, but it is still there.

Can someone tell me what might be going on?
Last edited by Hagar Delest on Sat Aug 22, 2009 12:35 am, edited 1 time in total.
Reason: tagged [Solved].
OOo v ersion 3.1.0
Win XP
gdc555
 
Posts: 4
Joined: Mon Aug 03, 2009 1:23 am

Re: Help - cut, copy, and paste not working

Postby FJCC » Mon Aug 03, 2009 3:34 am

Try resetting your user profile as explained here
AOO 3.4 or 4.0 on MS Windows XP ( before 2013-08-03) or Windows 7
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 3674
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Cut, copy, and paste not working

Postby gdc555 » Tue Aug 04, 2009 1:03 am

That didn't fix it. I guess I should have said that I have two users on this computer and it is affecting both of them.

When I get some time, I will probably uninstall OOo, delete all OOo folders, and do a clean installation. In the mean time, are there any other ideas?
OOo v ersion 3.1.0
Win XP
gdc555
 
Posts: 4
Joined: Mon Aug 03, 2009 1:23 am

Re: Cut, copy, and paste not working

Postby FJCC » Tue Aug 04, 2009 4:25 am

I think that upgrading from 3.0.1 to 3.1 doesn't replace all of the code, it just does selective changes. I could easily be wrong about that. If I'm right, you would have to uninstall your existing version and then re-install. You might want to wait a bit to see if someone says I'm wrong.
AOO 3.4 or 4.0 on MS Windows XP ( before 2013-08-03) or Windows 7
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 3674
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Cut, copy, and paste not working

Postby Bill » Tue Aug 04, 2009 3:04 pm

Unless the upgrade process has changed, upgrading should replace all the code. I know that on OOo 2, the old version was automatically uninstalled--old program files and registry settings which were part of the old version installation were completely removed before the new version's program files and registry settings were installed. That's why it wasn't necessary to manually uninstall the old version first. The old version would have to be manually uninstalled only if you wanted to do a clean installation, which also requires manually deleting the user profile folder, cleaning the registry and deleting any leftover OOo program file folders.
Bill
 
Posts: 3312
Joined: Sat Nov 24, 2007 6:48 am

Re: Cut, copy, and paste not working

Postby gdc555 » Wed Aug 05, 2009 1:38 pm

Either way, it didn't make a difference. I did a fresh install and still have the problem. I have a couple other programs that are acting up now, so I'm thinking it is a systemic thing. I'll probably have to rebuild the entire machine.
OOo v ersion 3.1.0
Win XP
gdc555
 
Posts: 4
Joined: Mon Aug 03, 2009 1:23 am

Re: Cut, copy, and paste not working

Postby RoryOF » Wed Aug 05, 2009 4:31 pm

If you insert the XP CD and boot from it, I think it gives you the option to rebuild your installation, preserving installed programs and settings.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14350
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Cut, copy, and paste not working

Postby gdc555 » Sat Aug 22, 2009 12:25 am

I found my problem! I remembered that just before I encountered the cut'n'paste issue, I had accidentally shutdown in the middle of a Java update :knock: . This is a Bad Thing(tm), apparently. So I removed all copies of Java from my machine, removed OOo, downloaded a fresh Java JRE and installed it (tested it too!), then reinstalled OOo. Cut'n'paste is working again. :bravo:
OOo v ersion 3.1.0
Win XP
gdc555
 
Posts: 4
Joined: Mon Aug 03, 2009 1:23 am


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 7 guests