[Solved] Basic syntax error

Discuss the database features

[Solved] Basic syntax error

Postby Jjs2060 » Wed Apr 15, 2015 7:40 pm

I have been working on a form for data review and input that uses a big macro. Recently, somehow I lost all macros. I went to my backups and found a database with the macros. However the main macro was out of date but I had a text copy of the latest version (attached). I copied the text and pasted it into the Sub. This macro worked before the problem and now gives this exception: Basic syntax error. "Function not allowed within a procedure." I can't get rid of the error. I feel it has something to do with how I pasted the text file. Any suggestions?
Last edited by Jjs2060 on Tue Apr 28, 2015 5:53 pm, edited 1 time in total.
Libre Office 4.2.2.1 on OS X 10.9.3
Jjs2060
 
Posts: 60
Joined: Sat Nov 08, 2014 2:53 am

Re: Basic syntax error

Postby FJCC » Wed Apr 15, 2015 7:46 pm

I'm guessing you have a Sub declaration that is not paired with an End Sub.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7007
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA


Return to Base

Who is online

Users browsing this forum: No registered users and 2 guests