[Solved] Database unable to open

Discuss the database features

Re: [Solved] Database unable to open

Postby Sliderule » Tue Jul 07, 2015 3:19 pm

jtbernier:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby wying0728 » Sun Jan 24, 2016 5:12 pm

Same problem here.
I was newbee for OpenOFfice since company only use OpenOffice rather than microsoft.
I have create a database to store the parts details info.
Yet after few month used, suddenly error appear "filter selection" window pop out.
Hope able to get solution here.

Thank you for the kind help.
OpenOffice 4.1.0
wying0728
 
Posts: 1
Joined: Sun Jan 24, 2016 5:08 pm

Re: [Solved] Database unable to open

Postby Sliderule » Sun Jan 24, 2016 5:44 pm

wying0728 wrote:Same problem here.
I was newbee for OpenOFfice since company only use OpenOffice rather than microsoft.
I have create a database to store the parts details info.
Yet after few month used, suddenly error appear "filter selection" window pop out.
Hope able to get solution here.

Thank you for the kind help.

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby rustyi » Tue Feb 02, 2016 2:21 am

As I saved the last time Base exited and now when I try to load the project I get the same filter message. Seeking help. Thanks!
OpenOffice 4.1.2 On Windows 10
rustyi
 
Posts: 2
Joined: Tue Feb 02, 2016 2:17 am

Re: [Solved] Database unable to open

Postby Sliderule » Tue Feb 02, 2016 7:32 am

rustyi:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby jconnin » Sun Mar 06, 2016 11:12 pm

I am in the same situation as the folks above, and like the others I'm hoping for help from Sliderule or anyone else who is able. Thank you in advance!
OpenOffice 4.1.2
Windows 10
jconnin
 
Posts: 12
Joined: Fri Nov 14, 2014 4:42 am

Re: [Solved] Database unable to open

Postby NancyMc » Fri Apr 29, 2016 11:46 pm

I also have this problem. Any help is appreciated.
OpenOffice 4.1.2 Windows10
NancyMc
 
Posts: 1
Joined: Fri Apr 29, 2016 11:34 pm

Re: [Solved] Database unable to open

Postby PC001 » Wed May 11, 2016 6:30 am

I'm having the same issues. Every-time I try to open my obd file I'm being asked to apply a filter and still can't open the database.
Openoffice 4.1.1 | Mac 10.9.5
PC001
 
Posts: 1
Joined: Wed May 11, 2016 6:08 am

Re: [Solved] Database unable to open

Postby MPbn80@gmail.com » Mon Jul 25, 2016 5:16 am

Sliderule wrote:rustyi:

I just sent you a PM ( Private Message ).

Sliderule



@Sliderule I have a corrupt .odb file that I cannot convert into a working .zip file. Anything you can help with?
OpenOffice 4.12 on Windows 10
MPbn80@gmail.com
 
Posts: 1
Joined: Mon Jul 25, 2016 5:05 am

Re: [Solved] Database unable to open

Postby Sliderule » Mon Jul 25, 2016 4:53 pm

MPbn80@gmail.com wrote:
Sliderule wrote:rustyi:

I just sent you a PM ( Private Message ).

Sliderule



@Sliderule I have a corrupt .odb file that I cannot convert into a working .zip file. Anything you can help with?

MPbn80@gmail.com

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby rdkbak » Tue Oct 04, 2016 2:23 am

I'm having the same issues. Every-time I try to open my obd file I'm being asked to apply a filter and still can't open the database.
One table and several queries, only about 500 records.
I really need this fixed to print post cards for mailing.

Thanks.
OpenOffice 4.1.2 on Windows 10
rdkbak
 
Posts: 1
Joined: Tue Oct 04, 2016 2:16 am

Re: [Solved] Database unable to open

Postby Sliderule » Tue Oct 04, 2016 3:31 pm

rdkbak:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Database unable to open

Postby svrhh69 » Thu Oct 06, 2016 4:39 pm

Hi,

while I was working with another program Open Office crashed. I tried to reopen the file and I got a "Filter Selection" window.
I guess Sliderule is the master of desaster. Is it possible to repair the DB?

Tkx a lot
OpenOffice 4.1.2 on Windows 10
svrhh69
 
Posts: 1
Joined: Thu Oct 06, 2016 4:33 pm

Re: [Solved] Database unable to open

Postby Sliderule » Thu Oct 06, 2016 4:50 pm

svrhh69:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

[SOLVED] Database unable to open

Postby Mino » Wed Oct 12, 2016 6:18 pm

Hi, I have the same problem !! Help me please! :crazy:
Last edited by Mino on Fri Oct 14, 2016 10:37 am, edited 1 time in total.
Windows 10, Asus F502, Intel Core i5, OpenOffice 4.1.2
Mino
 
Posts: 1
Joined: Wed Oct 12, 2016 6:12 pm

Re: [Solved] Database unable to open

Postby Sliderule » Wed Oct 12, 2016 7:48 pm

Mino:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby johnh009 » Thu Mar 16, 2017 2:31 pm

For the past 2 weeks I've designing a small admin system for an animal rescue charity here in Spain. I had the tables all normalised (well, as much as I wanted them to be), a considerable amount of data entered, and was beginning the process of creating forms (and trying to learn how to) based on tables and existing SQL queries. However, 2 days ago, when altering a form, based on linked tables, the application hung. I left it to try and sort itself out for about 30 mins, but as nothing appeared to be happening (PC resources were not being hogged), I 'force quit' the app. Then unfortunately, due to a very senior moment, I did what I always do when I shut it down and copied the .odb to the last back-up and obviously overwrote it - doh! So now I have the usual 3 error messages as follows:
---------------------------------------
The connection to the data source "AABAS" could not be established. The driver class " could not be loaded

Error code: 1000 The driver class '' could not be loaded.

SQL Status: HY000 The driver class '' could not be loaded.
---------------------------------------
I tried the recovery process described in the Base manual appendix, without success. A solution for this would be very much appreciated and save me a whole shed load of work.
LibreOffice 5.2.6.2 (Build ID:1:5.2.6-1). Linux (Sparkylinux based on Debian) 4.8
johnh009
 
Posts: 7
Joined: Thu Mar 16, 2017 2:00 pm

Re: [Solved] Database unable to open

Postby Sliderule » Thu Mar 16, 2017 3:06 pm

johnh009:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby johnh009 » Thu Mar 16, 2017 7:26 pm

Thank you, Sliderule. As you say, forms, macros, reports and sql queries are not there (not able to be recovered), but the database is, along with the data within it, i.e. the major parts. :bravo:

Thank you again.
LibreOffice 5.2.6.2 (Build ID:1:5.2.6-1). Linux (Sparkylinux based on Debian) 4.8
johnh009
 
Posts: 7
Joined: Thu Mar 16, 2017 2:00 pm

Re: [Solved] Database unable to open

Postby Tucker » Sun May 28, 2017 7:23 pm

I created my first query, saved it, closed the database. Now, I can't open it without the filter box which is a deadend. Please help and thanks in advance.
Open Office 4.1.3
on Windows 10, 64 bit
Tucker
 
Posts: 2
Joined: Sun May 28, 2017 7:15 pm

Re: [Solved] Database unable to open

Postby Sliderule » Sun May 28, 2017 7:56 pm

Tucker:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby Tucker » Sun May 28, 2017 9:28 pm

Sliderule, you fixed it. Can't thank you enough.
Open Office 4.1.3
on Windows 10, 64 bit
Tucker
 
Posts: 2
Joined: Sun May 28, 2017 7:15 pm

Re: [Solved] Database unable to open

Postby DespAle » Tue Oct 24, 2017 12:35 pm

Same issue here, cannot even open as archive by renaming it to zip...... Can something be done?

Lost 3 months worth of work......
OpenOffice 4.1.3, Windows 10
DespAle
 
Posts: 1
Joined: Tue Oct 24, 2017 12:25 pm

Re: [Solved] Database unable to open

Postby Sliderule » Tue Oct 24, 2017 2:34 pm

DespAle:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby Rchall » Wed Oct 25, 2017 7:57 pm

Hi There,

I have suddenly found the same problem - opening a database brings up a "Filter selection" menu. I had literally just backed up the database as it was fine this morning so now I have a database and a backup that are doing exactly the same thing.
I have noticed that where my database "recordings.odb" is saved there is also a file with the extension "recordings.odb.lck"

Any help gratefully received.
Thanks
Openoffice 4.13 on Windows 10 build 15063
Rchall
 
Posts: 5
Joined: Wed Oct 25, 2017 7:52 pm

Re: [Solved] Database unable to open

Postby Sliderule » Wed Oct 25, 2017 8:15 pm

Rchall:

I just sent you a PM ( Private Message ).

Sliderule
User avatar
Sliderule
Volunteer
 
Posts: 1191
Joined: Thu Nov 29, 2007 9:46 am

Re: [Solved] Database unable to open

Postby Rchall » Mon Nov 06, 2017 1:03 pm

Rchall wrote:Hi There,

I have suddenly found the same problem - opening a database brings up a "Filter selection" menu. I had literally just backed up the database as it was fine this morning so now I have a database and a backup that are doing exactly the same thing.
I have noticed that where my database "recordings.odb" is saved there is also a file with the extension "recordings.odb.lck"

Any help gratefully received.
Thanks


I am immensely grateful to sliderule for taking the time to solve this problem for me, quickly and efficiently. Thank-you.
Openoffice 4.13 on Windows 10 build 15063
Rchall
 
Posts: 5
Joined: Wed Oct 25, 2017 7:52 pm

Re: [Solved] Database unable to open

Postby LadyAly » Wed Dec 20, 2017 5:37 am

Hi

I'm having this same problem with a ODB file I've been working on. OpenOffice crashed while I was using another program and now I can't open the database file, I'm getting the "filter selection" screen but can't select anything. I haven't been backing the file up, because it's still a work in progress. It would just be a major pain to have to redo everything... again.

Any help or suggestions about how to deal with this would be greatly appreciated.
Newbee with basic end user skills... can understand a little more than most

OpenOffice 4.1.2 on Windows 8.1 OS
LadyAly
 
Posts: 2
Joined: Wed Dec 20, 2017 5:28 am

Re: [Solved] Database unable to open

Postby LadyAly » Wed Dec 20, 2017 10:56 am

LadyAly wrote:Hi

I'm having this same problem with a ODB file I've been working on. OpenOffice crashed while I was using another program and now I can't open the database file, I'm getting the "filter selection" screen but can't select anything. I haven't been backing the file up, because it's still a work in progress. It would just be a major pain to have to redo everything... again.

Any help or suggestions about how to deal with this would be greatly appreciated.



This issue has been fixed by Sliderule!!

Thank you so much, Sliderule! You are amazing, and were very friendly, understanding and helpful!
Newbee with basic end user skills... can understand a little more than most

OpenOffice 4.1.2 on Windows 8.1 OS
LadyAly
 
Posts: 2
Joined: Wed Dec 20, 2017 5:28 am

Corrupted database File

Postby BarneyinOz » Tue Jan 16, 2018 10:43 am

I have been setting up a database and after considerable effort I now have/had readable output reports. I closed the file, went to bed and had planned to continue adding data today. Except when I tried to open the file I just got a list of database formats. I scrolled down until I found .odb but it still would not open. The computer says wrong format. I take it from this that the file has somehow been corrupted. Anyone have any suggestions or do I go back to square 1

Thanks
Howard
Open Office Version 3 Windows Vista Operating System Firefox Web Browser
BarneyinOz
 
Posts: 13
Joined: Sun Apr 03, 2011 4:38 am

PreviousNext

Return to Base

Who is online

Users browsing this forum: No registered users and 2 guests