[Solved] Negative Symbol in a Power?

Discuss the formula editor

[Solved] Negative Symbol in a Power?

Postby BenG » Tue May 26, 2009 1:18 pm

I want to display the number -2e-8 in a formula.

When I enter either
Code: Select all   Expand viewCollapse view
-2 * 10^{-8}
or
Code: Select all   Expand viewCollapse view
-2 * 10^{--8}
The negative symbol isn't appearing in the power. See attached screen shot.

How can I get the negative symbol in the power?
Attachments
1.jpg
No negative symbol in the power - Example
1.jpg (24.38 KiB) Viewed 7396 times
Last edited by BenG on Tue May 26, 2009 3:32 pm, edited 1 time in total.
User avatar
BenG
 
Posts: 52
Joined: Tue Mar 04, 2008 5:48 pm
Location: Manchester, UK

Re: Negative Symbol in a Power?

Postby TheGurkha » Tue May 26, 2009 1:56 pm

Seems to work for me in 3.1. Which OOo are you using?
2009-05-26_125724.jpg
Negative Powers
2009-05-26_125724.jpg (24.39 KiB) Viewed 7395 times
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: Negative Symbol in a Power?

Postby BenG » Tue May 26, 2009 2:46 pm

Build 3.1.0
User avatar
BenG
 
Posts: 52
Joined: Tue Mar 04, 2008 5:48 pm
Location: Manchester, UK

Re: Negative Symbol in a Power?

Postby BenG » Tue May 26, 2009 2:52 pm

Hmmmmm....

Well after further review - it appears the "-" symbol is there (I can select it). However it doesn't seem to always be displayed. It appears to be dependant on the zoom level . E.g.

80% - Yes
90% - Yes
100% - No
110% - No
120% - Yes

Does the same happen on your OOo? Or is it just me?
User avatar
BenG
 
Posts: 52
Joined: Tue Mar 04, 2008 5:48 pm
Location: Manchester, UK

Re: Negative Symbol in a Power?

Postby acknak » Tue May 26, 2009 3:27 pm

I would write it as -2 times 10^{-8}, but that's just more familiar to me.

I can't reproduce the problem using 3.1 on Linux, although OOo does have similar problems with lines and rules in some cases, so I'm not surprised it could happen here as well.

BTW, is there a reason you're using OOo Math by itself? It's typically used from within another application, through Insert > Object > Formula. You may find, using it that way, that the formula display does not have this problem.

Using the "Optimal" zoom setting might be another good workaround.

There are some similar issues on file, but all of them seem to be fixed. E.g., Issue 16470: = appears as - in text files
You can register there and add a comment to that issue, asking that it be re-opened, or just file a new issue.

[Tutorial] Reporting bugs or suggestions
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Negative Symbol in a Power?

Postby BenG » Tue May 26, 2009 3:32 pm

acknak wrote:I would write it as -2 times 10^{-8}, but that's just more familiar to me.


Cheers.

acknak wrote:BTW, is there a reason you're using OOo Math by itself?


I was only using Math so I could get both parts of the text in view at once (for the screenshot). I'm actually putting a formula into a writer document.
User avatar
BenG
 
Posts: 52
Joined: Tue Mar 04, 2008 5:48 pm
Location: Manchester, UK

Re: [Solved] Negative Symbol in a Power?

Postby Dave » Tue May 26, 2009 3:54 pm

I do a LOT of math. In Windoze operating system, I use MathType, or, sometimes free Hermitech software, with never a problem.

David.
Dave
 
Posts: 1011
Joined: Sun Dec 23, 2007 6:53 pm


Return to Math

Who is online

Users browsing this forum: No registered users and 3 guests