Data missing when copy & paste selected data

Discuss the drawing application

Data missing when copy & paste selected data

Postby LJL_Houben » Mon Nov 16, 2020 10:33 am

Hello All

Maybe I do something wrong, but when I select some/all data from a drawing and I copy it to be used within an other program, then items are missing. Is this a setting? How to solve this?
See image below, left is 'MS paint' right is 'LibreOffice'. I have this with multiple locations, images, the location what is missing and it is regardless of the programm I use to paste to.
Thanks in advance for a solution

Grtz

Ludo

Untitled2.jpg



PS: Why is the image limit so low?
Win10 / LibreOffice 6.4.6.2
LJL_Houben
 
Posts: 4
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby Zizi64 » Mon Nov 16, 2020 11:02 am

PS: Why is the image limit so low?


Do you mean the file size limit of this forum?

You can optimize the images with a third party image magager software (like the free IrfanView) before you upload them here.
- Decrease the color depth: 256, 128 or sometimes even 64 colors enough for the screenshots.
- Decrease the resolution
- Crop the irrelevant part of the image
- Use a lossless compression (PNG) with a high compression ratio.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9656
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Data missing when copy & paste selected data

Postby Zizi64 » Mon Nov 16, 2020 11:07 am

What line width value are you using for the line that is invisible in the Paint?
Have you selected the whole line before you copiet it?
Have you tried to export the image into some image format, instead of copy-paste into the Paint?

Can you upload an .odg type sample file here?
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9656
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Mon Nov 16, 2020 7:35 pm

Hi ZiZi64

I selected all lines in the supplied image. All lines (arrows) are the same line-type (smalest). As I already mentioned it is 'random'. In other drawings I copied e.g. a rectangle and the bottom part of the rectangle is not copied to the clipboard but the rest is. For my 'feeling' it is always the 'most right' and 'most bottom' lines that are missing. I did not try to export the image into other formats (yet).
Win10 / LibreOffice 6.4.6.2
LJL_Houben
 
Posts: 4
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby Bidouille » Fri Nov 27, 2020 12:43 pm

Twice:
Zizi64 wrote:Can you upload an .odg type sample file here?
User avatar
Bidouille
Volunteer
 
Posts: 378
Joined: Mon Nov 19, 2007 10:58 am
Location: France

Re: Data missing when copy & paste selected data

Postby keme » Sat Nov 28, 2020 2:53 pm

I have seen this before in a couple of versions of the suite, when converting from vector to pixelmap format. I can't reproduce the problem now, using either LibreOffice version 6.4.4 or 7.0.3, nor with OpenOffice Draw versions 4.1.5 and 4.1.8.

I suggest upgrading to one of the current LO versions (6.4.7 or 7.0.3). Can't promise that it will solve the issue, but worth a try.

Also, if some of your lines are on a locked layer, they will not be selected, so not copied, and then can not be pasted. Probably not the issue in this case, but impossible to say for sure until we see that uploaded odg file...
User avatar
keme
Volunteer
 
Posts: 3395
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Sat Nov 28, 2020 2:58 pm

Bidouille wrote:Twice:
Zizi64 wrote:Can you upload an .odg type sample file here?


I will post next week the file as it is a file from work.
With kind regards

Ludo
Win10 / LibreOffice 6.4.6.2
LJL_Houben
 
Posts: 4
Joined: Mon Nov 16, 2020 10:17 am

Re: Data missing when copy & paste selected data

Postby LJL_Houben » Sat Nov 28, 2020 3:01 pm

keme wrote:I have seen this before in a couple of versions of the suite, when converting from vector to pixelmap format. I can't reproduce the problem now, using either LibreOffice version 6.4.4 or 7.0.3, nor with OpenOffice Draw versions 4.1.5 and 4.1.8.

I suggest upgrading to one of the current LO versions (6.4.7 or 7.0.3). Can't promise that it will solve the issue, but worth a try.

Also, if some of your lines are on a locked layer, they will not be selected, so not copied, and then can not be pasted. Probably not the issue in this case, but impossible to say for sure until we see that uploaded odg file...


It's definitly not an layer issue, but its a good suggestion. I will look which version which we use at work and upgrade it to the latest version. It somehow sees always to be the most 'left' or most 'bottom' line though :-)

Regards,

Ludo
Win10 / LibreOffice 6.4.6.2
LJL_Houben
 
Posts: 4
Joined: Mon Nov 16, 2020 10:17 am


Return to Draw

Who is online

Users browsing this forum: No registered users and 3 guests