Forum slowness?

The place for discussions and decisions about the forum

Forum slowness?

Postby Hagar Delest » Sun Jan 07, 2018 1:17 pm

The forum seems quite slower since rather recently. At first I thought it was my ISP but after a few days, I'm not so sure and there is a discussion on the dev mailing list about slow openoffice.org domain and I've talked about my observation with the forum.

Has anyone noticed a less responsive forum recently?
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28350
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum slowness?

Postby Villeroy » Sun Jan 07, 2018 1:46 pm

Server slowdown will be a wide spread problem in the near future: https://www.epicgames.com/fortnite/foru ... ity-update

Disclaimer: I'm not saying that this particular slowdown has anthing to do with the slowdown on epicgames.com

I'm visiting this site with a Firefox browser that includes some patch against Meltdown/Spectre. Therefore I can not tell if my browser, a microdode patch for my CPU, the microcode on the server CPU or any circumstance on 7 network layers is responsible for this.

"Meltdown" is a well chosen name. We may have reached a point of complexity where we have to melt down our expectations regarding performance or reliability.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26264
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Forum slowness?

Postby floris v » Sun Jan 07, 2018 2:07 pm

It loads fast enough for my tablet. I wasn't even aware that there's a problem.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4031
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Forum slowness?

Postby RoryOF » Sun Jan 07, 2018 5:09 pm

Might any perceived server slowdown be due to the new server rebuilding its cache?
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28180
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Forum slowness?

Postby acknak » Sun Jan 07, 2018 6:36 pm

I've noticed some variable slowness over the last couple of days: sometimes it's noticeable, other times it's ok.

I hadn't made any connection with the recent vulnerability disclosure; I think the patches for those should have been deployed well before the announcement.

Villeroy wrote:We may have reached a point of complexity where we have to melt down our expectations regarding performance or reliability.

No kidding. I'm boggled at the complexity/subtlety of these vulnerabilities. They (or one at least) exploit not simple flaws in the design, but "side channels"—side effects of the design, that expose one bit at a time through the timing of the processor.

For a good technical-but-not-too-technical explanation, listen to Scott Manley, here: https://www.youtube.com/watch?v=d7ILCoU9d4k
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Forum slowness?

Postby Hagar Delest » Sun Jan 07, 2018 11:51 pm

Well, will check at work tomorrow because after some work in the administration interface, there is definitively a problem.
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28350
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum slowness?

Postby charlie.it » Mon Jan 08, 2018 8:27 am

Hagar Delest wrote:Has anyone noticed a less responsive forum recently?


Yes, I confirm. It also happens in the Italian forum.
charlie
macOS 10.12 Sierra: Open Office 4.1.5 - LibreOffice 5.4.3.2
Windows 7 pro (VirtualBox): Open Office 4.1.5 - LibreOffice 5.4.4.2
Ubuntu 17.04 LTE (VirtualBox): LibreOffice 5.1.6.2
http://www.charlieopenoffice.altervista.org
User avatar
charlie.it
Volunteer
 
Posts: 306
Joined: Wed Aug 21, 2013 2:12 pm
Location: Italy

Re: Forum slowness?

Postby Hagar Delest » Mon Jan 08, 2018 9:02 am

Just checked at work and seems a little better but still page display lags a bit compared to last year.
Wait and see if something comes from the dev ML.
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28350
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum slowness?

Postby floris v » Mon Jan 08, 2018 12:05 pm

Just now, ironically, it took quite a while to load this page.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4031
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Forum slowness?

Postby charlie.it » Mon Jan 08, 2018 12:16 pm

floris v wrote:Just now, ironically, it took quite a while to load this page.

I confirm, now it is slow to load.
Edit: and upload.
charlie
macOS 10.12 Sierra: Open Office 4.1.5 - LibreOffice 5.4.3.2
Windows 7 pro (VirtualBox): Open Office 4.1.5 - LibreOffice 5.4.4.2
Ubuntu 17.04 LTE (VirtualBox): LibreOffice 5.1.6.2
http://www.charlieopenoffice.altervista.org
User avatar
charlie.it
Volunteer
 
Posts: 306
Joined: Wed Aug 21, 2013 2:12 pm
Location: Italy

Re: Forum slowness?

Postby RoryOF » Mon Jan 08, 2018 1:36 pm

Try a traceroute. It seems to me, from inspection of the server names on the traceroute, that my connection is going to London, Boston, Albany, Cleveland, ... Seattle. But I might be misreading the server abbreviations. Do I not remember that there was a mirror server in Germany, to which Europe was normally routed?

Code: Select all   Expand viewCollapse view
1  192.168.2.1 (192.168.2.1)  0.813 ms  1.205 ms  1.667 ms
2  89.19.64.135 (89.19.64.135)  32.470 ms  36.432 ms  42.500 ms
3  89.19.65.186 (89.19.65.186)  47.384 ms  52.248 ms  57.139 ms
4  ae3-111-ucr1.dub.cw.net (195.2.27.21)  62.317 ms  67.207 ms  72.104 ms
5  ae5-xcr1.duc.cw.net (195.2.21.1)  78.401 ms  83.356 ms  88.260 ms
6  ae24-xcr1.lns.cw.net (195.2.25.145)  101.508 ms  40.378 ms  40.656 ms
7  as174-gw-xcr1.lns.cw.net (195.2.22.22)  49.420 ms  50.434 ms as174-gw-xcr1.lns.cw.net (195.2.19.122)  56.027 ms
8  be2871.ccr42.lon13.atlas.cogentco.com (154.54.58.185)  60.290 ms be2869.ccr42.lon13.atlas.cogentco.com (154.54.57.161)  65.366 ms be2871.ccr42.lon13.atlas.cogentco.com (154.54.58.185)  69.305 ms
9  be2982.ccr31.bos01.atlas.cogentco.com (154.54.1.117)  143.289 ms be2983.ccr32.bos01.atlas.cogentco.com (154.54.1.178)  150.314 ms  155.235 ms
10  be2299.ccr21.alb02.atlas.cogentco.com (154.54.43.10)  161.152 ms be2302.ccr22.alb02.atlas.cogentco.com (154.54.43.14)  163.207 ms be2299.ccr21.alb02.atlas.cogentco.com (154.54.43.10)  171.416 ms
11  be2879.ccr22.cle04.atlas.cogentco.com (154.54.29.173)  183.167 ms be2878.ccr21.cle04.atlas.cogentco.com (154.54.26.129)  119.407 ms  124.294 ms
12  be2717.ccr41.ord01.atlas.cogentco.com (154.54.6.221)  129.215 ms be2718.ccr42.ord01.atlas.cogentco.com (154.54.7.129)  130.339 ms  134.308 ms
13  be2832.ccr22.mci01.atlas.cogentco.com (154.54.44.169)  155.411 ms be2831.ccr21.mci01.atlas.cogentco.com (154.54.42.165)  158.312 ms  162.230 ms
14  be3036.ccr22.den01.atlas.cogentco.com (154.54.31.89)  208.217 ms be3035.ccr21.den01.atlas.cogentco.com (154.54.5.89)  171.529 ms be3036.ccr22.den01.atlas.cogentco.com (154.54.31.89)  184.388 ms
15  be3037.ccr21.slc01.atlas.cogentco.com (154.54.41.145)  186.386 ms be3038.ccr21.slc01.atlas.cogentco.com (154.54.42.97)  192.224 ms be3037.ccr21.slc01.atlas.cogentco.com (154.54.41.145)  196.143 ms
16  be3284.ccr22.sea02.atlas.cogentco.com (154.54.44.73)  216.347 ms  221.259 ms be2085.ccr21.sea02.atlas.cogentco.com (154.54.2.197)  224.236 ms
17  be3055.ccr22.sea01.atlas.cogentco.com (154.54.2.169)  227.257 ms  187.499 ms be3054.ccr21.sea01.atlas.cogentco.com (154.54.2.41)  188.394 ms
18  be2670.rcr21.pdx01.atlas.cogentco.com (154.54.42.150)  198.310 ms  203.308 ms  207.254 ms
19  38.142.108.50 (38.142.108.50)  213.172 ms  218.283 ms  189.125 ms
20  ptck-p2-gw.nero.net (207.98.64.170)  189.649 ms  195.584 ms ptck-p1-gw.nero.net (207.98.64.168)  206.111 ms
21  corv-p1-gw.nero.net (207.98.64.25)  213.737 ms  218.675 ms  224.662 ms
22  corv-car1-gw.nero.net (207.98.64.17)  225.644 ms  230.357 ms corv-car1-gw.nero.net (207.98.64.19)  188.327 ms
23  erebus-ssl-new.apache.org (140.211.11.112)  192.195 ms  198.303 ms  202.220 ms
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28180
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Forum Governance

Who is online

Users browsing this forum: No registered users and 1 guest