[Solved] Forum Cut-over

The place for discussions and decisions about the forum

[Solved] Forum Cut-over

Postby TerryE » Thu Oct 27, 2011 11:19 am

It looks as if Oracle are proposing to turn off the usOOo server this weekend, so the forum has to move before then. The constraint is that I don't have an exact DNS A record change time from Andrew. So
  • I will take a snapshot now for safety.
  • When I do get this time of the A record change, then ahead of this I will take the forum offline, swap out posting.php with a polite apology that we are moving and bring it back online.
  • That way, the old forum will still be accessible but readonly in terms of content.
  • Functions like PM will still work but any new PMs will be lost at cut-over.
  • I will resync the content to the apache VM.
  • As the DNS record for the new server propagates, you will see the forum appear to be normal. The migration has completed.
For those who know how to add an explicit entry to their local etc/hosts file, I will post the new IP address for usooo so that they can add it temporarily and continue to use the services despite the DNS propagation effects.
Last edited by Hagar Delest on Sun Mar 04, 2012 4:01 pm, edited 1 time in total.
Reason: tagged [Solved].
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
Volunteer
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: Forum Cut-over

Postby RoryOF » Thu Oct 27, 2011 6:59 pm

I'm able to get in on both new and old addresses already, using normal DNS. specifying the particular forum server I need, Oracle or Apache.

Update: Friday 201110281230; Oracle Server seems to be gone.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28394
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Forum Cut-over

Postby floris v » Fri Oct 28, 2011 3:52 pm

We still sport the Oracle logo. We're spoiling them.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4037
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Forum Cut-over

Postby RoryOF » Fri Oct 28, 2011 5:13 pm

One thing at a time, floris! Time enough to change logos when all works well (as it seems to be doing).

A smooth transition, Thanks, Terry.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28394
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Forum Cut-over

Postby RGB » Fri Oct 28, 2011 10:08 pm

RoryOF wrote:A smooth transition, Thanks, Terry.

+1 :bravo:
There are two types of people: those who believe that there are two types of people and those who do not.

openSUSE Leap with KDE Plasma / LibO
User avatar
RGB
 
Posts: 1453
Joined: Mon Oct 08, 2007 1:34 am

Re: Forum Cut-over

Postby Hagar Delest » Fri Oct 28, 2011 10:17 pm

+1
:super:

This forum should be moved in the Site Feedback public section with full access to any users.
No objection? I'll move it in a few days then.
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28383
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum Cut-over

Postby RGB » Fri Oct 28, 2011 10:27 pm

Hagar Delest wrote:This forum should be moved in the Site Feedback public section with full access to any users.
No objection? I'll move it in a few days then.

That's fine. Just remember to cut the "minimum of 10 posts" remark on the forum rules ;)
There are two types of people: those who believe that there are two types of people and those who do not.

openSUSE Leap with KDE Plasma / LibO
User avatar
RGB
 
Posts: 1453
Joined: Mon Oct 08, 2007 1:34 am

Re: Forum Cut-over

Postby Hagar Delest » Fri Oct 28, 2011 10:40 pm

Rules have been removed. I had missed the rules, thanks!
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28383
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum Cut-over

Postby RoryOF » Fri Oct 28, 2011 11:23 pm

@Terry: I noticed that at all times there were a minimum of twelve "guest" connections on the new server. Are these some form of housekeeping, or are they real Users? I ask merely for information.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28394
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Forum Cut-over

Postby floris v » Fri Oct 28, 2011 11:31 pm

RoryOF wrote:One thing at a time, floris! Time enough to change logos when all works well (as it seems to be doing).


It'd require no more than changing the logo file name in the template file and dropping an Apache logo graphic in the correct folder. But Terry isn't necessarily the person who should take care of that.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4037
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Postby Hagar Delest » Sat Oct 29, 2011 12:08 am

As agreed in the proposal, I've moved the Site - governance and Forum Issues - EN to a read only area. Topics can be moved here if requested. Just PM an admin or moderator.
A new section (Private - EN) has been created for future discussions for sensitive matters only. Target is that posts will be sent to the ASF private mailing list.

Note that it has not been discussed IIRC but Quarantine, Deleted topics and Site - Forum administration should be kept as they are to continue current process with spam, temporary deletion and admin mailbox handling.
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28383
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Forum Cut-over

Postby TerryE » Sat Oct 29, 2011 12:21 am

We're sort of in a limbo now waiting for Oracle to update the DNS record. I did a quick mailshot to let the main players know about this URI, but it isn't widely known and this is probably a good thing as we will be switching back to usOOo ASAP. My mailshot was based on a mine of mail address of all posters with >300 posts and visited the forum within the last year.

This situation is a typical left-hand / right-hand thing that you see in large corps. EDS was just the same. Oracle Facilities have found a tenant for the ex-staroffice team's office in Hamburg and are working to a deadline to make it available for them. In the meantime the Oracle networks team are processing the DNS change request at their own tempo. And so the forums and wiki are stuck in this gap. Andrew Rist is doing what he can to expedite this. But in the meantime ...
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
Volunteer
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: Forum Cut-over

Postby acknak » Sat Oct 29, 2011 4:12 am

Everything looks good here.

Nice job, Terry! :bravo:
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Forum Cut-over

Postby DACM » Sat Oct 29, 2011 6:32 am

Nice job and thank you TerryE!

So what's the new URL?
http://user.services.openoffice.org
or
http://ooo-forums.apache.org

They both seem to have the same content now.
AOO 4.1.x; LO 4.2.x; Windows 7/8 64-bit
Warning: Avoid embedded databases --> Solution: Adopt a portable 'split database' folder
Soli Deo gloria
User avatar
DACM
Volunteer
 
Posts: 1138
Joined: Tue Nov 03, 2009 7:24 am

Meet the new boss/Same as the old boss

Postby MrProgrammer » Sat Oct 29, 2011 6:57 am

My interpretation of The rehosting of OpenOffice.org Forums at Apache (ASF) is that the new URL is the old URL: http://user.services.openoffice.org. That would allow existing links in topics to function. Note title of this post.
Mr. Programmer
AOO 4.1.5 Build 9789 on MacOS 10.11.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Volunteer
 
Posts: 3610
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: Forum Cut-over

Postby kingfisher » Sat Oct 29, 2011 7:07 am

I realise this is an interim measure. In case it is of any importance, my log-in was not remembered.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Re: Forum Cut-over

Postby RoryOF » Sat Oct 29, 2011 7:12 am

kingfisher wrote:I realise this is an interim measure. In case it is of any importance, my log-in was not remembered.


It is on the propagated old URL, but not on direct login to the new Apache URL, which is now redundant after the transition. Use the old URL and all should now be well.

 Edit: @kingfisher: Terry notes this in his updated post at
http://user.services.openoffice.org/en/forum/viewtopic.php?f=7&t=44893

Basically, we should use the old URL, not the direct link to the Apache URL, as that will not work correctly. 
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28394
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Forum Cut-over

Postby vasa1 » Sat Oct 29, 2011 8:36 am

LibreOffice 5.2.1.2 on Lubuntu 16.04 (Openbox)
vasa1
Volunteer
 
Posts: 261
Joined: Sat Dec 26, 2009 1:20 pm
Location: Bombay

Re: Forum Cut-over

Postby TerryE » Sat Oct 29, 2011 1:49 pm

The phpBB architecture ignores the inbound request hostname as a security measure and uses the one set in the configuration -- in this case user.services.openoffice.org. However the browser can get confused because the cookies are being set for the wrong hostname and this interferes with login but not guest access. I will be adding a redirection for http://ooo-forums.apache.org/* to http://user.services.openoffice.org/* to prevent this.

Also I still have a fit of work to do to reconfigure the batch jobs and the mailbox listener, so at the moment any requests to ooo-forum-XX-service@apache.org (the new Apache admin mailboxes) are simply piling up in the mail inbox Qs and not being posted to the Admin forums.
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
Volunteer
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: Forum Cut-over

Postby rudolfo » Sun Oct 30, 2011 2:47 am

Nice job, Terry. Thank you for the effort you have put in.
I am still a bit puzzled about the dates. On Friday 28th (European Time) until the late afternoon I was still accessing the old IP address of user.services.openoffice.org -- at least nslookup told me so. After 11pm, again European time, I couldn't access the site, which i thought was the one hour outage of the cut-over that Terry said would be expected. Which is a bit strange because the post above let me assume that the cut-over was done on Friday, 8pm UTC.
But anyway daylight saving time is about to end, so who cares about one hour more or less ;-)

The nameservers that are relevant for resolving the hostname of this forum are still oracle.com servers? Is this going to change at some later time? Though I am sure that the Oracle nameservers will not be affected by the shutting down of the old hosting servers for this forum. And as long as they respond with the right IP address of the apache.org servers that's all what DNS needs.
OpenOffice 3.1.1 (2.4.3 until October 2009) and LibreOffice 3.3.2 on Windows 2000, AOO 3.4.1 on Windows 7
There are several macro languages in OOo, but none of them is called Visual Basic or VB(A)! Please call it OOo Basic, Star Basic or simply Basic.
rudolfo
Volunteer
 
Posts: 1488
Joined: Wed Mar 19, 2008 11:34 am
Location: Germany

Re: Forum Cut-over

Postby TerryE » Sun Oct 30, 2011 7:35 pm

rudolfo wrote:The nameservers that are relevant for resolving the hostname of this forum are still oracle.com servers? Is this going to change at some later time? Though I am sure that the Oracle nameservers will not be affected by the shutting down of the old hosting servers for this forum. And as long as they respond with the right IP address of the apache.org servers that's all what DNS needs.

The servers were in a dev machine room in an office that used to house the Sun/Oracle StarOffice team, and which after shutting the team down was empty (apart from this server infrastructure). Oracle wanted to sell-on sublet the lease. The DNS servers are in Oracle corporate infrastructure and not related to StarOffice. Yes, Oracle still has day-to-day control of the *.openoffice.org DNS records, but I understand that that transfer is in progress and will be done this week.
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
Volunteer
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK


Return to Forum Governance

Who is online

Users browsing this forum: No registered users and 1 guest