Page 1 of 1

[Solved] Corrupted file (SAXParseException error)

PostPosted: Sun Jan 20, 2019 3:55 pm
by GeneticBio
I saved my file and when I tried to open it I got this error! I spent hours working on it. Can anyone please help me figure out what to do. I have to submit this as a grant tomorrow.

File format error found at
SAXParseException: '[word/document.xml line 2]: Attribute w:themeColor redefined
', Stream 'word/document.xml', Line 2, Column 206410(row,col).

*added after
https://drive.google.com/file/d/1VEgSAT ... sp=sharing

I am using Ubuntu 16.04 and Libra office 6.1. I couldn't create an account with this signature for some reason.

Looking through other posts I'll be sure to use the ODF format in the future.

Best,
Eric

Re: HELP corrupted file

PostPosted: Sun Jan 20, 2019 3:58 pm
by RoryOF
Please upload the file to Forum if less than 128KB, or to a file-sharing site.

Re: HELP corrupted file (SAXParseException error) LibraOffic

PostPosted: Sun Jan 20, 2019 4:20 pm
by RoryOF
Please send me a PM with email address to which I can send the repaired file. There were four errors such as you report in it. The repaired file passes well-formed XML test but will not open on my OO (a pre-release version, so that may not be significant, or on AbiWord, which I have never found reliable. LibreOffice may handle it OK.

Please check that all your content and formatting are as you require in the repaired file.

Re: HELP corrupted file (SAXParseException error) LibraOffic

PostPosted: Sun Jan 20, 2019 4:35 pm
by GeneticBio
Thanks so much that worked!! That is really really appreciated kind internet person. <3 I didn't have time to redo that today.

Re: SOLVED corrupted file (SAXParseException error) LibraOff

PostPosted: Sun Jan 20, 2019 10:22 pm
by a1ro
Good day. I have a similar problem with the creator of the topic. I can not open the file in LibreOffice. It gives an error with the following content:
SAXParseException: "No namespace defined for pic"
SAXParseException: '{word / document.xml line 20}: Namespace prefix pic on bodyPr is not defined
Stream 'word / document.xml', Line 20, Colum 23379
Please help restore the document. Writing language: Russian.

https://yadi.sk/d/rtY0wo2FRVWbrw

 Edit: Duplicate question - see viewtopic.php?f=101&t=96676