Page 1 of 1

Trouble running LibreLogo extension

PostPosted: Sun Dec 02, 2012 12:59 pm
by ConMan
I'm running LibreOffice 3.6.3.2 on my MacBook, and I installed the LibreLogo extension because I can think of no better use for a word processing program than to have a little turtle run around and draw pretty pictures in it*. Sadly, any time I click on one of the Logo buttons, I get a pop-up with the following error:

Code: Select all   Expand viewCollapse view
"A Scripting Framework error occured while running the Python script vnd.sun.star.script:librelogo-0.1.oxt|LibreLogo|
LibreLogo.py$stop?
language=Python&location=user:uno_packages.

Message: <type 'exceptions.KeyError'> u:'librelogo-0.1.oxt'

/Applications/LibreOffice.app/Contents/share/extensions/script-
provider-for-python/pythonscript.py:342 in function
getStorageUrlFromPersistentUrl() [package =
self.mapPackageName2Path[ packageName ]]

/Applications/LibreOffice.app/Contents/share/extensions/script-
provider-for-python/pythonscript.py:895 in function getScript()
[self.provCtx.uriHelper.getStorageURI(scriptURI) );]"

I get the message with both versions 0.1 and 0.2 of LibreLogo, and I'm running Script provider for Python 3.3.1 which is apparently the most up-to-date version of it. Any ideas on how I can get that turtle drawing?

* Despite the sarcasm, this is not actually that far from the truth of why I installed it.

Re: Trouble running LibreLogo extension

PostPosted: Mon Dec 03, 2012 11:20 am
by nemeth2
Please, check the name of the installed oxt file. Unfortunately, the script extensions, like this one, work only with unmodified package names, eg. librelogo-0.1.oxt or librelogo-0.2.oxt. After the installation, you have to restart OpenOffice.org (also its Quickstarter, if it exists on Mac). By the way, I tested LibreLogo with OpenOffice.org 3.3 only on Linux and Windows, but I have got report about successful installation on Mac OS X, too.

Re: Trouble running LibreLogo extension

PostPosted: Mon Dec 03, 2012 12:23 pm
by nemeth2
Sorry, I have focused only on the quoted error message. LibreLogo works with LibreOffice, too, moreover the upcoming alpha release of LibreOffice 4.0 will contain LibreLogo, so it will be free from installation problems.

Re: Trouble running LibreLogo extension

PostPosted: Tue Dec 04, 2012 2:15 am
by ConMan
I definitely didn't change the extension name from when I downloaded it, and I did restart LO after installing the extension. I also tried it woth OpenOffice, and got the same error message. However, thank you for letting me know that it will be included in the LO 4.0 alpha - when that it released I will give it a try. In the meantime, any other suggestions would be appreciated.

Re: Trouble running LibreLogo extension

PostPosted: Thu Mar 21, 2013 2:53 am
by ConMan
So, I downloaded and installed LO 4.0 last night, and gave it another shot. This time, clicking on the buttons worked perfectly - the turtle appeared, moved, drew its lines, and cleared the screen as required. However, attempting to run a program either from within the document via the "play" button, or through the command line, did absolutely nothing - the turtle just stayed where it was, but no error messages popped up. Also, the "translate" button did generate an error message, which I can't see right now as it's on my home computer and I'm at work. I am happy to have progress, but obviously I want to be able to do all the nifty things that are only possible from a written program. Any ideas?