ALT key doesn't seem to work in LO

Help with installation and general system troubleshooting questions concerning the office suite LibreOffice.

ALT key doesn't seem to work in LO

Postby Baasha » Sun Oct 23, 2011 1:55 am

Hi,
I am using LO 3.4.3 on Ubuntu 11.10.

Since the switch to LO from OOo the ALT key no longer works with selecting menu items. For instance, in Calc if I want to add a row I would normally type ALT+i and then r. But in LO the ALT key seems to be being ignored so what I get on the screen is "ir".

I had a look in Tools>Customize>Keyboard but there is no listing for the ALT key. The closest thing I could find was ???+a key, which looked like you could assign a key to the ???, but then I discovered that there was no way to modify that. The help files give no information about how to do this, just a generic description of what customizing the keyboard does.

How does one go about assigning key combinations to perform functions that used to be built in with OOo?
Baasha
 
Posts: 51
Joined: Fri Apr 11, 2008 9:32 pm

Re: ALT key doesn't seem to work in LO

Postby thomasjk » Sun Oct 23, 2011 5:25 am

That combination work for me using 3.4.3 on WIN 7. Are you using the vanilla LO version or the Linux distribution version?
Tom K.
Windows 10 Home version 1803 17134.165
LibreOffice 5.4.7.2
thomasjk
Volunteer
 
Posts: 4408
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: ALT key doesn't seem to work in LO

Postby Baasha » Sun Oct 23, 2011 9:43 pm

I am using the Ubuntu Linux version. AFAIK there shouldn't be any major difference, and this has never been an issue before. Did LO make some changes when they left OOo?
Baasha
 
Posts: 51
Joined: Fri Apr 11, 2008 9:32 pm

Re: ALT key doesn't seem to work in LO

Postby thomasjk » Sun Oct 23, 2011 10:47 pm

Yes there have been lots of changes. I can't speak to Linux version but the windows version has been changed several times.
Tom K.
Windows 10 Home version 1803 17134.165
LibreOffice 5.4.7.2
thomasjk
Volunteer
 
Posts: 4408
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: ALT key doesn't seem to work in LO

Postby acknak » Mon Oct 24, 2011 12:57 am

LO 3.4.3 on Fedora 13 seems to work. Alt+F gets me the file menu, I can assign shortcuts to Alt-X, etc.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: ALT key doesn't seem to work in LO

Postby Baasha » Mon Oct 24, 2011 1:53 am

Ok then, I now know that at least some versions of the Linux distribution works as it should. Who would you suggest I talk to about the Ubuntu version. Does the Ubuntu community have developers who work on their own version, or is it a more generic Linux group who develops LO for the Linux community?
Baasha
 
Posts: 51
Joined: Fri Apr 11, 2008 9:32 pm

Re: ALT key doesn't seem to work in LO

Postby acknak » Mon Oct 24, 2011 2:08 am

Where did you get the LO from?

If you downloaded it yourself from LO, then I'd report the bug back to the project.

If you installed it through Ubuntu, then I'd report it there.

In any case, I'd try starting LO with a clean user settings profile before I reported anything: [Tutorial] The OOo user profile
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: ALT key doesn't seem to work in LO

Postby Baasha » Mon Oct 24, 2011 2:25 am

Thx Acknak, I will try your suggestions.
Baasha
 
Posts: 51
Joined: Fri Apr 11, 2008 9:32 pm

Re: ALT key doesn't seem to work in LO

Postby Nikos » Wed Oct 26, 2011 4:26 pm

Hello Baasha,

just wanted to say Alt works perfectly for me on a newly updated ubuntu 11.10 with the distro version of LibreOffice. So there is probably something else you have customized?
LibreOffice 4.0.5 on OpenSuse 12.3/64bit/KDE4.10 (Version from the TDF page) + LibreOffice 4.1.1 on Debian Wheezy/64bit/KDE4.8 + LibreOffice 4.1.1 on Win7/64bit
Nikos
 
Posts: 172
Joined: Mon Dec 17, 2007 11:50 am

Re: ALT key doesn't seem to work in LO

Postby acknak » Wed Oct 26, 2011 5:06 pm

I'm guessing here, but it may have to do with your keyboard or keyboard settings: maybe Alt+ combinations are already reserved for entering other characters.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3


Return to LibreOffice

Who is online

Users browsing this forum: No registered users and 2 guests