Typing Complex Text Language

Help with installation and general system troubleshooting questions concerning the office suite LibreOffice.

Typing Complex Text Language

Postby PrakashC » Fri Oct 07, 2011 2:37 pm

I am running LibreOffice under OpenSUSE 11.4 (64 bit). I have used OpenOffice under both Windows Vista and OpenSUSE 11.2 without this issue.

I set up keyboard input to Hindi (either Bolnagri or Wx), set up document accordingly in Libre writer. The first key stroke enters whatever alphabet has been selected, but the next key stroke whether alphabet or "matra like ी ू" does not get in. Pressing space bar enters a blank space and the keystroke thereafter is accepted and again the freeze! Thus I can only type in an alphabet or "matra" standing alone and not form words. I tried to type in Hindi in kwrite and it worked fine! So the problem is not from the OS or kbd.

Secondly is it possible to add a TT font set to the package.

LibreOffice on OpenSUSE 11.4 (64 bit)
Open Office 3.3 on Windows Vista Home Premium
Posts: 1
Joined: Fri Oct 07, 2011 10:56 am

Re: Typing Complex Text Language

Postby Robert Tucker » Fri Oct 07, 2011 4:46 pm

I don't think I've seen this problem before. Are you just using the Hindi keyboard layout or are you using iBus or SCIM? Is there a Hindi OpenSUSE or Linux forum where you could ask? You could file a bug report here:


One way to install fonts system wide is to copy them to (a folder in) /usr/share/fonts.
LibreOffice 6.x.x on Fedora 31 and Ubuntu 19.10 (Dual Boot)
User avatar
Robert Tucker
Posts: 1247
Joined: Mon Oct 08, 2007 1:34 am
Location: Manchester UK

Return to LibreOffice

Who is online

Users browsing this forum: No registered users and 2 guests