Page 1 of 1

[Issue] LibreOffice won't remember Printer Duplex setting

PostPosted: Sun Aug 21, 2011 10:59 am
by 2CV67oo
Excuse me if this is a RTFM problem - I think I have had a good look round before posting...

All applications of LibreOffice fail to remember when I set printer options to "Duplex".
Every new "Print" command requires me to reset "Duplex".

I am running LibO 3.3.3 in Ubuntu 11.04

Tools/Options/Load/Save/General has default (I think) settings, with the 2 "Load" items checked, in case that is significant.

Thanks for any help!

Re: LibreOffice won't remember Printer Duplex setting.

PostPosted: Sun Aug 21, 2011 11:21 am
by Villeroy
These settings can be stored individually in the document.
Apply your settings, apply some dummy change (edit and undo) to your document, save the document, close the document, reopen the document. The printer set up is still there.

Re: LibreOffice won't remember Printer Duplex setting.

PostPosted: Sun Aug 21, 2011 11:23 am
by RoryOF
Set the Duplex option in your System / Administration / Printing settings. You can set up a second printer instance there, one Duplex by default, one non duplex.

Re: LibreOffice won't remember Printer Duplex setting.

PostPosted: Wed Aug 24, 2011 5:25 pm
by 2CV67oo
Thanks for those 2 rapid replies & sorry for my slow reaction!
(I am often confused by the positive-looking tick by "Subscribe Topic", which looks like I have subscribed, whereas I had not, so did not find the replies...)

It seems there are at least 3 places where I can set Duplex On or Off, and as far as I can see, they work like this.

1. In System > Admin > Printing > Printer > Properties > Printer Options > 2-Sided Printing: This has always been at (default?) "Off" & has never prevented LibO or any other application printing Duplex whenever I ask.

2. In LibO > File > Printer Settings > Properties > Duplex: This setting can be altered, stays at last setting as long as document is open, stays at latest-saved setting when document is re-opened, and seems to have no effect at all on printing!

3. In LibO > File > Print > General > Properties > Paper > Duplex: This is the one I normally use in LibO (& similar ones in other apps).
It immediately controls whatever I print next (as expected), but in LibO it then reverts to its default state for the next Print.
It is not saved when the document is saved & re-opened, even with dummy changes to force the saving.
I thought the default state was "Off", but in playing around, I discover that the default state is whetever I have set in item 1.

I really don't want to have yet another set of phantom printers (with various drivers I use) just for Duplex printing in LibO.
Imagine trying to explain that to all users...
Surely LibO should save Duplex settings with each document, just like all other applications do?

It probably does, but I have not found out how yet...

Thanks for your continuing patience!

Re: LibreOffice won't remember Printer Duplex setting.

PostPosted: Thu Aug 25, 2011 10:51 pm
by 2CV67oo
I checked back with OpenOffice 3.2.0 in Ubuntu 10.04 & that works just as you would expect, with same PC & same printer:
If I select Duplex, then that stays selected for all subsequent printing so long as the document is open.
If I save (with option to allow saving without changes, or by forcing with dummy changes) then Duplex stays saved with the document.

All I want is for LibreOffice to do the same!

Re: LibreOffice won't remember Printer Duplex setting.

PostPosted: Fri Aug 26, 2011 6:31 pm
by 2CV67oo
I see there is a bug report on this, which I have commented.
https://bugs.freedesktop.org/show_bug.cgi?id=33639

Does this feature actually work OK in LibreOffice for everybody else?
In Ubuntu?

Re: LibreOffice won't remember Printer Duplex setting.

PostPosted: Sun Aug 28, 2011 10:34 pm
by 2CV67oo
In the absence of any other ideas (hint...) I removed & reinstalled LibreOffice.

No change.

No other ideas or comments?

Re: LibreOffice won't remember Printer Duplex setting.

PostPosted: Fri Nov 04, 2011 12:46 pm
by 2CV67oo
Villeroy wrote:These settings can be stored individually in the document.
Apply your settings, apply some dummy change (edit and undo) to your document, save the document, close the document, reopen the document. The printer set up is still there.


I left this problem unsolved for a long time, but today have been trying to print again from LibreOffice.

I can now see that not only the Duplex setting, but all or most other printer settings cannot be saved to a document either.

In today's case, I wanted to save one Draw document to print on Glossy Photo Paper at 1200dpi with High quality, but those details have to be reset every print.

My comments in my post of Aug 24 still stand:
Putting any settings in LibO > File > Print > General > Properties, gives the right result for one print, but is not retained for the next print.
I can set the printer settings in LibO > File > Printer Settings > Properties, and they stay there OK, but have no effect on what I then see in LibO > File > Print > General > Properties so no effect on printing.
This seems to be the key problem - why are the settings in LibO > File > Printer Settings > Properties, not being taken into account?

As I said in post of Aug 25, OpenOffice (which I still have in Ubuntu 10.04) works just the way you would expect.
Whatever I put in File > Printer Settings > Properties, is automatically picked up in File > Print > General > Properties and does not need to be reset for every print and is still there when the document is reopened.

Surely LibreOffice should be working the same way?

Re: [Issue] LibreOffice won't remember Printer Duplex settin

PostPosted: Fri Nov 04, 2011 1:22 pm
by Villeroy
Well, LibreOffice has another development culture. Lots of people add lots of amazing things (horrible stupid mess too) and nobody overlooks all the possible side effects.
I'm not sure if they follow clear specifications how each and every aspect is supposed work anyway. These specifications were very strict in the OOo development process and quite often they restrained amazing new features that were not well thought.

Thank you very much for filing the bug which has been confirmed by now (status is NEW).

Re: [Issue] LibreOffice won't remember Printer Duplex settin

PostPosted: Sun Jan 29, 2012 10:08 am
by Daddie0
For the record, I've experienced the same problem in OO, so I don't think this is just a LibreOffice issue. I was actually saddened to see Libre had the same problem as I was just thinking of switching to it to try to correct the issue with OO.

So is there any solution in sight? I've had to revert back to OO 3.1.1, which is now acting flaky (apparently doesn't like being used after 3.3.0 has been uninstalled?) and I'm not sure what to try next. Any advice?

Re: [Issue] LibreOffice won't remember Printer Duplex settin

PostPosted: Tue Nov 13, 2012 7:00 pm
by oldamnofgammagamma
I have the same problem on Open Office 3.1.1 on Linux.

Re: [Issue] LibreOffice won't remember Printer Duplex settin

PostPosted: Sun Nov 18, 2012 4:03 pm
by mlagan
I have the same problem - Writer won't remember Duplex setting. I can only set it for one print session. After that is defaults back to single sided. File/printer settings/properties says it is duplex Short Edge (flip) but when I go to file/print.../properties it goes back to Duplex = Off. This is most frustrating as I often forget to check it and end up with singled copies and wasting paper and ink. If anyone has any ideas I would love to hear from you. BTW using lastest version of LO 3.6.3 and Ubuntu Precise Pangolin

Re: [Issue] LibreOffice won't remember Printer Duplex settin

PostPosted: Sun Nov 18, 2012 7:40 pm
by Hagar Delest
Vote for the bug.

Re: [Issue] LibreOffice won't remember Printer Duplex settin

PostPosted: Fri Jun 07, 2013 6:31 am
by Ron O
If your OS is Ubuntu or another Linux distro, there is a good chance that your printer drivers are using the CUPS wrapper. Open a browser (yes, a WEB browser, believe it or not) and enter into the address box

http://localhost:631/admin

Press the Manage Printers button then select your printer from the list. If there are two of the same model listed, select the one that does NOT say "text only printer". This opens a new page where you drop the Administration menu and select Default Options. Under "Two Sided" select whether you will be binding (stapling) pages on the left (long side) or on the top (short side). Select any other defaults you want and save. When it asks for a username and password, I used my Ubuntu username and password. (I do not remember putting this into CUPS, so it must have defaulted to the system info.)

Now it always prints duplex unless you change the individual document.

Done. Practically painless too- no sudo-tampering with system files.