From Power Point to Impress

Discuss the presentation application

From Power Point to Impress

Postby DBrodeur » Fri May 31, 2019 11:57 pm

I had a PPt presentation that was almost done, I had to change computer (mine died) and I didn't have PowerPoint anymore. I am trying OpenOffice 4.1.6. When I opened my document in Impress, all the images where gone (I can understand that, the links were all wrong since I change computer.) So 1 by one I reopen all the images (jpg) in Impress but it keeps crashing. I get the message "bad allocation fatal error"
So I save every move I make to not redo it all every time, and it still crashing and when I reopen some of the images (that were saved!) are not there again...

SO far I had to reopen some of the images 4 times...

Is this a known problem and is there a fix to it?

Thank you!
DB
OpenOffice 4.1.6 on Windows 10
DBrodeur
 
Posts: 6
Joined: Fri May 31, 2019 11:32 pm

Re: From Power Point to Impress

Postby RusselB » Sat Jun 01, 2019 12:44 am

Welcome to the Forums.
This is a known problem, but there is no guaranteed fix.
A search of the forum for that error message brings up your post, and an additional 11 posts.
Some steps that may help include resetting your OpenOffice User Profile, as described here, restarting your computer in Safe Mode and running OpenOffice in Safe Mode, switching from OpenOffice to LibreOffice.
I'm going to suggest that you try these, one at a time, and see if you have any better luck.
OpenOffice 4.1.7 and LibreOffice 6.3.3.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 5697
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: From Power Point to Impress

Postby RoryOF » Sat Jun 01, 2019 9:12 am

With Windows 10 there was at least one update to Win 10 that caused instability of OpenOffice. This was cured with later updates, so I suggest that you tell Win 10 to fully update, verify that there are no outstanding updates, and try OO again.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29918
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: From Power Point to Impress

Postby Bidouille » Sat Jun 01, 2019 9:34 pm

A workaround is to use Powerpoint Online [1]
And download a copy exported as ODP


[1] https://office.live.com/start/PowerPoint.aspx
User avatar
Bidouille
Volunteer
 
Posts: 295
Joined: Mon Nov 19, 2007 10:58 am
Location: France

Re: From Power Point to Impress

Postby RoryOF » Sat Jun 01, 2019 9:49 pm

There is a known problem with OO suddenly losing images. I have found a method which seems to cure this for me; I have only tested this method extensively on Xubuntu, but in the dim distant past, when I used Windows (10 years ago), I recollect that it also worked on it. The method is to use /Tools /Options /Load-Save /General and uncheck "Save AutoRecovery information every ...". It now becomes your reesponsibility to Save your file more frequently, preferably using timed/dated backups. The extension you can download from
https://forum.openoffice.org/en/forum/viewtopic.php?p=406045#p405921
helps with that process.
Note that you must invoke it separately using its button; it does not replace the standard save mechanism.

This fix may or may not work for you - I offer it in goodwill - I have just completed preparation of a 100 slide presentation, incorporating about 200 images and taking 38 hours editing, with no loss of images, so I am content that it works for me on my equipment.

LibreOffice have recently expended €44k on having the problem fixed by recoding, so you could switch to that if you wished.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29918
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: From Power Point to Impress

Postby DBrodeur » Sun Jun 02, 2019 5:25 pm

Thank you, I will look into it. Hope it's going to work.
Danielle
OpenOffice 4.1.6 on Windows 10
DBrodeur
 
Posts: 6
Joined: Fri May 31, 2019 11:32 pm

Re: From Power Point to Impress

Postby DBrodeur » Sun Jun 02, 2019 5:27 pm

RusselB wrote:Welcome to the Forums.
This is a known problem, but there is no guaranteed fix.
A search of the forum for that error message brings up your post, and an additional 11 posts.
Some steps that may help include resetting your OpenOffice User Profile, as described here, restarting your computer in Safe Mode and running OpenOffice in Safe Mode, switching from OpenOffice to LibreOffice.
I'm going to suggest that you try these, one at a time, and see if you have any better luck.


Thank you for your help. I will try one of these.
Danielle
OpenOffice 4.1.6 on Windows 10
DBrodeur
 
Posts: 6
Joined: Fri May 31, 2019 11:32 pm

Re: From Power Point to Impress

Postby DBrodeur » Sun Jun 02, 2019 5:30 pm

Bidouille wrote:A workaround is to use Powerpoint Online [1]
And download a copy exported as ODP


[1] https://office.live.com/start/PowerPoint.aspx


Oh! I didn't know that. That should let me edit it after I download or I better edit online and download when everything is done...
Thanks!
Danielle
OpenOffice 4.1.6 on Windows 10
DBrodeur
 
Posts: 6
Joined: Fri May 31, 2019 11:32 pm

Re: From Power Point to Impress

Postby DBrodeur » Sun Jun 02, 2019 5:32 pm

RoryOF wrote:With Windows 10 there was at least one update to Win 10 that caused instability of OpenOffice. This was cured with later updates, so I suggest that you tell Win 10 to fully update, verify that there are no outstanding updates, and try OO again.

I just got my computer last week (needed to be replaced) so I'm pretty sure it's up to date. But I will check. Thank you!
Danielle
OpenOffice 4.1.6 on Windows 10
DBrodeur
 
Posts: 6
Joined: Fri May 31, 2019 11:32 pm

Re: From Power Point to Impress

Postby DBrodeur » Sun Jun 02, 2019 5:56 pm

I was wondering if this problem is related... some of the images I am adding in the presentation are changing colors, most of them are fine but for some reason some others are way off. FYI they are all jpg.
If it's not related I will post another topic. Please let me know. Thank you!
Danielle
* attached file
Attachments
Capture.JPG
Difference between the colors in File Explorer and in Impress.
OpenOffice 4.1.6 on Windows 10
DBrodeur
 
Posts: 6
Joined: Fri May 31, 2019 11:32 pm

Re: From Power Point to Impress

Postby RoryOF » Sun Jun 02, 2019 6:50 pm

I can't answer for colour changes - most of my images are tif, png or jpg and their colour rendering seems quite accurate - at least to onscreen or projection viewing without careful colour measurement. I am aware that there are different forms of internal coding for jpg.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29918
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Impress

Who is online

Users browsing this forum: No registered users and 1 guest