Inserting movie in new Impress presentation crashes AOO

Discuss the presentation application

Inserting movie in new Impress presentation crashes AOO

Postby sloebman » Fri Apr 19, 2019 10:44 pm

Hi There,

Recently, I was sent a pptx presentation with embedded movies and gifs. I opened it successfully in Impress, and I was able to start the slide show. When I got to a slide with multiple objects (big movie side by side a gif), A.O.O. crashed. I tried to reopen it, and I was unable to do so (caught in a loop trying to recover and crashing again). I then tried to open an existing odp presentation with an embedded mp4 file that I generated previous (and I know works), and it crashed in the same way.

I have been troubleshooting this a bit. I have followed helpful advise on the forum to clear my user profile (removed Library/Application Support/OpenOffice/4/user). I also have removed the Library/Saved Application State/org.openoffice.script.savedState files. I have looked for hidden locked files
(files including .~lock.*) and removed them. I have trashed my A.O.O. install (put A.O.O. found in my Application Folder in the Trash, emptied Trash, and rebooted my MacBook Pro). I have downloaded a clean version of A.O.O., reinstalled, and generated a new user profile. I then start a brand new Impress Presentation. If I try to insert a movie (mp4 or mpg) into a new presentation, it instantly crashes. Likewise, I cannot open any existing odp files with movies; they all crash immediately.

I have also installed LibreOffice. It will open and play existing odp files. However, I am used to working in A.O.O. instead of LibreOffice, and I would prefer to fix my A.O.O. install rather than adapting to LibreOffice. Any ideas or suggestions of what I can do to fix the problem I am having?

Thank you for any help you can offer.
OpenOffice 4.1.6 on macOS Mojave 10.14.4
sloebman
 
Posts: 2
Joined: Fri Apr 19, 2019 10:08 pm

Re: inserting movie in new impress presentation crashes A.O.

Postby MrProgrammer » Sat Apr 20, 2019 10:41 pm

Hi, and welcome to the forum.

sloebman wrote:Recently, I was sent a pptx presentation with embedded movies and gifs.
OpenOffice was created to make a high quality office suite available as open source software. It is not intended to be a clone of Microsnot's office suite. If you need to work reliably with Powerpoint presentations, use Powerpoint Online.

sloebman wrote:If I try to insert a movie (mp4 or mpg) into a new presentation, it instantly crashes. Likewise, I cannot open any existing odp files with movies; they all crash immediately.
There are numerous topics in this forum about movies in Impress. You should review them to determine if any address your situation.
[Tutorial] Which video formats does AOO support?
You could try to reproduce the difficulty on the Guest User though this is less likely to resolve the problem if it occurs with a new profile. [Tutorial] Mac FAQ Q28/A28

If this solved your problem please go to your first post use the Edit button and add [Solved] to the start of the title. You can select the green checkmark icon at the same time.
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 3893
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: inserting movie in new impress presentation crashes A.O.

Postby sloebman » Sun Apr 21, 2019 2:01 am

MrProgrammer wrote:OpenOffice was created to make a high quality office suite available as open source software. It is not intended to be a clone of Microsnot's office suite. If you need to work reliably with Powerpoint presentations, use Powerpoint Online.


Fair enough. I mention the pptx file because it was a trigger for the ongoing problem I have now (I do not intend to open pptx files with Impress in the future).

MrProgrammer wrote:There are numerous topics in this forum about movies in Impress. You should review them to determine if any address your situation.
[Tutorial] Which video formats does AOO support?


I have read through the forum discussions on movies in Impress; unfortunately, I cannot find a thread on this particular issue. That is, if I start an empty Impress presentation with a brand new user profile and try to insert a movie of a known supported type (e.g., a mpg or mov file that is an appropriate resolution and length), the program crashes instantly.

A Guest User account does not appear to resolve the issue. Any other thoughts on what I can do? It is agonizing to have the software cease to function as it did before.
OpenOffice 4.1.6 on macOS Mojave 10.14.4
sloebman
 
Posts: 2
Joined: Fri Apr 19, 2019 10:08 pm

Re: Inserting movie in new Impress presentation crashes AOO

Postby Bidouille » Tue Apr 30, 2019 8:56 am

Try to insert this video: https://forum.openoffice.org/fr/forum/d ... p?id=25578
Did the crash occurs?
User avatar
Bidouille
Volunteer
 
Posts: 294
Joined: Mon Nov 19, 2007 10:58 am
Location: France


Return to Impress

Who is online

Users browsing this forum: No registered users and 1 guest