Inserted video has wrong format

Discuss the presentation application

Inserted video has wrong format

Postby victorpaul » Thu Nov 22, 2018 8:24 am

When I try to insert a video I get a message to say it is the wrong format. But nowhere can I find which formats are acceptable

Title Edited. A descriptive title for posts helps others who are searching for solutions and increases the chances of a reply [robleyd, Moderator].
openoffice 4.1.0 on windows 7
victorpaul
 
Posts: 10
Joined: Mon May 05, 2014 5:54 pm

Re: videos

Postby robleyd » Thu Nov 22, 2018 8:43 am

Into what application are you trying to insert a video, and what steps are you using to do the insert?
Cheers
David
Apache OpenOffice 4.2.0 Build 9820 alpha version - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 2515
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Inserted video has wrong format

Postby victorpaul » Thu Nov 22, 2018 9:30 am

I am trying insert the video into a Presentation using INSERT, Movie/Sound
openoffice 4.1.0 on windows 7
victorpaul
 
Posts: 10
Joined: Mon May 05, 2014 5:54 pm

Re: Inserted video has wrong format

Postby John_Ha » Thu Nov 22, 2018 1:10 pm

Try searching the Impress forum with video.

Try searching Help with video which says:

To insert a movie or sound file into your document
1. Click where you want to insert the file.
2. Choose Insert - Movie and Sound.
3. In the File Open dialogue box, select the file that you want to insert.

The file types that are listed in this dialogue box are not supported by all operating systems.

4. Click Open.
Alternatively, you can choose Tools - Media Player to open the Media Player. Use the Media Player to preview all supported media files. Click the Apply button in the Media Player window to insert the current media file into your document.


Try clicking the arrow in the file format box when you insert.

Clipboard02.png
Clipboard02.png (6.17 KiB) Viewed 422 times

Showing that a problem has been solved helps others searching so, if your problem is now solved, please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6467
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Inserted video has wrong format

Postby RoryOF » Thu Nov 22, 2018 3:16 pm

It may be - probably will be - that LibreOffice will handle the format better. I am aware that improved multimedia handling is being investigated for a future release of OO; this may depend on external handling packages.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28413
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Inserted video has wrong format

Postby John_Ha » Thu Nov 22, 2018 3:31 pm

Google convert video to convert any video format into any other format.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6467
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Inserted video has wrong format

Postby RoryOF » Thu Nov 22, 2018 3:50 pm

OpenOffice on Windows may differ from OO on linux (which is what I use). In general, since OO 3.X, (not sure exactly when) OO linux hasn't hooked well to gstreamer 0.10 and hasn't played the few video clips I might use. Rather than waste my time trying to sort this I merely hyperlink to the system video player; my video clips are typically several minutes long, so the clunkiness of this link is easily overlooked. A recent trial of a version of OO under development included hooks to gstreamer 1.0 which did add multimedia functionality, but this development has been paused while OO 4.1.6 was issued and revised.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28413
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Inserted video has wrong format

Postby John_Ha » Thu Nov 22, 2018 3:53 pm

RoryOF wrote: I merely hyperlink to the system video player

Rory
Could you upload a small example presentation with a hyperlink. Thanks
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6467
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Inserted video has wrong format

Postby RoryOF » Thu Nov 22, 2018 5:03 pm

Here is a small sample. On the second slide, the first two hyperlinks won't work - they are to a file stored locally on my computer; all my video files are too large to enclose with this crude presentation. The third link should work to a film on Internet Archive.
Attachments
Sample multimedia.odp
(14.84 KiB) Downloaded 18 times
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28413
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Inserted video has wrong format

Postby John_Ha » Thu Nov 22, 2018 6:29 pm

Thanks.

The links also work if I export the file to a PDF.

Exporting an Impress presentation to a PDF is a useful way of presenting it as AOO (and LO) sometimes lose images - a PDF does not.
Attachments
Sample multimedia.pdf
(37.24 KiB) Downloaded 16 times
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6467
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Inserted video has wrong format

Postby RoryOF » Thu Nov 22, 2018 6:33 pm

I noted that on export to PDF, all links defaulted to the last (the Internet) link. I didn't investigate further.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28413
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Inserted video has wrong format

Postby John_Ha » Thu Nov 22, 2018 7:10 pm

The three links in the PDF work OK for me on W7.

I moved the Impress .odp file to C:\Users\John\Desktop and created the PDF. The first two links point to the "equivalent location" on my PC, the third points to archive.org.

I get the same values for the links irrespective of whether I tick or don't tick Export URLs relative to the file system in File > Export as PDF > Links.

Clipboard02.gif
Clipboard02.gif (10.38 KiB) Viewed 391 times

Editing an already inserted hyperlink was surprisingly tricky. I needed Help which says

Editing Hyperlinks

When you Ctrl-click a hyperlink in a Writer document, your web browser opens with the requested web address. If you don't use a mouse, position the cursor inside the hyperlink and open the context menu by Shift+F10, then choose Open Hyperlink.

Change the text of a hyperlink as follows

- In Writer documents, you can click anywhere into a hyperlink and edit the visible text.
If you leave the hyperlink by positioning the cursor somewhere else, only the visible text will be changed.
If you leave the hyperlink by entering a space character directly following the last character, the AutoCorrect - if enabled - will change the target URL to be the same as the visible text.

- In all document types, you can open the Hyperlink dialogue box to edit a hyperlink. First set the cursor into the hyperlink or directly in front of the hyperlink, then click the Hyperlink icon on the Standard bar.

Change the URL of a hyperlink as follows

- Option 1: As described above, open Hyperlink Dialogue Box.
- Option 2: Open Hyperlink Bar (View - Toolbars - Hyperlink Bar). Click on the hyperlink, do not release the mouse button and drag the hyperlink to the Hyperlink Bar. Edit the URL on the Hyperlink Bar and press the Return key.

Change the attribute of all hyperlinks

1. Open the Styles and Formatting window.
2. Click the Character Styles icon.
3. Right-click the "Internet Link" or "Visited Internet Link" character style, and choose Modify.
4. In the dialogue box, select the new attributes, and click OK.

Edit a hyperlink button

If the hyperlink is a button, click on the border to select it, or press the Alt key while clicking. Open the Properties dialogue box through the context menu. You can edit the label text under "Caption," and modify the address in the "URL" field.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6467
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Impress

Who is online

Users browsing this forum: No registered users and 2 guests