[Solved] Save - Error in AOO Impress

Discuss the presentation application

[Solved] Save - Error in AOO Impress

Postby finnkastel@gmail.com » Tue Jul 12, 2016 1:17 pm

Can't save changes to existing ODF files - using OO 3.4.1 and win8.1. After upgrading to OO 4.1.2 i still doesn't work. I also tried to make a new presentation using OO 4.1.2. and win8.1, but same result. I keep getting this message: "Error saving teh documnet XXXXXX: Write error. The file could not be written"
Last edited by finnkastel@gmail.com on Mon Jul 25, 2016 1:57 pm, edited 1 time in total.
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby RoryOF » Tue Jul 12, 2016 1:44 pm

In /File /Save As, do you have "Automatic file name extension" checked? It should be.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29744
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Tue Jul 12, 2016 1:49 pm

Thanks. Yes I have. Furthermore, I just realized that I face the same issue (can't save) when working with ODS files
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby RoryOF » Tue Jul 12, 2016 2:05 pm

If you navigate to your Desktop in the /File /Save As dialog can you Save to your Desktop?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29744
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Tue Jul 12, 2016 2:08 pm

No, same result :-(
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby Hagar Delest » Tue Jul 12, 2016 9:11 pm

Can you save there with another application (like Notepad for example)?
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28587
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Tue Jul 12, 2016 11:56 pm

Yes, e.g. ODT files - so far, the only extensions I can't save are ODS and ODP
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby Hagar Delest » Wed Jul 13, 2016 9:08 pm

Ah, well, rather strange.
Have you tried to reset your OpenOffice user profile?
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28587
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Thu Jul 14, 2016 11:08 am

I did that when I upgraded to 4..1.2 the first time ( didn't tick the "keep..." option during the process). Anyways, I just did reset it again. Now it seems that I can create AND save a new ODS file, but I still can't save the old ones.
Unfortunately the problem persist when it comes to ODF files. When I try to save a new ODF file I get the message: "Error saving the document XXXXXX: Write error. The file could not be written" The strange thing is that the file name indicated in the message is different from the one I gave it ?
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby Hagar Delest » Fri Jul 15, 2016 9:38 pm

Can you upload such a file here if there is no sensitive data (see How to attach a document here)?
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28587
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Fri Jul 15, 2016 10:35 pm

budget 2.ods
Spredsheet that causes a lot of frustations when trying to file changes/ additions
(21.72 KiB) Downloaded 102 times
I attach a spreadsheet which I have used for more than a year using 3.4.1 and WIN 8.1 without any problems. Suddenly I was not able to update the file. As earlier stated, I have the same issue with presentations. It seems though that documents are OK. The problem appearss randomly. I can delete but not add (most of the time :crazy:
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby RoryOF » Fri Jul 15, 2016 10:47 pm

Your sample file opened correctly and saved correctly for me after alteration.

I suggest you delete or rename the OpenOffice user profile. If that doesn't cure the problem, try running Windows in Safe Mode. If the problem does not occur in t hat mode, then you must look for crosstalk from some program that runs in Windows Normal Mode.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29744
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Save - error in OO Impress

Postby Hagar Delest » Sat Jul 16, 2016 11:15 am

See also: [Solved] Error writing file message
There are links to another topic that may help.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28587
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Sun Jul 17, 2016 9:58 am

First of all - thank you RoryOF and Hagar for your contribution. Appreciated!
I have renamed and afterwards deleted the user profile in version 3.4.1. The problem still occurred. Then I installed 4.1.1. No change. Finally, I ran Windows in Safe Mode and it cured the problem :-)
How do I look for crosstalk programs ? Any standard process or method ??

When Iook on the list of installed programs, I currently have no new programs installed immediately before the problem occurred.
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby RoryOF » Sun Jul 17, 2016 10:06 am

The only way I know of sorting out such a problem is to list the processes running in Safe Mode and the processes running in normal mode and one by one remove the extra ones. You could try disconnecting from the internet (for safety - turn off the router) and disabling your antivirus and your firewall (one at a time); these are the most likely culprits. If you can tie the problem down to one of these then it is a matter of tweaking its settings. The chances are that someone on forum can give you the settings for that firewall or antivirus that works for him.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29744
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Sun Jul 17, 2016 1:09 pm

Thanks. Disconnecting from the internet didn't solve the problem. I'm using F-Secure SAFE as security platform
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Wed Jul 20, 2016 6:20 pm

I now have identified at least one service which has caused the save error message. It is a service delivered by F-Secure. I'm in contact with their backend team and I expect a feed back within the next 24 hours.
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby RoryOF » Wed Jul 20, 2016 7:16 pm

It has been noted that applications which touch open OpenOffice files, such as continuous backup utilities, can render OO unstable. It is possible that you will have to configure F-Secure to check OpenOffice files on open or close, not to monitor them continually.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29744
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Thu Jul 21, 2016 8:56 am

Is your statement consistent with the fact that I successfully can update ODT files even when F-Secure is running ? - as opposed to ODS and ODP files.
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby RoryOF » Thu Jul 21, 2016 9:03 am

I make no claims for my statement being consistent with YOUR problem. I draw attention to the fact that a situation as I outlined occurred in the past and may still be applicable. Whether it is applicable or not to your case I cannot say, as I have not detailed knowledge of your computer setup.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29744
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Thu Jul 21, 2016 6:38 pm

Point taken. I have done a little experiment. I can save the spreadsheet if I save it as a .xls document, and I can continue working in xls format. But - if I then try to save it as .ODS, I get this save error : "Error saving the document XXXXXX: Write error. The file could not be written"

Have you met that before ?
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby RoryOF » Thu Jul 21, 2016 6:48 pm

Are you certain that you have "Automatic file name extension" checked in /File /Save as, and that the file is definitely showing up with an .ods extension?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29744
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Thu Jul 21, 2016 7:04 pm

Yes - 100%
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby RoryOF » Thu Jul 21, 2016 7:11 pm

If you navigate the /Save As to another directory, can you save in .ods format there?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29744
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Thu Jul 21, 2016 7:27 pm

I could. Then I started to tap in some numbers )4 cells only) - and was allowed to save :-) Then I added those numbers - but now i couldn't save. I chose the regret function and tried again. This time I could save. Very strange. I added 4 more numbers without any problem, but when I afterwards inserted a new colomn and copied and pasted an existing colomn into that the save error appeared again. Very unstable and unpredictable, it seems.
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm

Re: Save - error in OO Impress

Postby finnkastel@gmail.com » Mon Jul 25, 2016 1:52 pm

One hour ago I removed a piece of software called ByteFence. It must have sneaked in together with another piece of software (java ?).An yway, now I'm back to normal (it seems) allowing me to make alterations of and save odt files. Thanks. I'll mark it solved.​
OpenOffice 4.1.2 on Windows 8.1
finnkastel@gmail.com
 
Posts: 14
Joined: Tue Jul 12, 2016 12:53 pm


Return to Impress

Who is online

Users browsing this forum: No registered users and 7 guests