[Issue] Scanned Image - poor quality

Discuss the presentation application

[Issue] Scanned Image - poor quality

Postby sanderja » Wed Jun 04, 2008 3:27 pm

I have a PowerPoint presentation that was created with pages of a training book scanned and then text boxes placed on top of it in the appropriate positions. We are converting everything to OO in our school district. A teacher approached me with this large presentation and showed me that the background image is not clear in Impress and then showed me how it looked in PowerPoint. There is a marked degradation of the quality of the scanned image in OO as opposed to .ppt. I tried scanning the images again and placing them into an Impress slide and the images are not clear at all. Will I need to scan them with a higher resolution for use in Impress? They are clear in PowerPoint so I am frustrated. Thanks in advance for any insight.
Jill
Last edited by Hagar Delest on Mon Jun 09, 2008 6:02 pm, edited 2 times in total.
Reason: tagged the thread as issue.
sanderja
 
Posts: 11
Joined: Wed Mar 12, 2008 7:54 pm

Re: Scanned Image - poor quality

Postby Phil » Wed Jun 04, 2008 3:59 pm

Jill,

you have stumbled over one of the main flaws of Impress: So far, it does not perform anti-aliasing (AA) on graphics. :(
The entire graphics system of OOo is in the process of being re-engineered so to include anti-aliased graphics, but it is scheduled for version 3.1 at the moment (originally it had been scheduled for 3.0), so it will certainly not be included in a final release before beginning of or mid 2009.

The only workaround is to export presentations to PDF files and to show them in a PDF reader in full screen mode.
Of course, in this case no animations and slide transitions are possible.

Discussion on this is going on since many years(!), and I find it very disappointing that this couldn't be adressed yet. :cry:

There have been a couple of interesting discussions about this, e.g. in the threads
Antialias and smooth lines
Anti aliasing in impress

So rescanning at higher resolution will not help. Maybe the hint on using Inkscape discussed in the second thread can help?

Kind regards,
phil
OOo 3.0.1 & DEV-3.1 • WinXP pro 32-bit + SP3 + current patches
Looking for OpenOffice-related information? Try the search engine on OpenOfficeNinja - a great tool!
My favorite extension: Alt. Find & Replace for Writer. All you need and much more...
OOo 2.4.X on Ms Windows XP
Phil
Volunteer
 
Posts: 802
Joined: Fri Nov 30, 2007 5:35 pm
Location: Germany

Re: Scanned Image - poor quality

Postby Hagar Delest » Wed Jun 04, 2008 4:09 pm

AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28893
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Scanned Image - poor quality

Postby micha137 » Wed Jun 04, 2008 4:22 pm

Hi sanderja and jill,

I agree that it is a pity, that antialiasing of vector- and pixelgraphics has not been implemented yet in open office. The degree of annoyance depends strongly on the format of the image you embed. if you embed pictures scanned in black and white or in an indexed color scale, the effect is devastating. As a workaround for now you could use an Image processing software (e.g. the gimp) to do antialiasing in the primary picture. (This may require to convert it from gif, tiff or whatever other indexed image format to e.g.*.jpg or *.png in the first place.)
In case your picture is black and white, convert it to greyscale and then shrink it. Then it will look "antialiased" without necessarily taking up more space. Try it out, usually you can shrink the pixel number substantially for the grey or rgb format without loosing quality.
In general, convert it to greyscale or rgb(from indexed or black and white), if necessary perform some smoothing, then shrink it to a smaller pixel-number.
It is some work to do if you have a lot of images to convert but if you do it properly, there will be no problem with appearance any more.

regards
micha137
OOo 3.0.X on Ubuntu 8.x
micha137
 
Posts: 33
Joined: Mon Dec 03, 2007 12:25 pm
Location: Wedel/Germany


Return to Impress

Who is online

Users browsing this forum: No registered users and 3 guests