[Solved] Impress too slow to save presentation

Discuss the presentation application

[Solved] Impress too slow to save presentation

Postby mdogruel » Sat Apr 26, 2008 1:01 pm

Hi,

Saving my Impress presentation is taking 15 minutes (not seconds!) on my Fedora 8, 64 bit laptop, while the CPU consumption remains at max (and it takes about 10% memory, out of 2GB RAM). The file size is 3.5 MB, and I have about 60 slides on it. It's also slow in switching to the next slide in presentation mode (takes about 2-3 seconds). What could be wrong? At least the file saving speed was fine yesterday, when I had fewer slides.

My linux kernel is: 2.6.24.4-64.fc8 #1 SMP

My office version is the latest that comes with Fedora 8: 2.3.0-6.14. Upgrading it to 2.4.0 might solve the problem, but 2.3 was working fine till yesterday...

Thanks!
M.
Last edited by Hagar Delest on Tue Jun 10, 2008 2:08 pm, edited 2 times in total.
Reason: tagged the thread as Solved.
mdogruel
 
Posts: 2
Joined: Sat Apr 26, 2008 12:38 pm

Re: Impress too slow to save presentation

Postby AndrewZ » Sat Apr 26, 2008 4:55 pm

1. I generally recommend not using any 64-bit version of OOo
2. I generally recommend not using any OpenOffice.org derivative, such as the one that comes with Fedora. I have been using Fedora heavily for years, and I stopped using its OOo years ago because of crashing bugs. It may have improved since then, but I am not ready to find out
3. Yes, please try OOo 2.4.0 vanilla
4. What is the resolution of the images? Assuming you are not printing, try downsampling the extraneous resolution using http://extensions.services.openoffice.o ... nMinimizer
5. Do you have other elements in your presentation other than images? Transitions? Animations? OLE objects?
<signature>
* Did you solve your problem? Do others a favor: Post the solution
* Visit OpenOffice.org Ninja (blog) and OpenOffice.org Ninja Wiki for news, previews, troubleshooting, etc.
</signature>
OOo 3.0.X on Fedora 9 + XP
User avatar
AndrewZ
Volunteer
 
Posts: 633
Joined: Mon Oct 08, 2007 1:25 am
Location: Colorado, USA

Re: Impress too slow to save presentation

Postby mdogruel » Sun Apr 27, 2008 1:18 am

Hi,

I have been already using the i586 version of OOo in my 64 bits Fedora. After I sent my first post, I thought I'd give the 64 bit version of OOo a try. But the same thing happened, i.e., the same presentation file (along with the previously created ones I tried) had an incredibly long file-saving time.

Later on, I changed the Java version that OOo uses (Tools -> Options -> Java). It was using the system-default one, which is a 64 bit Java. I selected another JRE installation I had, a 32 bit one, and the problem was gone, even under the 64 bit version of OOo! Now I can load & save my presentation file (odp or ppt) with the usual speed.

The other problem, the ~2 seconds delay when proceeding to the next slide in presentation mode, however, is still occurring. Thanks for suggesting the "presentation minimizer" extension --exactly what I was looking for. But the extension manager gave a "loading library failed" error in each of my several attempts. I guess this binary is intended for use in 32 bit OOo only. So, whenever I have free time, I'll switch back to the i586 version (or find a 64 bits minimizer), but I am currently happy with my working system, at least until I give my seminar in a couple of days:)

Cheers
M.
mdogruel
 
Posts: 2
Joined: Sat Apr 26, 2008 12:38 pm


Return to Impress

Who is online

Users browsing this forum: No registered users and 7 guests