[Solved] Open pps files in edit instead of presentation mode

Discuss the presentation application

[Solved] Open pps files in edit instead of presentation mode

Postby fpflug » Mon Oct 05, 2009 1:20 am

Good day,

Something I like in previous version of OO was that pps files were opened in the same way as ppt files, meaning not automatically as presentation.
Now, I can even edit pps files, because opening them, directly with double click on the file, or opening first OO Impress, then via File > Open, the pps files open as presentation automatically.

I'm running OO 3.1.1. (OOO310m19 build:9420)
Package: openoffice.org-core 1:3.1.1-1ubuntu-jaunty1

All under Kubuntu jaunty.

So, the question is: is there a way to edit these PPS files without starting them automatically as a presentation?

Thank you!
Last edited by fpflug on Wed Oct 07, 2009 5:23 am, edited 1 time in total.
Kubuntu 9.10 x84_64 on QuadCore 6600 - 3gb RAM
OpenOffice.org 3.1.1. (OOO310m19, Build:9420)
--
Kubuntu Netbook 9.10 i386 on Asus 1005HA
OpenOffice 3.1.1. from ubuntu packages
fpflug
 
Posts: 7
Joined: Sat Mar 08, 2008 4:33 pm
Location: Brazil

Re: Open .pps files in edit instead of presentation mode

Postby squenson » Mon Oct 05, 2009 6:04 am

Welcome to this forum, fpflug!

If you rename a .pps into .ppt, you can then edit it. Just a weak workaround, though...
LibreOffice 4.2.3.3. on Ubuntu 14.04
User avatar
squenson
Volunteer
 
Posts: 1885
Joined: Wed Jan 30, 2008 9:21 pm
Location: Lausanne, Switzerland

Re: Open .pps files in edit instead of presentation mode

Postby Hagar Delest » Mon Oct 05, 2009 1:37 pm

Weird. By default, OOo opens the pps in edit mode. The usual request is the opposite (open in slideshow). Perhaps the Ubuntu version has integrated the Impress Runner extension. You can try the Sun version instead: [Ubuntu] Installing OOo on Debian and Co.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28543
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Open .pps files in edit instead of presentation mode

Postby fpflug » Tue Oct 06, 2009 2:35 am

@ squenson

Tks for the hint. I'm in fact doing that, changing the extension.
But this is in fact what I would like to avoid, as I need to save from thunderbird to any folder and then from there open it.


@ Hagar de l'Est
I'll try to further investigate this before setting to solved, if it's not a problem.
I checked the extension manager from Impress, but I don't have the extension you mentioned.
Kubuntu 9.10 x84_64 on QuadCore 6600 - 3gb RAM
OpenOffice.org 3.1.1. (OOO310m19, Build:9420)
--
Kubuntu Netbook 9.10 i386 on Asus 1005HA
OpenOffice 3.1.1. from ubuntu packages
fpflug
 
Posts: 7
Joined: Sat Mar 08, 2008 4:33 pm
Location: Brazil

Re: Open .pps files in edit instead of presentation mode

Postby Hagar Delest » Tue Oct 06, 2009 7:59 am

fpflug wrote:I checked the extension manager from Impress, but I don't have the extension you mentioned.

It may have been included in the code itself. Ubuntu version is different. Some features added but some bugs also.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28543
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Open .pps files in edit instead of presentation mode

Postby acknak » Tue Oct 06, 2009 8:20 am

I just tried a random .pps from the web: it opens in edit mode as usual.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Open .pps files in edit instead of presentation mode

Postby r4zoli » Tue Oct 06, 2009 10:17 am

If I open pps in sun source based OOo opens in edit mode, if I open in go-oo source OOo, presentation starts and when finished OOo closes, can not open pps in edit mode, only when rename to ppt.
AOO 4.0 and LibO 4 on Win 8
Hungarian forum co-admin
User avatar
r4zoli
Volunteer
 
Posts: 2882
Joined: Mon Nov 19, 2007 8:23 pm
Location: Budapest, Hungary

Re: [Solved]Open .pps files in edit instead of presentation mode

Postby fpflug » Wed Oct 07, 2009 5:23 am

Solved installing the OO as instructed in this post.
Kubuntu 9.10 x84_64 on QuadCore 6600 - 3gb RAM
OpenOffice.org 3.1.1. (OOO310m19, Build:9420)
--
Kubuntu Netbook 9.10 i386 on Asus 1005HA
OpenOffice 3.1.1. from ubuntu packages
fpflug
 
Posts: 7
Joined: Sat Mar 08, 2008 4:33 pm
Location: Brazil

Re: [Solved] Open pps files in edit instead of presentation mode

Postby zzarko » Thu Nov 26, 2009 6:48 pm

I have the same problem and I solved it with this script. It's brute-force solution (temporarily renames pps to ppt), but it works.
Code: Select all   Expand viewCollapse view
#!/bin/bash
#script to open pps files in edit mode in Ubuntu
#script contains code found on several places on the internet and can handle only one parameter (file)

fullpath=$1
filename="${fullpath##*/}"                      # Strip longest match of */ from start
dir="${fullpath:0:${#fullpath} - ${#filename}}" # Substring from 0 thru pos of filename
base="${filename%.[^.]*}"                       # Strip shortest match of . plus at least one non-dot char from end
ext="${filename:${#base} + 1}"                  # Substring from len of base thru end
if [[ -z "$base" && -n "$ext" ]]; then          # If we have an extension and no base, it's really the base
    base=".$ext"
    ext=""
fi
extnew=$ext
if [ "$ext" == "pps" ] || [ "$ext" == "PPS" ]; then
   extnew="ppt"
fi
if [ "$dir" == "" ]; then
   dir="."
fi
oldname="$dir/$filename"
newname="$dir/$base.$extnew"
mv "$oldname" "$newname"
ooimpress "$newname"
mv "$newname" "$oldname"

Save it as ooimpress-noshow, do
Code: Select all   Expand viewCollapse view
chmod a+x ooimpress-noshow

and open your pps files with it. You can change association globally (from Properties on pps file), or (probably better) just for some programs in their local preferences (Thunderbird, Firefox, ...).
zzarko
 
Posts: 6
Joined: Sat Dec 22, 2007 5:11 pm

Re: [Solved] Open pps files in edit instead of presentation mode

Postby danielias » Wed Dec 16, 2009 8:48 pm

Much like fpflug, I hate .pps files opening automatically in presentation mode. Mainly because of those "elaborated" presentations coming via e-mail, with the letters falling down from the top of the page - one at a time - to form frases (argh!)
The solution below worked fine for me. Try it.

The command ooimpress has the -n option:
# ooimpress -n filename
which is intended to create/edit a new file, using filename as a template.
To all intents and purposes, it is the same of opening filename in edition mode.

So, just create a shell script named ooimpress-edit (or whatever) containing:

#!/bin/bash
ooimpress -n "$*"
exit

# The special parameter $*, within double quotes,
# expands to the positional parameters, starting from one,
# as a single word, with the value of each parameter separated
# by white space (the first character of the IFS special variable).
# It is necessary if the passed file name has spaces.

As root, save this file to /usr/local/bin (which should be in your $PATH).
Don't forget to make it executable! (I mention it because I always do...)

Then edit the "file associations" (mime types) and include ooimpress-edit as the first option to open .pps files.
Of course, do the same in your e-mail client (in Thunderbird: Preferences->Attachments->View & Edit Actions...).

Cheers
OpenOffice 3.1 on Kubuntu 9.10
danielias
 
Posts: 2
Joined: Wed Dec 16, 2009 6:25 pm

Re: [Solved] Open pps files in edit instead of presentation

Postby wasteofspace » Wed Mar 31, 2010 4:57 pm

Thank you so much for that solution, It has been annoying me for ages. :D :D
OpenOffice 3.1 on Ubuntu 9.04
wasteofspace
 
Posts: 1
Joined: Wed Mar 31, 2010 4:53 pm

Re: [Solved] Open pps files in edit instead of presentation

Postby danielias » Wed Mar 31, 2010 6:36 pm

wasteofspace wrote:Thank you so much for that solution, It has been annoying me for ages. :D :D

My pleasure...
OpenOffice 3.1 on Kubuntu 9.10
danielias
 
Posts: 2
Joined: Wed Dec 16, 2009 6:25 pm


Return to Impress

Who is online

Users browsing this forum: No registered users and 2 guests