Page 1 of 1

Artifact during presentation: borders around images

PostPosted: Thu Jan 08, 2009 2:02 am
by gurkesaft
Hello,

When I switched from Windows XP to Eeebuntu (a 8.10 variant), I noticed an artifact in Impress.

While designing a slide, the images I've pasted in look just fine, and antialiased. Then I go to presentation mode, a thin, 1-pixel border appears around the images, with different degrees of darkness, randomly.

I believe this could be due to the antialiasing in presentation mode (a new feature in version 3). All the lines and vector graphics look great!

I've also tried a few settings in compiz like bicubic filtering but it looks the same.

I'm running Eeebuntu on an Asus eee 1000, with compiz enabled (I don't know how to disable it in this version of linux).

Anyone experience this? Know a solution?

Should this be a bug?

Cheers!
Jack

Re: Artifact during presentation: borders around images

PostPosted: Thu Jan 08, 2009 2:02 am
by gurkesaft
(I've also tried adding a white border to the images, but that seems to be drawn outside the image and doesn't cover up the artifact line.)

Re: Artifact during presentation: borders around images

PostPosted: Sat Jan 10, 2009 1:33 am
by gurkesaft
Okay, if I turn off "use hardware" in the presentation preferences, the images look good again, but then all the vector graphics look like garbage (no antialiasing).

I have a hackjob around it, a macro I wrote to auto-crop the images:

Code: Select all   Expand viewCollapse view
Sub QuickCrop

' Get the image
selection = thisComponent.getCurrentSelection()

' Crop from all edges
img = selection(0)
crop = img.GraphicCrop
crop.Right  = crop.Right+25
crop.Top    = crop.Right+25
crop.Bottom = crop.Right+25
crop.Left   = crop.Right+25
img.GraphicCrop = crop

End Sub

Sub UnCrop

' Get the image
selection = thisComponent.getCurrentSelection()

' Crop from all edges
img = selection(0)
crop = img.GraphicCrop
crop.Right  = 0
crop.Top    = 0
crop.Bottom = 0
crop.Left   = 0
img.GraphicCrop = crop

End Sub


... bound to F12 and shift-F12. This gets rid of the border usually in one step. I'm pretty sure the crop function is using a mask on top of the image. With it set to 0 some of some black background is leaking through I think.

This could be a hardware/driver issue as I'm using an integrated video chip. Compiz and other shininess work just fine though.

Anyone see similar artifacts? Have any ideas?

Thanks,
Jack

Re: Artifact during presentation: borders around images

PostPosted: Tue Feb 03, 2009 10:56 pm
by RainCT
Hey,

I have the same problem (Ubuntu Intrepid with OpenOffice.org 3.0 from the official PPA. In case it matters, I have an NVIDIA GeForce 9600M GT and I'm using the latest version of the proprietary driver -glx 180-) :(. This didn't happen with OpenOffice.org 2.

Re: Artifact during presentation: borders around images

PostPosted: Tue Feb 03, 2009 11:07 pm
by RainCT
This problem has also been mentioned here: http://www.oooforum.org/forum/viewtopic.phtml?t=77989

Re: Artifact during presentation: borders around images

PostPosted: Thu Feb 26, 2009 1:24 pm
by uweschi
I also have the same problem. It appeared when I updated to OOo 3.0. Unfortunately, a downgrade is also no option, since Impress 2.4 also has tons of bugs. I attached a screenshot to illustrate the issue.

As far as I understand the hackjob, you need to press F12 to get rid of the lines, am I getting this correctly? Has anyone else found a way around? Should someone file a bug report?

Re: Artifact during presentation: borders around images

PostPosted: Wed Apr 22, 2009 9:21 pm
by bae22
I too have this problem (Ubuntu 8.10 64bit, OOo 3.0.1, Nvidia graphics driver) and it has been driving me mad for ages. Turning off hardware acceleration is not really an option as it makes the graphics look terrible.

Finally tonight I have spotted a sort of workaround - I noticed that only some graphical elements got the nasty borders. It is only where the borders of two graphical elements overlap that you get these artifacts. By moving them apart slightly so they do not overlap gets rid of the borders.

I know it is not a full solution, but it may allow some people to avoid the problem with careful layout of your slides.

Hope this helps some people until the bug is fixed.

Ben

Re: Artifact during presentation: borders around images

PostPosted: Mon May 04, 2009 3:47 pm
by darkmire
This looks like an Ubuntu thing as I just don't get the problem using SuSE 10.3 or Windows XP. If you have this problem, do you also get the same using Firefox 3 when viewing images that have been resized? If it is, then you'll be sad to know that nobody seems to have thought of a workaround to that either. I've posted to the Ubuntu Forums on this one too.

Re: Artifact during presentation: borders around images

PostPosted: Tue May 05, 2009 1:29 pm
by rondina
I've came across the same problem on openSUSE 11.1 with the OOo version that has been shipped within. I even tried creating a new fresh presentation and only added one slide with a 100x100 white jpeg file. When I went to presentation mode (slide show, F5) I was able to see the thin gray border around the image. Have anyone found a workaround for this yet? Does the macro posted by gurkesaft work? My graphic card is a nVidia GTX280 with nVidia's driver version x86_64-180.22. The OOo I'm using is OpenOffice.org 3.0.0 OOO3m21 (Build:9319).

Re: Artifact during presentation: borders around images

PostPosted: Tue May 05, 2009 4:44 pm
by uweschi
Openoffice.org 3.1 is supposed to come out in about two days. I guess, the best thing for the moment is wait and see, if the bug has been fixed there...

Re: Artifact during presentation: borders around images

PostPosted: Sat Sep 05, 2009 9:11 am
by James70
Hi

I fell on this post after looking for a solution to the same problem. I'm using Openoffice 3.1 on Ubuntu and had the same annoying border in Impress. I've found a workaround by changing the background from white to transparent with the Gimp. This works perfectly and the border has disappeared.
Hope this helps someone.

James

Re: Artifact during presentation: borders around images

PostPosted: Wed Oct 21, 2009 10:36 pm
by micha137
Hi all,
this seems to be a bug of the intermediate Openoffice-Version 3.1 that comes with ubuntu intrepid. The newest OO-version from the OO-website doesn't have this bug any more. If you install that one in place of the repository version however, you exchange this bug against some other one's that do not occur in the ubuntu version ;-)
The choice is Yours: Have the funny frames around images and be able to insert and play videos in the presentation or else have clean images but forget videos and observe funny effects when animating text in front of a gradient background.

Seriously - just be a little patient, the problem will be gone soon.

regards
micha137

Re: Artifact during presentation: borders around images

PostPosted: Wed Nov 18, 2009 9:05 pm
by linsalrob
Try selecting the image, and setting it to 1% transparency in OO (from the picture toolbar). This does not affect the image noticeably, but does remove the line.

Re: Artifact during presentation: borders around images

PostPosted: Fri Apr 30, 2010 4:48 am
by pgn674
linsalrob wrote:Try selecting the image, and setting it to 1% transparency in OO (from the picture toolbar). This does not affect the image noticeably, but does remove the line.
Worked wonderfully :D Thanks for the awesome work-around!

Re: Artifact during presentation: borders around images

PostPosted: Sat May 12, 2012 4:39 pm
by russelliitb
Thank you so much linsalrob ...