[Solved+Issue] Premature Bullets from 4.0 and Above

Discuss the presentation application

[Solved+Issue] Premature Bullets from 4.0 and Above

Postby Brak » Mon Dec 03, 2018 3:54 am

Ok, after upgrading to 4.0 my impress slides don't work right.
I am running in macOS Sierra 10.12.1

In versions earlier than 3.3.0, the bullets show up with the text. Which is the expected behavior.

However in 3.3.0 and above the bullet shows up before the text. So to explain:
When I move to a slide, instead of being blank (as it used to be) it has the bullet with out the text.
When you click the text appears, along with the bullet for the NEXT line - but without the text of that bullet.

I have tried every version of 4.x and its does the same thing.

So in summery: all versions from 2.4 to 3.0.0 works as expected. All version of 3.3.0 - 4.x has this premature bullet issue.

I'm hoping there is a "Default" setting that is causing this that I can simply turn off.


Thanks in advance.
Last edited by Hagar Delest on Mon Dec 10, 2018 9:17 am, edited 1 time in total.
Reason: tagged solved
OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: Premature Bullets from 4.0 and Above

Postby Brak » Tue Dec 04, 2018 4:10 am

As requested here is a sample Impress file, along with video clips showing its behavior in 3.0.0 (which works) and 4.1.5 (which doesn't).
Attachments

[ Play Quicktime file ] Test 4.1.5.mp4 [ 112.71 KiB | Viewed 312 times ]

[ Play Quicktime file ] Test 3.0.0.mp4 [ 113.48 KiB | Viewed 312 times ]

Test.odp
(14.15 KiB) Downloaded 5 times
OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: Premature Bullets from 4.0 and Above

Postby John_Ha » Tue Dec 04, 2018 12:52 pm

When I add new bulleted text it does not do it.

1. Remove the bullet formatting
2. Apply the bullet formatting.

Does it still do it?
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6009
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Premature Bullets from 4.0 and Above

Postby RoryOF » Tue Dec 04, 2018 12:59 pm

When I copied the original blank slide (no. 1) and entered text, it entered as plain text, no bullet points. The text shown on slides 2 and 3 is shown in /Format /Styles and Formatting as Outline 1 format.

 Edit: How are you selecting the text cursor to enter your text? 
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27676
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Premature Bullets from 4.0 and Above

Postby John_Ha » Tue Dec 04, 2018 1:24 pm

Rory

How do I set the Headings to Default text? I don't have the "styles pull down box" I have in Writer. The Format paintbrush in F11 Styles and formatting doesn't seem to do anything.

View > Toolbars ..., doesn't suggest anything.
Attachments
Clipboard01.gif
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6009
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Premature Bullets from 4.0 and Above

Postby John_Ha » Tue Dec 04, 2018 1:28 pm

I hate it when I answer my own question :crazy:

Select the text > Format > Default Formatting.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6009
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Premature Bullets from 4.0 and Above

Postby RoryOF » Tue Dec 04, 2018 2:34 pm

Or select the text, /Format /Styles and Formatting, second icon from left, double click Default Press the Bullets on/off button on the Text Formatting toolbar
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27676
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Premature Bullets from 4.0 and Above

Postby John_Ha » Tue Dec 04, 2018 2:52 pm

And yet another way. Select the text > right-click > Default.

Also, I found it difficult to identify what the "yellow rectangle" is. The Navigator isn't as useful as in Writer. I eventually discovered that it is presumably a "text rectangle" because selecting it caused the " T " icon in the Draw bar to be highlighted. Sometimes it did not until I placed the cursor in the text. Double clicking always highlighted the " T ".

Is there any other way to discover what it is? right-clicking gives no clue.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6009
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Premature Bullets from 4.0 and Above

Postby Brak » Wed Dec 05, 2018 12:43 am

John_Ha wrote:When I add new bulleted text it does not do it.

1. Remove the bullet formatting
2. Apply the bullet formatting.

Does it still do it?


I tried removing the bullets and re adding them - and it still does the same.
OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: Premature Bullets from 4.0 and Above

Postby Brak » Wed Dec 05, 2018 12:47 am

I want to thank everyone who has been working on this thus far!

So some questions:
So does the file exhibit the same odd behavior for you as it does for me in the 4.1.5 video I posted?
Are you trying this on Mac, as that is the OS I am having the issues with.
Out of curiosity, those trying this in Windows - does the oddness happen for you as well?
OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: Premature Bullets from 4.0 and Above

Postby John_Ha » Wed Dec 05, 2018 1:51 am

The problem is that the text is an Outline 1 style. Change it to Default Text (Highlight all the text on a slide > Format > Default formatting). Now apply the bullets.

Showing that a problem has been solved helps others searching so, if your problem is now solved, please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6009
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Premature Bullets from 4.0 and Above

Postby Brak » Wed Dec 05, 2018 2:31 am

I did as you suggested and it didn't actual work.

So after I did the "default formatting" the background turned grey.
When I tested it - it did work.
However, when I changed it to have the gradient color again the issue came back.

So to reproduce:
After you do the "default formatting":
Click at the top of the text area so that it is selected
Change "Area Style/Filling" from "None" to "Gradient"
Select a gradient (don't matter which)

Then test it, and you will see the problem comes back.

So for some reason it seems that using a gradient breaks it. (If you remove the gradient the problem goes away)
OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: Premature Bullets from 4.0 and Above

Postby Brak » Wed Dec 05, 2018 2:34 am

I did some more testing.

So using color: works
using gradient: breaks
using hatching: it does ALL kinds of weird stuff - doesn't even show the text at all, just draws lines sequentially as you click)
using bitmap: works

So it seems something is buggy here.
OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: Premature Bullets from 4.0 and Above

Postby John_Ha » Wed Dec 05, 2018 2:07 pm

I set the text to Default formatting in this file, and added the colour by a rectangle.

It works fine for me - each entire bulletted line appears as one - the bullet does not appear before the text appears.
Attachments
Test_repaired.odp
(17.49 KiB) Downloaded 3 times
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6009
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Premature Bullets from 4.0 and Above

Postby Brak » Wed Dec 05, 2018 8:36 pm

I checked out the file you submitted - but the text isn't inside the box, which is how I need it to be.

I am uploading two more videos.
One shows what happens when I toggle between color and gradient, the other when I toggle between color and hatching.
(Sorry for the poor video quality, as these clips are longer I needed significantly lower the quality to get them to fit in the 128KiB limit)

So it is clear that some bug was introduced sometime after 3.0.0, in which text inside a box doesn't work anymore when using a gradient or hatching.
Attachments

[ Play Quicktime file ] Hatching.mp4 [ 127.12 KiB | Viewed 188 times ]

[ Play Quicktime file ] Gradient.mp4 [ 111.51 KiB | Viewed 188 times ]

OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: Premature Bullets from 4.0 and Above

Postby John_Ha » Thu Dec 06, 2018 12:35 am

Brak wrote:I checked out the file you submitted - but the text isn't inside the box, which is how I need it to be.


Resize the box.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6009
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Premature Bullets from 4.0 and Above

Postby Brak » Thu Dec 06, 2018 2:24 am

Sorry if I didn't explain it well.
I mean I need the text to be part of the box - so that if I move the box, the text inside moves with it.

This is how I have all my slides set up - as this is how the template I first started with had it.


So question, by us talking about it here - is the dev team aware of this bug, or do I need to contact them elsewhere to report it?
If I still need to report it, where do I do so.


Once again, I appreciate all the help with this!
OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: Premature Bullets from 4.0 and Above

Postby robleyd » Thu Dec 06, 2018 2:39 am

Developers don't visit here so you'll need to use the formal reporting process - [Tutorial] Reporting bugs or suggestions. You might search on the reporting site just in case something has already been reported. Note you will need to create an account there to submit a report.
Cheers
David
Apache OpenOffice 4.1.6 - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 2264
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Premature Bullets from 4.0 and Above

Postby Brak » Thu Dec 06, 2018 9:26 pm

robleyd wrote:Developers don't visit here so you'll need to use the formal reporting process - [Tutorial] Reporting bugs or suggestions. You might search on the reporting site just in case something has already been reported. Note you will need to create an account there to submit a report.


Thanks! I reported it.

For the mean time, I have decided to just change my slides from using the yellow gradient to just color yellow 4. Doesn't look as nice - but it get the job done with minimal modifications.

I'll try to keep you all abreast of the progress of the support ticket.


And you all again for all the help!!!
OpenOffice 2.4.3 on WinXP
OpenOffice (trying 4.x and 3.x) on macOS Sierra 10.12.1
Brak
 
Posts: 48
Joined: Sun Dec 29, 2013 11:37 am

Re: [Solved+Issue] Premature Bullets from 4.0 and Above

Postby robleyd » Mon Dec 10, 2018 10:12 am

Issue report can be seen here
Cheers
David
Apache OpenOffice 4.1.6 - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 2264
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia


Return to Impress

Who is online

Users browsing this forum: Google Feedfetcher and 1 guest